Login
Newsletter
Werbung

Sicherheit: Pufferüberlauf in patch
Aktuelle Meldungen Distributionen
Name: Pufferüberlauf in patch
ID: FEDORA-2018-17f2d1f30c
Distribution: Fedora
Plattformen: Fedora 28
Datum: Fr, 21. Dezember 2018, 07:17
Referenzen: http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-17942
Applikationen: patch

Originalnachricht

-------------------------------------------------------------------------------
-
Fedora Update Notification
FEDORA-2018-17f2d1f30c
2018-12-21 05:52:07.257851
-------------------------------------------------------------------------------
-

Name : patch
Product : Fedora 28
Version : 2.7.6
Release : 8.fc28
URL : http://www.gnu.org/software/patch/patch.html
Summary : Utility for modifying/upgrading files
Description :
The patch program applies diff files to originals. The diff command
is used to compare an original to a changed file. Diff lists the
changes made to the file. A person who has the original file can then
use the patch command with the diff file to add the changes to their
original file (patching the file).

Patch should be installed because it is a common way of upgrading
applications.

-------------------------------------------------------------------------------
-
Update Information:

- CVE-2018-17942, gnulib: heap-based buffer overflow - Added virtual provides
for bundled gnulib library
-------------------------------------------------------------------------------
-
ChangeLog:

* Mon Nov 26 2018 Than Ngo <than@redhat.com> - 2.7.6-8
- Added virtual provides for bundled gnulib library
- Fixed CVE-2018-17942, gnulib: heap-based buffer overflow
* Thu Oct 11 2018 Than Ngo <than@redhat.com> - 2.7.6-7
- Fixed #1582675 - Patch can be crashed and coredumped with a trivial wrong
command
* Wed Aug 15 2018 Than Ngo <than@redhat.com> - 2.7.6-6
- Fixed #1554752 - Double free of memory, CVE-2018-6952
* Fri Jul 13 2018 Fedora Release Engineering <releng@fedoraproject.org> -
2.7.6-5
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
* Thu May 3 2018 Tim Waugh <twaugh@redhat.com> - 2.7.6-4
- Fixed CVE-2018-1000156 - Malicious patch files cause ed to execute arbitrary
commands.
-------------------------------------------------------------------------------
-

This update can be installed with the "dnf" update program. Use
su -c 'dnf upgrade --advisory FEDORA-2018-17f2d1f30c' at the command
line. For more information, refer to the dnf documentation available at
http://dnf.readthedocs.io/en/latest/command_ref.html#upgrade-command-label

All packages are signed with the Fedora Project GPG key. More details on the
GPG keys used by the Fedora Project can be found at
https://fedoraproject.org/keys
-------------------------------------------------------------------------------
-
_______________________________________________
package-announce mailing list -- package-announce@lists.fedoraproject.org
To unsubscribe send an email to package-announce-leave@lists.fedoraproject.org
Fedora Code of Conduct: https://getfedora.org/code-of-conduct.html
List Guidelines: https://fedoraproject.org/wiki/Mailing_list_guidelines
List Archives: https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org
Pro-Linux
Gewinnspiel
Neue Nachrichten
Werbung