Login
Newsletter
Werbung

Sicherheit: Mehrere Probleme in perl
Aktuelle Meldungen Distributionen
Name: Mehrere Probleme in perl
ID: openSUSE-SU-2018:4258-1
Distribution: SUSE
Plattformen: SUSE openSUSE Leap 15.0
Datum: So, 23. Dezember 2018, 12:30
Referenzen: http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-18313
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-18312
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-18314
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-18311
Applikationen: Perl

Originalnachricht

   openSUSE Security Update: Security update for perl
______________________________________________________________________________

Announcement ID: openSUSE-SU-2018:4258-1
Rating: moderate
References: #1114674 #1114675 #1114681 #1114686
Cross-References: CVE-2018-18311 CVE-2018-18312 CVE-2018-18313
CVE-2018-18314
Affected Products:
openSUSE Leap 15.0
______________________________________________________________________________

An update that fixes four vulnerabilities is now available.

Description:

This update for perl fixes the following issues:

Secuirty issues fixed:

- CVE-2018-18311: Fixed integer overflow with oversize environment
(bsc#1114674).
- CVE-2018-18312: Fixed heap-buffer-overflow write / reg_node overrun
(bsc#1114675).
- CVE-2018-18313: Fixed heap-buffer-overflow read if regex contains \0
chars (bsc#1114681).
- CVE-2018-18314: Fixed heap-buffer-overflow in regex (bsc#1114686).

This update was imported from the SUSE:SLE-15:Update update project.


Patch Instructions:

To install this openSUSE Security Update use the SUSE recommended
installation methods
like YaST online_update or "zypper patch".

Alternatively you can run the command listed for your product:

- openSUSE Leap 15.0:

zypper in -t patch openSUSE-2018-1595=1



Package List:

- openSUSE Leap 15.0 (i586 x86_64):

perl-5.26.1-lp150.6.6.1
perl-base-5.26.1-lp150.6.6.1
perl-base-debuginfo-5.26.1-lp150.6.6.1
perl-debuginfo-5.26.1-lp150.6.6.1
perl-debugsource-5.26.1-lp150.6.6.1

- openSUSE Leap 15.0 (noarch):

perl-doc-5.26.1-lp150.6.6.1

- openSUSE Leap 15.0 (x86_64):

perl-32bit-5.26.1-lp150.6.6.1
perl-32bit-debuginfo-5.26.1-lp150.6.6.1
perl-base-32bit-5.26.1-lp150.6.6.1
perl-base-32bit-debuginfo-5.26.1-lp150.6.6.1


References:

https://www.suse.com/security/cve/CVE-2018-18311.html
https://www.suse.com/security/cve/CVE-2018-18312.html
https://www.suse.com/security/cve/CVE-2018-18313.html
https://www.suse.com/security/cve/CVE-2018-18314.html
https://bugzilla.suse.com/1114674
https://bugzilla.suse.com/1114675
https://bugzilla.suse.com/1114681
https://bugzilla.suse.com/1114686

--
To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@opensuse.org
For additional commands, e-mail: opensuse-security-announce+help@opensuse.org
Pro-Linux
Gewinnspiel
Neue Nachrichten
Werbung