Login
Newsletter
Werbung

Sicherheit: Mehrere Probleme in systemd
Aktuelle Meldungen Distributionen
Name: Mehrere Probleme in systemd
ID: SUSE-SU-2019:0054-1
Distribution: SUSE
Plattformen: SUSE Linux Enterprise Server 12-SP1-LTSS
Datum: Do, 10. Januar 2019, 06:19
Referenzen: http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-15686
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-16865
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-16864
Applikationen: systemd

Originalnachricht

   SUSE Security Update: Security update for systemd
______________________________________________________________________________

Announcement ID: SUSE-SU-2019:0054-1
Rating: important
References: #1068588 #1071558 #1113665 #1120323
Cross-References: CVE-2018-15686 CVE-2018-16864 CVE-2018-16865

Affected Products:
SUSE Linux Enterprise Server 12-SP1-LTSS
______________________________________________________________________________

An update that solves three vulnerabilities and has one
errata is now available.

Description:

This update for systemd fixes the following issues:

* Fix security vulnerabilities CVE-2018-16864 and CVE-2018-16865
(bsc#1120323): Both issues were memory corruptions via
attacker-controlled alloca which could have been used to gain root
privileges by a local attacker.

* Fix security vulnerability CVE-2018-15686 (bsc#1113665): A vulnerability
in unit_deserialize of systemd used to allow an attacker to supply
arbitrary state across systemd re-execution via NotifyAccess. This could
have been used to improperly influence systemd execution and possibly
lead to root privilege escalation.

* Remedy 2048 character line-length limit in systemd-sysctl code that
would cause parser failures if /etc/sysctl.conf contained lines that
exceeded this length (bsc#1071558).

* Fix a bug in systemd's core timer code that would cause timer looping
under certain conditions, resulting in hundreds of syslog messages being
written to the journal (bsc#1068588).


Patch Instructions:

To install this SUSE Security Update use the SUSE recommended installation
methods
like YaST online_update or "zypper patch".

Alternatively you can run the command listed for your product:

- SUSE Linux Enterprise Server 12-SP1-LTSS:

zypper in -t patch SUSE-SLE-SERVER-12-SP1-2019-54=1



Package List:

- SUSE Linux Enterprise Server 12-SP1-LTSS (ppc64le s390x x86_64):

libgudev-1_0-0-210-116.19.1
libgudev-1_0-0-debuginfo-210-116.19.1
libgudev-1_0-devel-210-116.19.1
libudev-devel-210-116.19.1
libudev1-210-116.19.1
libudev1-debuginfo-210-116.19.1
systemd-210-116.19.1
systemd-debuginfo-210-116.19.1
systemd-debugsource-210-116.19.1
systemd-devel-210-116.19.1
systemd-sysvinit-210-116.19.1
typelib-1_0-GUdev-1_0-210-116.19.1
udev-210-116.19.1
udev-debuginfo-210-116.19.1

- SUSE Linux Enterprise Server 12-SP1-LTSS (s390x x86_64):

libgudev-1_0-0-32bit-210-116.19.1
libgudev-1_0-0-debuginfo-32bit-210-116.19.1
libudev1-32bit-210-116.19.1
libudev1-debuginfo-32bit-210-116.19.1
systemd-32bit-210-116.19.1
systemd-debuginfo-32bit-210-116.19.1

- SUSE Linux Enterprise Server 12-SP1-LTSS (noarch):

systemd-bash-completion-210-116.19.1


References:

https://www.suse.com/security/cve/CVE-2018-15686.html
https://www.suse.com/security/cve/CVE-2018-16864.html
https://www.suse.com/security/cve/CVE-2018-16865.html
https://bugzilla.suse.com/1068588
https://bugzilla.suse.com/1071558
https://bugzilla.suse.com/1113665
https://bugzilla.suse.com/1120323

_______________________________________________
sle-security-updates mailing list
sle-security-updates@lists.suse.com
http://lists.suse.com/mailman/listinfo/sle-security-updates
Pro-Linux
Unterstützer werden
Neue Nachrichten
Werbung