Login
Newsletter
Werbung

Sicherheit: Zwei Probleme in haproxy
Aktuelle Meldungen Distributionen
Name: Zwei Probleme in haproxy
ID: openSUSE-SU-2019:0044-1
Distribution: SUSE
Plattformen: SUSE openSUSE Leap 15.0
Datum: Sa, 12. Januar 2019, 12:56
Referenzen: http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-20103
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-20102
Applikationen: HAproxy

Originalnachricht

   openSUSE Security Update: Security update for haproxy
______________________________________________________________________________

Announcement ID: openSUSE-SU-2019:0044-1
Rating: important
References: #1119368 #1119419
Cross-References: CVE-2018-20102 CVE-2018-20103
Affected Products:
openSUSE Leap 15.0
______________________________________________________________________________

An update that fixes two vulnerabilities is now available.

Description:

This update for haproxy to version 1.8.15 fixes the following issues:

Security issues fixed:

- CVE-2018-20102: Fixed an out-of-bounds read in
dns_validate_dns_response(), which allowed for memory disclosure
(bsc#1119368)
- CVE-2018-20103: Fixed an infinite recursion via crafted packet allows
stack exhaustion and denial of service (bsc#1119419)

Other notable bug fixes:

- Fix off-by-one write in dns_validate_dns_response()
- Fix out-of-bounds read via signedness error in
dns_validate_dns_response()
- Prevent out-of-bounds read in dns_validate_dns_response()
- Prevent out-of-bounds read in dns_read_name()
- Prevent stack-exhaustion via recursion loop in dns_read_name

For a full list of changes, please refer to:
https://www.haproxy.org/download/1.8/src/CHANGELOG

This update was imported from the SUSE:SLE-15:Update update project.


Patch Instructions:

To install this openSUSE Security Update use the SUSE recommended
installation methods
like YaST online_update or "zypper patch".

Alternatively you can run the command listed for your product:

- openSUSE Leap 15.0:

zypper in -t patch openSUSE-2019-44=1



Package List:

- openSUSE Leap 15.0 (x86_64):

haproxy-1.8.15~git0.6b6a350a-lp150.2.6.1
haproxy-debuginfo-1.8.15~git0.6b6a350a-lp150.2.6.1
haproxy-debugsource-1.8.15~git0.6b6a350a-lp150.2.6.1


References:

https://www.suse.com/security/cve/CVE-2018-20102.html
https://www.suse.com/security/cve/CVE-2018-20103.html
https://bugzilla.suse.com/1119368
https://bugzilla.suse.com/1119419

--
To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@opensuse.org
For additional commands, e-mail: opensuse-security-announce+help@opensuse.org
Pro-Linux
Pro-Linux @Facebook
Neue Nachrichten
Werbung