Login
Newsletter
Werbung

Sicherheit: Mehrere Probleme in ntpsec
Aktuelle Meldungen Distributionen
Name: Mehrere Probleme in ntpsec
ID: openSUSE-SU-2019:0082-1
Distribution: SUSE
Plattformen: SUSE openSUSE Leap 15.0
Datum: Do, 24. Januar 2019, 07:21
Referenzen: https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-6444
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-6443
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-6442
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-6445
Applikationen: ntpsec

Originalnachricht

   openSUSE Security Update: Security update for ntpsec
______________________________________________________________________________

Announcement ID: openSUSE-SU-2019:0082-1
Rating: important
References: #1122131 #1122132 #1122134 #1122144
Cross-References: CVE-2019-6442 CVE-2019-6443 CVE-2019-6444
CVE-2019-6445
Affected Products:
openSUSE Leap 15.0
______________________________________________________________________________

An update that fixes four vulnerabilities is now available.

Description:

This update for ntpsec to version 1.1.3 fixes the following issues:

Security issues fixed:

- CVE-2019-6442: Fixed a out of bounds write via a malformed config
request (boo#1122132)
- CVE-2019-6443: Fixed a stack-based buffer over-read in the ctl_getitem
function (boo#1122144)
- CVE-2019-6444: Fixed a stack-based buffer over-read in the
process_control function (boo#1122134)
- CVE-2019-6445: Fixed a NULL pointer dereference in the ctl_getitem
function (boo#1122131)


Patch Instructions:

To install this openSUSE Security Update use the SUSE recommended
installation methods
like YaST online_update or "zypper patch".

Alternatively you can run the command listed for your product:

- openSUSE Leap 15.0:

zypper in -t patch openSUSE-2019-82=1



Package List:

- openSUSE Leap 15.0 (x86_64):

ntpsec-1.1.3-lp150.2.3.1
ntpsec-debuginfo-1.1.3-lp150.2.3.1
ntpsec-debugsource-1.1.3-lp150.2.3.1
ntpsec-utils-1.1.3-lp150.2.3.1
python3-ntp-1.1.3-lp150.2.3.1
python3-ntp-debuginfo-1.1.3-lp150.2.3.1


References:

https://www.suse.com/security/cve/CVE-2019-6442.html
https://www.suse.com/security/cve/CVE-2019-6443.html
https://www.suse.com/security/cve/CVE-2019-6444.html
https://www.suse.com/security/cve/CVE-2019-6445.html
https://bugzilla.suse.com/1122131
https://bugzilla.suse.com/1122132
https://bugzilla.suse.com/1122134
https://bugzilla.suse.com/1122144

--
To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@opensuse.org
For additional commands, e-mail: opensuse-security-announce+help@opensuse.org
Pro-Linux
Pro-Linux @Facebook
Neue Nachrichten
Werbung