Login
Newsletter
Werbung

Sicherheit: Zwei Probleme in python3
Aktuelle Meldungen Distributionen
Name: Zwei Probleme in python3
ID: SUSE-SU-2019:0215-1
Distribution: SUSE
Plattformen: SUSE Linux Enterprise Module for Basesystem 15, SUSE Linux Enterprise Module for Development Tools 15, SUSE Linux Enterprise Module for Open Buildservice Development Tools 15
Datum: Do, 31. Januar 2019, 23:33
Referenzen: https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-5010
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-20406
Applikationen: Python

Originalnachricht

   SUSE Security Update: Security update for python3
______________________________________________________________________________

Announcement ID: SUSE-SU-2019:0215-1
Rating: important
References: #1120644 #1122191
Cross-References: CVE-2018-20406 CVE-2019-5010
Affected Products:
SUSE Linux Enterprise Module for Open Buildservice
Development Tools 15
SUSE Linux Enterprise Module for Development Tools 15
SUSE Linux Enterprise Module for Basesystem 15
______________________________________________________________________________

An update that fixes two vulnerabilities is now available.

Description:

This update for python3 fixes the following issues:

Security issue fixed:

- CVE-2019-5010: Fixed a denial-of-service vulnerability in the X509
certificate parser (bsc#1122191)
- CVE-2018-20406: Fixed a integer overflow via a large LONG_BINPUT
(bsc#1120644)


Patch Instructions:

To install this SUSE Security Update use the SUSE recommended installation
methods
like YaST online_update or "zypper patch".

Alternatively you can run the command listed for your product:

- SUSE Linux Enterprise Module for Open Buildservice Development Tools 15:

zypper in -t patch SUSE-SLE-Module-Development-Tools-OBS-15-2019-215=1

- SUSE Linux Enterprise Module for Development Tools 15:

zypper in -t patch SUSE-SLE-Module-Development-Tools-15-2019-215=1

- SUSE Linux Enterprise Module for Basesystem 15:

zypper in -t patch SUSE-SLE-Module-Basesystem-15-2019-215=1



Package List:

- SUSE Linux Enterprise Module for Open Buildservice Development Tools 15
(aarch64 ppc64le s390x x86_64):

python3-base-debuginfo-3.6.5-3.8.1
python3-base-debugsource-3.6.5-3.8.1
python3-testsuite-3.6.5-3.8.1
python3-testsuite-debuginfo-3.6.5-3.8.1

- SUSE Linux Enterprise Module for Open Buildservice Development Tools 15
(noarch):

python3-doc-3.6.5-3.8.1

- SUSE Linux Enterprise Module for Development Tools 15 (aarch64 ppc64le
s390x x86_64):

python3-base-debuginfo-3.6.5-3.8.1
python3-base-debugsource-3.6.5-3.8.1
python3-tools-3.6.5-3.8.1

- SUSE Linux Enterprise Module for Basesystem 15 (aarch64 ppc64le s390x
x86_64):

libpython3_6m1_0-3.6.5-3.8.1
libpython3_6m1_0-debuginfo-3.6.5-3.8.1
python3-3.6.5-3.8.1
python3-base-3.6.5-3.8.1
python3-base-debuginfo-3.6.5-3.8.1
python3-base-debugsource-3.6.5-3.8.1
python3-curses-3.6.5-3.8.1
python3-curses-debuginfo-3.6.5-3.8.1
python3-dbm-3.6.5-3.8.1
python3-dbm-debuginfo-3.6.5-3.8.1
python3-debuginfo-3.6.5-3.8.1
python3-debugsource-3.6.5-3.8.1
python3-devel-3.6.5-3.8.1
python3-devel-debuginfo-3.6.5-3.8.1
python3-idle-3.6.5-3.8.1
python3-tk-3.6.5-3.8.1
python3-tk-debuginfo-3.6.5-3.8.1


References:

https://www.suse.com/security/cve/CVE-2018-20406.html
https://www.suse.com/security/cve/CVE-2019-5010.html
https://bugzilla.suse.com/1120644
https://bugzilla.suse.com/1122191

_______________________________________________
sle-security-updates mailing list
sle-security-updates@lists.suse.com
http://lists.suse.com/mailman/listinfo/sle-security-updates
Pro-Linux
Pro-Linux @Facebook
Neue Nachrichten
Werbung