Login
Newsletter
Werbung

Sicherheit: Mehrere Probleme in LibVNCServer
Aktuelle Meldungen Distributionen
Name: Mehrere Probleme in LibVNCServer
ID: SUSE-SU-2019:0283-1
Distribution: SUSE
Plattformen: SUSE Linux Enterprise Workstation Extension 15, SUSE Linux Enterprise Module for Open Buildservice Development Tools 15, SUSE Linux Enterprise Module for Packagehub Subpackages 15
Datum: Do, 7. Februar 2019, 23:02
Referenzen: https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-20748
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-20750
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-20749
Applikationen: LibVNCServer

Originalnachricht

   SUSE Security Update: Security update for LibVNCServer
______________________________________________________________________________

Announcement ID: SUSE-SU-2019:0283-1
Rating: critical
References: #1123823 #1123828 #1123832
Cross-References: CVE-2018-20748 CVE-2018-20749 CVE-2018-20750

Affected Products:
SUSE Linux Enterprise Workstation Extension 15
SUSE Linux Enterprise Module for Packagehub Subpackages 15
SUSE Linux Enterprise Module for Open Buildservice
Development Tools 15
______________________________________________________________________________

An update that fixes three vulnerabilities is now available.

Description:

This update for LibVNCServer fixes the following issues:

Security issues fixed:

- CVE-2018-20749: Fixed a heap out of bounds write vulnerability in
rfbserver.c (bsc#1123828)
- CVE-2018-20750: Fixed a heap out of bounds write vulnerability in
rfbserver.c (bsc#1123832)
- CVE-2018-20748: Fixed multiple heap out-of-bound writes in VNC client
code (bsc#1123823)


Patch Instructions:

To install this SUSE Security Update use the SUSE recommended installation
methods
like YaST online_update or "zypper patch".

Alternatively you can run the command listed for your product:

- SUSE Linux Enterprise Workstation Extension 15:

zypper in -t patch SUSE-SLE-Product-WE-15-2019-283=1

- SUSE Linux Enterprise Module for Packagehub Subpackages 15:

zypper in -t patch SUSE-SLE-Module-Packagehub-Subpackages-15-2019-283=1

- SUSE Linux Enterprise Module for Open Buildservice Development Tools 15:

zypper in -t patch SUSE-SLE-Module-Development-Tools-OBS-15-2019-283=1



Package List:

- SUSE Linux Enterprise Workstation Extension 15 (x86_64):

LibVNCServer-debugsource-0.9.10-4.6.1
libvncclient0-0.9.10-4.6.1
libvncclient0-debuginfo-0.9.10-4.6.1

- SUSE Linux Enterprise Module for Packagehub Subpackages 15 (aarch64
ppc64le s390x x86_64):

LibVNCServer-debugsource-0.9.10-4.6.1
libvncserver0-0.9.10-4.6.1
libvncserver0-debuginfo-0.9.10-4.6.1

- SUSE Linux Enterprise Module for Open Buildservice Development Tools 15
(aarch64 ppc64le s390x x86_64):

LibVNCServer-debugsource-0.9.10-4.6.1
LibVNCServer-devel-0.9.10-4.6.1
libvncserver0-0.9.10-4.6.1
libvncserver0-debuginfo-0.9.10-4.6.1


References:

https://www.suse.com/security/cve/CVE-2018-20748.html
https://www.suse.com/security/cve/CVE-2018-20749.html
https://www.suse.com/security/cve/CVE-2018-20750.html
https://bugzilla.suse.com/1123823
https://bugzilla.suse.com/1123828
https://bugzilla.suse.com/1123832

_______________________________________________
sle-security-updates mailing list
sle-security-updates@lists.suse.com
http://lists.suse.com/mailman/listinfo/sle-security-updates
Pro-Linux
Gewinnspiel
Neue Nachrichten
Werbung