Login
Newsletter
Werbung

Sicherheit: Mangelnde Prüfung von Zertifikaten in python-urllib3
Aktuelle Meldungen Distributionen
Name: Mangelnde Prüfung von Zertifikaten in python-urllib3
ID: openSUSE-SU-2019:0159-1
Distribution: SUSE
Plattformen: SUSE openSUSE Leap 42.3
Datum: Di, 12. Februar 2019, 17:23
Referenzen: https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2016-9015
Applikationen: python-urllib3

Originalnachricht

   openSUSE Security Update: Security update for python-urllib3
______________________________________________________________________________

Announcement ID: openSUSE-SU-2019:0159-1
Rating: moderate
References: #1024540 #1074247 #1110422
Cross-References: CVE-2016-9015
Affected Products:
openSUSE Leap 42.3
______________________________________________________________________________

An update that solves one vulnerability and has two fixes
is now available.

Description:

This update for python-urllib3 fixes the following issues:

python-urllib3 was updated to version 1.22 (fate#326733, bsc#1110422) and
contains new features and lots of bugfixes:

The full changelog can be found on:

https://github.com/Lukasa/urllib3/blob/1.22/CHANGES.rst

Security issues fixed:

- CVE-2016-9015: TLS certificate validation vulnerability (bsc#1024540).
(This issue did not affect our previous version 1.16.)

Non security issues fixed:

- bsc#1074247: Fix test suite, use correct date (gh#shazow/urllib3#1303).

This update was imported from the SUSE:SLE-12-SP1:Update update project.


Patch Instructions:

To install this openSUSE Security Update use the SUSE recommended
installation methods
like YaST online_update or "zypper patch".

Alternatively you can run the command listed for your product:

- openSUSE Leap 42.3:

zypper in -t patch openSUSE-2019-159=1



Package List:

- openSUSE Leap 42.3 (noarch):

python-urllib3-1.22-4.4.1
python3-urllib3-1.22-4.4.1


References:

https://www.suse.com/security/cve/CVE-2016-9015.html
https://bugzilla.suse.com/1024540
https://bugzilla.suse.com/1074247
https://bugzilla.suse.com/1110422

--
To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@opensuse.org
For additional commands, e-mail: opensuse-security-announce+help@opensuse.org
Pro-Linux
Pro-Linux @Facebook
Neue Nachrichten
Werbung