Login
Newsletter
Werbung

Sicherheit: Mehrere Probleme in mosquitto
Aktuelle Meldungen Distributionen
Name: Mehrere Probleme in mosquitto
ID: openSUSE-SU-2019:0233-1
Distribution: SUSE
Plattformen: SUSE openSUSE Leap 15.0
Datum: Fr, 22. Februar 2019, 21:02
Referenzen: https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-12550
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-12551
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-12546
Applikationen: Mosquitto

Originalnachricht

   openSUSE Security Update: Security update for mosquitto
______________________________________________________________________________

Announcement ID: openSUSE-SU-2019:0233-1
Rating: low
References: #1125019 #1125020 #1125021
Cross-References: CVE-2018-12546 CVE-2018-12550 CVE-2018-12551

Affected Products:
openSUSE Leap 15.0
______________________________________________________________________________

An update that fixes three vulnerabilities is now available.

Description:

This update for mosquitto fixes the following issues:

Security issues fixed:

- CVE-2018-12546: Fixed an issue with revoked access to topics
(bsc#1125019).
- CVE-2018-12551: Fixed an issue which allowed malformed data in the
password file to be treated as valid (bsc#1125020).
- CVE-2018-12550: Fixed an an issue which treats an empty ACL file
wrongly (bsc#1125021).


Patch Instructions:

To install this openSUSE Security Update use the SUSE recommended
installation methods
like YaST online_update or "zypper patch".

Alternatively you can run the command listed for your product:

- openSUSE Leap 15.0:

zypper in -t patch openSUSE-2019-233=1



Package List:

- openSUSE Leap 15.0 (x86_64):

libmosquitto1-1.4.15-lp150.2.3.1
libmosquitto1-debuginfo-1.4.15-lp150.2.3.1
libmosquittopp1-1.4.15-lp150.2.3.1
libmosquittopp1-debuginfo-1.4.15-lp150.2.3.1
mosquitto-1.4.15-lp150.2.3.1
mosquitto-clients-1.4.15-lp150.2.3.1
mosquitto-clients-debuginfo-1.4.15-lp150.2.3.1
mosquitto-debuginfo-1.4.15-lp150.2.3.1
mosquitto-debugsource-1.4.15-lp150.2.3.1
mosquitto-devel-1.4.15-lp150.2.3.1


References:

https://www.suse.com/security/cve/CVE-2018-12546.html
https://www.suse.com/security/cve/CVE-2018-12550.html
https://www.suse.com/security/cve/CVE-2018-12551.html
https://bugzilla.suse.com/1125019
https://bugzilla.suse.com/1125020
https://bugzilla.suse.com/1125021

--
To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@opensuse.org
For additional commands, e-mail: opensuse-security-announce+help@opensuse.org
Pro-Linux
Pro-Linux @Facebook
Neue Nachrichten
Werbung