Login
Newsletter
Werbung

Sicherheit: Mehrere Probleme in xen
Aktuelle Meldungen Distributionen
Name: Mehrere Probleme in xen
ID: FEDORA-2019-bce6498890
Distribution: Fedora
Plattformen: Fedora 28
Datum: Fr, 22. März 2019, 07:41
Referenzen: https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-19961
https://bugzilla.redhat.com/show_bug.cgi?id=1679321
https://bugzilla.redhat.com/show_bug.cgi?id=1679334
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-19966
https://bugzilla.redhat.com/show_bug.cgi?id=1683956
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-19962
https://bugzilla.redhat.com/show_bug.cgi?id=1679332
https://bugzilla.redhat.com/show_bug.cgi?id=1679328
https://bugzilla.redhat.com/show_bug.cgi?id=1685568
https://bugzilla.redhat.com/show_bug.cgi?id=1685570
https://bugzilla.redhat.com/show_bug.cgi?id=1679327
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-19965
https://bugzilla.redhat.com/show_bug.cgi?id=1679326
Applikationen: Xen

Originalnachricht

-------------------------------------------------------------------------------
-
Fedora Update Notification
FEDORA-2019-bce6498890
2019-03-21 21:08:05.034360
-------------------------------------------------------------------------------
-

Name : xen
Product : Fedora 28
Version : 4.10.3
Release : 2.fc28
URL : http://xen.org/
Summary : Xen is a virtual machine monitor
Description :
This package contains the XenD daemon and xm command line
tools, needed to manage virtual machines running under the
Xen hypervisor

-------------------------------------------------------------------------------
-
Update Information:

xen: various flaws (#1685577) grant table transfer issues on large hosts
[XSA-284] race with pass-through device hotplug [XSA-285] x86: steal_page
violates page_struct access discipline [XSA-287] x86: Inconsistent PV IOMMU
discipline [XSA-288] missing preemption in x86 PV page table unvalidation
[XSA-290] x86/PV: page type reference counting issue with failed IOMMU update
[XSA-291] x86: insufficient TLB flushing when using PCID [XSA-292] x86: PV
kernel context switch corruption [XSA-293] x86 shadow: Insufficient TLB
flushing
when using PCID [XSA-294] ---- update to xen-4.10.3 ---- - insufficient TLB
flushing / improper large page mappings with AMD IOMMUs [XSA-275] (#1651665) -
x86: DoS from attempting to use INVPCID with a non-canonical addresses
[XSA-279]
- Fix for XSA-240 conflicts with shadow paging [XSA-280] ---- guest use of
HLE
constructs may lock up host [XSA-282]
-------------------------------------------------------------------------------
-
ChangeLog:

* Tue Mar 5 2019 Michael Young <m.a.young@durham.ac.uk> - 4.10.3-2
- xen: various flaws (#1685577)
grant table transfer issues on large hosts [XSA-284]
race with pass-through device hotplug [XSA-285]
x86: steal_page violates page_struct access discipline [XSA-287]
x86: Inconsistent PV IOMMU discipline [XSA-288]
missing preemption in x86 PV page table unvalidation [XSA-290]
x86/PV: page type reference counting issue with failed IOMMU update [XSA-291]
x86: insufficient TLB flushing when using PCID [XSA-292]
x86: PV kernel context switch corruption [XSA-293]
x86 shadow: Insufficient TLB flushing when using PCID [XSA-294]
* Tue Feb 26 2019 Michael Young <m.a.young@durham.ac.uk> - 4.10.3-1
- update to xen-4.10.3
adjust xen.use.fedora.ipxe.patch
drop most of xen.fedora.efi.build.patch and let efi build on i686
remove patches for issues now fixed upstream
* Tue Nov 20 2018 Michael Young <m.a.young@durham.ac.uk> - 4.10.2-4
- insufficient TLB flushing / improper large page mappings with AMD IOMMUs
[XSA-275, CVE-2018-19961, CVE-2018-19962] (#1651665)
- x86: DoS from attempting to use INVPCID with a non-canonical addresses
[XSA-279, CVE-2018-19965] (#1651970)
- Fix for XSA-240 conflicts with shadow paging [XSA-280, CVE-2018-19966]
(#1652251)
* Tue Nov 6 2018 Michael Young <m.a.young@durham.ac.uk> - 4.10.2-3
- guest use of HLE constructs may lock up host [XSA-282, CVE-2018-19967]
* Thu Oct 25 2018 Michael Young <m.a.young@durham.ac.uk> - 4.10.2-2
- x86: Nested VT-x usable even when disabled [XSA-278, CVE-2018-18883]
(#1643118)
* Tue Sep 25 2018 Michael Young <m.a.young@durham.ac.uk> - 4.10.2-1
- update to xen-4.10.2
adjust xen.use.fedora.ipxe.patch
remove patches for issues now fixed upstream
* Wed Aug 15 2018 Michael Young <m.a.young@durham.ac.uk> - 4.10.1-6
- L1 Terminal Fault speculative side channel patch bundle [XSA-273,
CVE-2018-3620, CVE-2018-3646]
drop patches also in the bundle, which also includes
Use of v2 grant tables may cause crash on ARM [XSA-268, CVE-2018-15469]
(#1616081)
x86: Incorrect MSR_DEBUGCTL handling lets guests enable BTS [XSA-269,
CVE-2018-15468] (#1616077)
oxenstored does not apply quota-maxentity [XSA-272, CVE-2018-15470]
(#1616080)
* Wed Jun 27 2018 Michael Young <m.a.young@durham.ac.uk> - 4.10.1-5
- preemption checks bypassed in x86 PV MM handling [XSA-264, CVE-2018-12891]
(#1595959)
- x86: #DB exception safety check can be triggered by a guest [XSA-265,
CVE-2018-12893] (#1595958)
- libxl fails to honour readonly flag on HVM emulated SCSI disks [XSA-266,
CVE-2018-12892] (#1595957)
* Fri Jun 15 2018 Michael Young <m.a.young@durham.ac.uk> - 4.10.1-4
- Speculative register leakage from lazy FPU context switching
[XSA-267, CVE-2018-3665]
- fix for change in iasl output
* Tue May 22 2018 Michael Young <m.a.young@durham.ac.uk> - 4.10.1-3
- Speculative Store Bypass [XSA-263, CVE-2018-3639]
(with extra patches so it applies cleanly)
* Tue May 8 2018 Michael Young <m.a.young@durham.ac.uk> - 4.10.1-2
- x86: mishandling of debug exceptions [XSA-260, CVE-2018-8897]
- x86 vHPET interrupt injection errors [XSA-261, CVE-2018-10982] (#1576089)
- qemu may drive Xen into unbounded loop [XSA-262, CVE-2018-10981] (#1576680)
* Thu May 3 2018 Michael Young <m.a.young@durham.ac.uk> - 4.10.1-1
- update to xen-4.10.1
adjust xen.use.fedora.ipxe.patch and xen.fedora.efi.build.patch
remove patches for issues now fixed upstream
package /usr/lib/debug/usr/lib/xen/boot/xen-shim-syms
* Wed Apr 25 2018 Michael Young <m.a.young@durham.ac.uk> - 4.10.0-9
- Information leak via crafted user-supplied CDROM [XSA-258, CVE-2018-10472]
(#1571867)
- x86: PV guest may crash Xen with XPTI [XSA-259, CVE-2018-10471] (#1571878)
-------------------------------------------------------------------------------
-
References:

[ 1 ] Bug #1679321 - xen: xsa288: Inconsistent PV IOMMU discipline
https://bugzilla.redhat.com/show_bug.cgi?id=1679321
[ 2 ] Bug #1679326 - xen: xsa292: insufficient TLB flushing when using PCID
https://bugzilla.redhat.com/show_bug.cgi?id=1679326
[ 3 ] Bug #1679327 - xen: xsa293: PV kernel context switch corruption
https://bugzilla.redhat.com/show_bug.cgi?id=1679327
[ 4 ] Bug #1679328 - xen: xsa287: steal_page violates page_struct access
discipline
https://bugzilla.redhat.com/show_bug.cgi?id=1679328
[ 5 ] Bug #1679332 - xen: xsa285: race with pass-through device hotplug
https://bugzilla.redhat.com/show_bug.cgi?id=1679332
[ 6 ] Bug #1679334 - xen: xsa290: missing preemption in x86 PV page table
unvalidation
https://bugzilla.redhat.com/show_bug.cgi?id=1679334
[ 7 ] Bug #1683956 - xen: xsa294: Insufficient TLB flushing when using PCID
https://bugzilla.redhat.com/show_bug.cgi?id=1683956
[ 8 ] Bug #1685568 - xen: xsa284: grant table transfer issues on large hosts
https://bugzilla.redhat.com/show_bug.cgi?id=1685568
[ 9 ] Bug #1685570 - xen: xsa291: x86/PV: page type reference counting issue
with failed IOMMU update
https://bugzilla.redhat.com/show_bug.cgi?id=1685570
[ 10 ] Bug #1647573 - CVE-2018-19961 CVE-2018-19962 xen: insufficient TLB
flushing / improper large page mappings with AMD IOMMUs
https://bugzilla.redhat.com/show_bug.cgi?id=1647573
[ 11 ] Bug #1647588 - CVE-2018-19965 xen: x86: DoS from attempting to use
INVPCID with a non-canonical addresses
https://bugzilla.redhat.com/show_bug.cgi?id=1647588
[ 12 ] Bug #1652235 - CVE-2018-19966 xsa280 xen: Conflicts with shadow paging
due to XSA-240 incomplete fix (XSA-280)
https://bugzilla.redhat.com/show_bug.cgi?id=1652235
-------------------------------------------------------------------------------
-

This update can be installed with the "dnf" update program. Use
su -c 'dnf upgrade --advisory FEDORA-2019-bce6498890' at the command
line. For more information, refer to the dnf documentation available at
http://dnf.readthedocs.io/en/latest/command_ref.html#upgrade-command-label

All packages are signed with the Fedora Project GPG key. More details on the
GPG keys used by the Fedora Project can be found at
https://fedoraproject.org/keys
-------------------------------------------------------------------------------
-
_______________________________________________
package-announce mailing list -- package-announce@lists.fedoraproject.org
To unsubscribe send an email to package-announce-leave@lists.fedoraproject.org
Fedora Code of Conduct: https://getfedora.org/code-of-conduct.html
List Guidelines: https://fedoraproject.org/wiki/Mailing_list_guidelines
List Archives: https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org
Pro-Linux
Pro-Linux @Facebook
Neue Nachrichten
Werbung