Login
Newsletter
Werbung

Sicherheit: Pufferüberlauf in webkit2gtk3
Aktuelle Meldungen Distributionen
Name: Pufferüberlauf in webkit2gtk3
ID: SUSE-SU-2019:0890-1
Distribution: SUSE
Plattformen: SUSE Linux Enterprise Module for Basesystem 15, SUSE Linux Enterprise Module for Desktop Applications 15, SUSE Linux Enterprise Module for Open Buildservice Development Tools 15
Datum: Fr, 5. April 2019, 23:57
Referenzen: https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-8375
Applikationen: webkit2gtk3

Originalnachricht


SUSE Security Update: Security update for webkit2gtk3
______________________________________________________________________________

Announcement ID: SUSE-SU-2019:0890-1
Rating: moderate
References: #1126768
Cross-References: CVE-2019-8375
Affected Products:
SUSE Linux Enterprise Module for Open Buildservice
Development Tools 15
SUSE Linux Enterprise Module for Desktop Applications 15
SUSE Linux Enterprise Module for Basesystem 15
______________________________________________________________________________

An update that fixes one vulnerability is now available.

Description:

This update for webkit2gtk3 to version 2.24.0 fixes the following issue:

Security issue fixed:

- CVE-2019-8375: Fixed an issue in UIProcess subsystem which could allow
the script dialog size to exceed the web view size leading to Buffer
Overflow or other unspecified impact (bsc#1126768).


Patch Instructions:

To install this SUSE Security Update use the SUSE recommended installation
methods
like YaST online_update or "zypper patch".

Alternatively you can run the command listed for your product:

- SUSE Linux Enterprise Module for Open Buildservice Development Tools 15:

zypper in -t patch SUSE-SLE-Module-Development-Tools-OBS-15-2019-890=1

- SUSE Linux Enterprise Module for Desktop Applications 15:

zypper in -t patch SUSE-SLE-Module-Desktop-Applications-15-2019-890=1

- SUSE Linux Enterprise Module for Basesystem 15:

zypper in -t patch SUSE-SLE-Module-Basesystem-15-2019-890=1



Package List:

- SUSE Linux Enterprise Module for Open Buildservice Development Tools 15
(aarch64 ppc64le s390x x86_64):

webkit-jsc-4-2.24.0-3.21.1
webkit-jsc-4-debuginfo-2.24.0-3.21.1
webkit2gtk3-debugsource-2.24.0-3.21.1

- SUSE Linux Enterprise Module for Desktop Applications 15 (aarch64 ppc64le
s390x x86_64):

typelib-1_0-JavaScriptCore-4_0-2.24.0-3.21.1
typelib-1_0-WebKit2-4_0-2.24.0-3.21.1
typelib-1_0-WebKit2WebExtension-4_0-2.24.0-3.21.1
webkit2gtk3-debugsource-2.24.0-3.21.1
webkit2gtk3-devel-2.24.0-3.21.1

- SUSE Linux Enterprise Module for Basesystem 15 (aarch64 ppc64le s390x
x86_64):

libjavascriptcoregtk-4_0-18-2.24.0-3.21.1
libjavascriptcoregtk-4_0-18-debuginfo-2.24.0-3.21.1
libwebkit2gtk-4_0-37-2.24.0-3.21.1
libwebkit2gtk-4_0-37-debuginfo-2.24.0-3.21.1
webkit2gtk-4_0-injected-bundles-2.24.0-3.21.1
webkit2gtk-4_0-injected-bundles-debuginfo-2.24.0-3.21.1
webkit2gtk3-debugsource-2.24.0-3.21.1

- SUSE Linux Enterprise Module for Basesystem 15 (noarch):

libwebkit2gtk3-lang-2.24.0-3.21.1


References:

https://www.suse.com/security/cve/CVE-2019-8375.html
https://bugzilla.suse.com/1126768

_______________________________________________
sle-security-updates mailing list
sle-security-updates@lists.suse.com
http://lists.suse.com/mailman/listinfo/sle-security-updates
Pro-Linux
Unterstützer werden
Neue Nachrichten
Werbung