Login
Newsletter
Werbung

Sicherheit: Zwei Probleme in ovmf
Aktuelle Meldungen Distributionen
Name: Zwei Probleme in ovmf
ID: openSUSE-SU-2019:1172-1
Distribution: SUSE
Plattformen: SUSE openSUSE Leap 15.0
Datum: Mo, 8. April 2019, 16:56
Referenzen: https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-0160
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-12181
Applikationen: OVMF

Originalnachricht

   openSUSE Security Update: Security update for ovmf
______________________________________________________________________________

Announcement ID: openSUSE-SU-2019:1172-1
Rating: moderate
References: #1128503 #1130267
Cross-References: CVE-2018-12181 CVE-2019-0160
Affected Products:
openSUSE Leap 15.0
______________________________________________________________________________

An update that fixes two vulnerabilities is now available.

Description:

This update for ovmf fixes the following issues:

Security issues fixed:

- CVE-2019-0160: Fixed multiple buffer overflows in UDF-related codes in
MdeModulePkg\Universal\Disk\PartitionDxe\Udf.c and
MdeModulePkg\Universal\Disk\UdfDxe (bsc#1130267).
- CVE-2018-12181: Fixed a stack buffer overflow in the HII database when a
corrupted Bitmap was used (bsc#1128503).

This update was imported from the SUSE:SLE-15:Update update project.


Patch Instructions:

To install this openSUSE Security Update use the SUSE recommended
installation methods
like YaST online_update or "zypper patch".

Alternatively you can run the command listed for your product:

- openSUSE Leap 15.0:

zypper in -t patch openSUSE-2019-1172=1



Package List:

- openSUSE Leap 15.0 (i586 x86_64):

ovmf-2017+git1510945757.b2662641d5-lp150.4.16.1
ovmf-tools-2017+git1510945757.b2662641d5-lp150.4.16.1

- openSUSE Leap 15.0 (noarch):

qemu-ovmf-ia32-2017+git1510945757.b2662641d5-lp150.4.16.1
qemu-ovmf-x86_64-2017+git1510945757.b2662641d5-lp150.4.16.1

- openSUSE Leap 15.0 (x86_64):

qemu-ovmf-x86_64-debug-2017+git1510945757.b2662641d5-lp150.4.16.1


References:

https://www.suse.com/security/cve/CVE-2018-12181.html
https://www.suse.com/security/cve/CVE-2019-0160.html
https://bugzilla.suse.com/1128503
https://bugzilla.suse.com/1130267

--
To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@opensuse.org
For additional commands, e-mail: opensuse-security-announce+help@opensuse.org
Pro-Linux
Traut euch!
Neue Nachrichten
Werbung