Login
Newsletter
Werbung

Sicherheit: Mehrere Probleme in gnuplot
Aktuelle Meldungen Distributionen
Name: Mehrere Probleme in gnuplot
ID: openSUSE-SU-2019:1216-1
Distribution: SUSE
Plattformen: SUSE openSUSE Leap 15.0
Datum: Di, 16. April 2019, 23:44
Referenzen: https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-19490
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-19491
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-19492
Applikationen: gnuplot

Originalnachricht

   openSUSE Security Update: Security update for gnuplot
______________________________________________________________________________

Announcement ID: openSUSE-SU-2019:1216-1
Rating: moderate
References: #1117463 #1117464 #1117465
Cross-References: CVE-2018-19490 CVE-2018-19491 CVE-2018-19492

Affected Products:
openSUSE Leap 15.0
______________________________________________________________________________

An update that fixes three vulnerabilities is now available.

Description:

This update for gnuplot fixes the following issues:

Security issues fixed:

- CVE-2018-19492: Fixed a buffer overflow in cairotrm_options function
(bsc#1117463)
- CVE-2018-19491: Fixed a buffer overlow in the PS_options function
(bsc#1117464)
- CVE-2018-19490: Fixed a heap-based buffer overflow in the
df_generate_ascii_array_entry function (bsc#1117465)

This update was imported from the SUSE:SLE-15:Update update project.


Patch Instructions:

To install this openSUSE Security Update use the SUSE recommended
installation methods
like YaST online_update or "zypper patch".

Alternatively you can run the command listed for your product:

- openSUSE Leap 15.0:

zypper in -t patch openSUSE-2019-1216=1



Package List:

- openSUSE Leap 15.0 (i586 x86_64):

gnuplot-5.2.2-lp150.3.3.1
gnuplot-debuginfo-5.2.2-lp150.3.3.1
gnuplot-debugsource-5.2.2-lp150.3.3.1

- openSUSE Leap 15.0 (noarch):

gnuplot-doc-5.2.2-lp150.3.3.1


References:

https://www.suse.com/security/cve/CVE-2018-19490.html
https://www.suse.com/security/cve/CVE-2018-19491.html
https://www.suse.com/security/cve/CVE-2018-19492.html
https://bugzilla.suse.com/1117463
https://bugzilla.suse.com/1117464
https://bugzilla.suse.com/1117465

--
To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@opensuse.org
For additional commands, e-mail: opensuse-security-announce+help@opensuse.org
Pro-Linux
Pro-Linux @Facebook
Neue Nachrichten
Werbung