Login
Newsletter
Werbung

Sicherheit: Pufferüberlauf in slurm
Aktuelle Meldungen Distributionen
Name: Pufferüberlauf in slurm
ID: openSUSE-SU-2019:1264-1
Distribution: SUSE
Plattformen: SUSE openSUSE Leap 15.0
Datum: Mi, 24. April 2019, 18:27
Referenzen: https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-6438
Applikationen: slurm

Originalnachricht

   openSUSE Security Update: Security update for slurm
______________________________________________________________________________

Announcement ID: openSUSE-SU-2019:1264-1
Rating: moderate
References: #1123304
Cross-References: CVE-2019-6438
Affected Products:
openSUSE Leap 15.0
______________________________________________________________________________

An update that fixes one vulnerability is now available.

Description:

This update for slurm to version 17.11.13 fixes the following issues:

Security issue fixed:

- CVE-2019-6438: Fixed a heap overflow on 32-bit systems in xmalloc
(bsc#1123304).

This update was imported from the SUSE:SLE-15:Update update project.


Patch Instructions:

To install this openSUSE Security Update use the SUSE recommended
installation methods
like YaST online_update or "zypper patch".

Alternatively you can run the command listed for your product:

- openSUSE Leap 15.0:

zypper in -t patch openSUSE-2019-1264=1



Package List:

- openSUSE Leap 15.0 (x86_64):

libpmi0-17.11.13-lp150.5.20.1
libpmi0-debuginfo-17.11.13-lp150.5.20.1
libslurm32-17.11.13-lp150.5.20.1
libslurm32-debuginfo-17.11.13-lp150.5.20.1
perl-slurm-17.11.13-lp150.5.20.1
perl-slurm-debuginfo-17.11.13-lp150.5.20.1
slurm-17.11.13-lp150.5.20.1
slurm-auth-none-17.11.13-lp150.5.20.1
slurm-auth-none-debuginfo-17.11.13-lp150.5.20.1
slurm-config-17.11.13-lp150.5.20.1
slurm-debuginfo-17.11.13-lp150.5.20.1
slurm-debugsource-17.11.13-lp150.5.20.1
slurm-devel-17.11.13-lp150.5.20.1
slurm-doc-17.11.13-lp150.5.20.1
slurm-lua-17.11.13-lp150.5.20.1
slurm-lua-debuginfo-17.11.13-lp150.5.20.1
slurm-munge-17.11.13-lp150.5.20.1
slurm-munge-debuginfo-17.11.13-lp150.5.20.1
slurm-node-17.11.13-lp150.5.20.1
slurm-node-debuginfo-17.11.13-lp150.5.20.1
slurm-openlava-17.11.13-lp150.5.20.1
slurm-pam_slurm-17.11.13-lp150.5.20.1
slurm-pam_slurm-debuginfo-17.11.13-lp150.5.20.1
slurm-plugins-17.11.13-lp150.5.20.1
slurm-plugins-debuginfo-17.11.13-lp150.5.20.1
slurm-seff-17.11.13-lp150.5.20.1
slurm-sjstat-17.11.13-lp150.5.20.1
slurm-slurmdbd-17.11.13-lp150.5.20.1
slurm-slurmdbd-debuginfo-17.11.13-lp150.5.20.1
slurm-sql-17.11.13-lp150.5.20.1
slurm-sql-debuginfo-17.11.13-lp150.5.20.1
slurm-sview-17.11.13-lp150.5.20.1
slurm-sview-debuginfo-17.11.13-lp150.5.20.1
slurm-torque-17.11.13-lp150.5.20.1
slurm-torque-debuginfo-17.11.13-lp150.5.20.1


References:

https://www.suse.com/security/cve/CVE-2019-6438.html
https://bugzilla.suse.com/1123304

--
To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@opensuse.org
For additional commands, e-mail: opensuse-security-announce+help@opensuse.org
Pro-Linux
Pro-Linux @Facebook
Neue Nachrichten
Werbung