Login
Newsletter
Werbung

Sicherheit: Mangelnde Rechteprüfung in wpa_supplicant
Aktuelle Meldungen Distributionen
Name: Mangelnde Rechteprüfung in wpa_supplicant
ID: openSUSE-SU-2019:1345-1
Distribution: SUSE
Plattformen: SUSE openSUSE Leap 42.3
Datum: Mi, 8. Mai 2019, 19:12
Referenzen: https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-14526
Applikationen: wpa_supplicant

Originalnachricht

   openSUSE Security Update: Security update for wpa_supplicant
______________________________________________________________________________

Announcement ID: openSUSE-SU-2019:1345-1
Rating: moderate
References: #1104205 #1109209
Cross-References: CVE-2018-14526
Affected Products:
openSUSE Leap 42.3
______________________________________________________________________________

An update that solves one vulnerability and has one errata
is now available.

Description:

This update for wpa_supplicant fixes the following issues:

This security issue was fixed:

- CVE-2018-14526: Under certain conditions, the integrity of EAPOL-Key
messages was not checked, leading to a decryption oracle. An attacker
within range of the Access Point and client could have abused the
vulnerability to recover sensitive information (bsc#1104205).

This non-security issue was fixed:

- Enabled PWD as EAP method. This allows for password-based
authentication, which is easier to setup than most of the other methods,
and is used by the Eduroam network (bsc#1109209).

This update was imported from the SUSE:SLE-12:Update update project.


Patch Instructions:

To install this openSUSE Security Update use the SUSE recommended
installation methods
like YaST online_update or "zypper patch".

Alternatively you can run the command listed for your product:

- openSUSE Leap 42.3:

zypper in -t patch openSUSE-2019-1345=1



Package List:

- openSUSE Leap 42.3 (i586 x86_64):

wpa_supplicant-2.6-16.1
wpa_supplicant-debuginfo-2.6-16.1
wpa_supplicant-debugsource-2.6-16.1
wpa_supplicant-gui-2.6-16.1
wpa_supplicant-gui-debuginfo-2.6-16.1


References:

https://www.suse.com/security/cve/CVE-2018-14526.html
https://bugzilla.suse.com/1104205
https://bugzilla.suse.com/1109209

--
To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@opensuse.org
For additional commands, e-mail: opensuse-security-announce+help@opensuse.org
Pro-Linux
Pro-Linux @Facebook
Neue Nachrichten
Werbung