Login
Newsletter
Werbung

Sicherheit: Mehrere Probleme in gnutls
Aktuelle Meldungen Distributionen
Name: Mehrere Probleme in gnutls
ID: openSUSE-SU-2019:1353-1
Distribution: SUSE
Plattformen: SUSE openSUSE Leap 15.0
Datum: Mi, 8. Mai 2019, 22:47
Referenzen: https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-3829
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-16868
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-3836
Applikationen: GNU Transport Layer Security Library

Originalnachricht

   openSUSE Security Update: Security update for gnutls
______________________________________________________________________________

Announcement ID: openSUSE-SU-2019:1353-1
Rating: important
References: #1118087 #1130681 #1130682
Cross-References: CVE-2018-16868 CVE-2019-3829 CVE-2019-3836

Affected Products:
openSUSE Leap 15.0
______________________________________________________________________________

An update that fixes three vulnerabilities is now available.

Description:

This update for gnutls fixes to version 3.6.7 the following issues:

Security issued fixed:

- CVE-2019-3836: Fixed an invalid pointer access via malformed TLS1.3
async messages (bsc#1130682).
- CVE-2019-3829: Fixed a double free vulnerability in the certificate
verification API (bsc#1130681).
- CVE-2018-16868: Fixed Bleichenbacher-like side channel leakage in PKCS#1
v1.5 verification and padding oracle verification (bsc#1118087)

Non-security issue fixed:

- Update gnutls to support TLS 1.3 (fate#327114)

This update was imported from the SUSE:SLE-15:Update update project.


Patch Instructions:

To install this openSUSE Security Update use the SUSE recommended
installation methods
like YaST online_update or "zypper patch".

Alternatively you can run the command listed for your product:

- openSUSE Leap 15.0:

zypper in -t patch openSUSE-2019-1353=1



Package List:

- openSUSE Leap 15.0 (i586 x86_64):

gnutls-3.6.7-lp150.9.1
gnutls-debuginfo-3.6.7-lp150.9.1
gnutls-debugsource-3.6.7-lp150.9.1
gnutls-guile-3.6.7-lp150.9.1
gnutls-guile-debuginfo-3.6.7-lp150.9.1
libgnutls-dane-devel-3.6.7-lp150.9.1
libgnutls-dane0-3.6.7-lp150.9.1
libgnutls-dane0-debuginfo-3.6.7-lp150.9.1
libgnutls-devel-3.6.7-lp150.9.1
libgnutls30-3.6.7-lp150.9.1
libgnutls30-debuginfo-3.6.7-lp150.9.1
libgnutlsxx-devel-3.6.7-lp150.9.1
libgnutlsxx28-3.6.7-lp150.9.1
libgnutlsxx28-debuginfo-3.6.7-lp150.9.1

- openSUSE Leap 15.0 (x86_64):

libgnutls-devel-32bit-3.6.7-lp150.9.1
libgnutls30-32bit-3.6.7-lp150.9.1
libgnutls30-32bit-debuginfo-3.6.7-lp150.9.1


References:

https://www.suse.com/security/cve/CVE-2018-16868.html
https://www.suse.com/security/cve/CVE-2019-3829.html
https://www.suse.com/security/cve/CVE-2019-3836.html
https://bugzilla.suse.com/1118087
https://bugzilla.suse.com/1130681
https://bugzilla.suse.com/1130682

--
To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@opensuse.org
For additional commands, e-mail: opensuse-security-announce+help@opensuse.org
Pro-Linux
Pro-Linux @Facebook
Neue Nachrichten
Werbung