Login
Newsletter
Werbung

Sicherheit: Mehrere Probleme in python-Jinja2
Aktuelle Meldungen Distributionen
Name: Mehrere Probleme in python-Jinja2
ID: openSUSE-SU-2019:1395-1
Distribution: SUSE
Plattformen: SUSE openSUSE Leap 15.0
Datum: Mo, 13. Mai 2019, 18:51
Referenzen: https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2016-10745
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-10906
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-8341
Applikationen: Jinja2

Originalnachricht

   openSUSE Security Update: Security update for python-Jinja2
______________________________________________________________________________

Announcement ID: openSUSE-SU-2019:1395-1
Rating: important
References: #1125815 #1132174 #1132323
Cross-References: CVE-2016-10745 CVE-2019-10906 CVE-2019-8341

Affected Products:
openSUSE Leap 15.0
______________________________________________________________________________

An update that fixes three vulnerabilities is now available.

Description:

This update for python-Jinja2 to version 2.10.1 fixes the following issues:

Security issues fixed:

- CVE-2019-8341: Fixed a command injection in from_string() (bsc#1125815).
- CVE-2019-10906: Fixed a sandbox escape due to information disclosure via
str.format (bsc#1132323).

This update was imported from the SUSE:SLE-15:Update update project.


Patch Instructions:

To install this openSUSE Security Update use the SUSE recommended
installation methods
like YaST online_update or "zypper patch".

Alternatively you can run the command listed for your product:

- openSUSE Leap 15.0:

zypper in -t patch openSUSE-2019-1395=1



Package List:

- openSUSE Leap 15.0 (noarch):

python-Jinja2-emacs-2.10.1-lp150.2.3.1
python-Jinja2-vim-2.10.1-lp150.2.3.1
python2-Jinja2-2.10.1-lp150.2.3.1
python3-Jinja2-2.10.1-lp150.2.3.1


References:

https://www.suse.com/security/cve/CVE-2016-10745.html
https://www.suse.com/security/cve/CVE-2019-10906.html
https://www.suse.com/security/cve/CVE-2019-8341.html
https://bugzilla.suse.com/1125815
https://bugzilla.suse.com/1132174
https://bugzilla.suse.com/1132323

--
To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@opensuse.org
For additional commands, e-mail: opensuse-security-announce+help@opensuse.org
Pro-Linux
Pro-Linux @Facebook
Neue Nachrichten
Werbung