Login
Newsletter
Werbung

Sicherheit: Mehrere Probleme in lxcfs und lxc
Aktuelle Meldungen Distributionen
Name: Mehrere Probleme in lxcfs und lxc
ID: openSUSE-SU-2019:1481-1
Distribution: SUSE
Plattformen: SUSE openSUSE Leap 42.3
Datum: Sa, 1. Juni 2019, 00:45
Referenzen: https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2015-1334
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-5985
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2015-1335
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-6556
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-5736
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2015-1331
Applikationen: lxcfs, LXC

Originalnachricht

   openSUSE Security Update: Security update for lxc, lxcfs
______________________________________________________________________________

Announcement ID: openSUSE-SU-2019:1481-1
Rating: important
References: #1036360 #1099239 #1122185 #1131762 #988348
#998326
Cross-References: CVE-2015-1331 CVE-2015-1334 CVE-2015-1335
CVE-2017-5985 CVE-2018-6556 CVE-2019-5736

Affected Products:
openSUSE Leap 42.3
______________________________________________________________________________

An update that fixes 6 vulnerabilities is now available.

Description:

This update for lxc, lxcfs to version 3.1.0 fixes the following issues:

Security issues fixed:

- CVE-2019-5736: Fixed a container breakout vulnerability (boo#1122185).
- CVE-2018-6556: Enable setuid bit on lxc-user-nic (boo#988348).

Non-security issues fixed:

- Update to LXC 3.1.0. The changelog is far too long to include here,
please look at https://linuxcontainers.org/. (boo#1131762)


Patch Instructions:

To install this openSUSE Security Update use the SUSE recommended
installation methods
like YaST online_update or "zypper patch".

Alternatively you can run the command listed for your product:

- openSUSE Leap 42.3:

zypper in -t patch openSUSE-2019-1481=1



Package List:

- openSUSE Leap 42.3 (i586 x86_64):

lxcfs-3.0.3-2.1
lxcfs-debuginfo-3.0.3-2.1
lxcfs-debugsource-3.0.3-2.1

- openSUSE Leap 42.3 (x86_64):

liblxc-devel-3.1.0-24.1
liblxc1-3.1.0-24.1
liblxc1-debuginfo-3.1.0-24.1
lxc-3.1.0-24.1
lxc-debuginfo-3.1.0-24.1
lxc-debugsource-3.1.0-24.1
pam_cgfs-3.1.0-24.1
pam_cgfs-debuginfo-3.1.0-24.1

- openSUSE Leap 42.3 (noarch):

lxc-bash-completion-3.1.0-24.1
lxcfs-hooks-lxc-3.0.3-2.1


References:

https://www.suse.com/security/cve/CVE-2015-1331.html
https://www.suse.com/security/cve/CVE-2015-1334.html
https://www.suse.com/security/cve/CVE-2015-1335.html
https://www.suse.com/security/cve/CVE-2017-5985.html
https://www.suse.com/security/cve/CVE-2018-6556.html
https://www.suse.com/security/cve/CVE-2019-5736.html
https://bugzilla.suse.com/1036360
https://bugzilla.suse.com/1099239
https://bugzilla.suse.com/1122185
https://bugzilla.suse.com/1131762
https://bugzilla.suse.com/988348
https://bugzilla.suse.com/998326

--
To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@opensuse.org
For additional commands, e-mail: opensuse-security-announce+help@opensuse.org
Pro-Linux
Traut euch!
Neue Nachrichten
Werbung