Login
Newsletter
Werbung

Sicherheit: Ausführen beliebiger Kommandos in GraphicsMagick
Aktuelle Meldungen Distributionen
Name: Ausführen beliebiger Kommandos in GraphicsMagick
ID: openSUSE-SU-2019:1491-1
Distribution: SUSE
Plattformen: SUSE openSUSE Leap 42.3, SUSE openSUSE Leap 15.0, SUSE openSUSE Leap 15.1
Datum: Mo, 3. Juni 2019, 13:02
Referenzen: Keine Angabe
Applikationen: GraphicsMagick

Originalnachricht

   openSUSE Security Update: Recommended update for GraphicsMagick
______________________________________________________________________________

Announcement ID: openSUSE-SU-2019:1491-1
Rating: moderate
References: #1136183
Affected Products:
openSUSE Leap 42.3
openSUSE Leap 15.1
openSUSE Leap 15.0
______________________________________________________________________________

An update that contains security fixes can now be installed.

Description:

This update for GraphicsMagick fixes the following issues:

Changes in GraphicsMagick:

- disable also PCL decoding by default, as it is also passed through
ghostscript (boo#1136183)


Patch Instructions:

To install this openSUSE Security Update use the SUSE recommended
installation methods
like YaST online_update or "zypper patch".

Alternatively you can run the command listed for your product:

- openSUSE Leap 42.3:

zypper in -t patch openSUSE-2019-1491=1

- openSUSE Leap 15.1:

zypper in -t patch openSUSE-2019-1491=1

- openSUSE Leap 15.0:

zypper in -t patch openSUSE-2019-1491=1



Package List:

- openSUSE Leap 42.3 (i586 x86_64):

GraphicsMagick-1.3.25-141.1
GraphicsMagick-debuginfo-1.3.25-141.1
GraphicsMagick-debugsource-1.3.25-141.1
GraphicsMagick-devel-1.3.25-141.1
libGraphicsMagick++-Q16-12-1.3.25-141.1
libGraphicsMagick++-Q16-12-debuginfo-1.3.25-141.1
libGraphicsMagick++-devel-1.3.25-141.1
libGraphicsMagick-Q16-3-1.3.25-141.1
libGraphicsMagick-Q16-3-debuginfo-1.3.25-141.1
libGraphicsMagick3-config-1.3.25-141.1
libGraphicsMagickWand-Q16-2-1.3.25-141.1
libGraphicsMagickWand-Q16-2-debuginfo-1.3.25-141.1
perl-GraphicsMagick-1.3.25-141.1
perl-GraphicsMagick-debuginfo-1.3.25-141.1

- openSUSE Leap 15.1 (x86_64):

GraphicsMagick-1.3.29-lp151.4.3.1
GraphicsMagick-debuginfo-1.3.29-lp151.4.3.1
GraphicsMagick-debugsource-1.3.29-lp151.4.3.1
GraphicsMagick-devel-1.3.29-lp151.4.3.1
libGraphicsMagick++-Q16-12-1.3.29-lp151.4.3.1
libGraphicsMagick++-Q16-12-debuginfo-1.3.29-lp151.4.3.1
libGraphicsMagick++-devel-1.3.29-lp151.4.3.1
libGraphicsMagick-Q16-3-1.3.29-lp151.4.3.1
libGraphicsMagick-Q16-3-debuginfo-1.3.29-lp151.4.3.1
libGraphicsMagick3-config-1.3.29-lp151.4.3.1
libGraphicsMagickWand-Q16-2-1.3.29-lp151.4.3.1
libGraphicsMagickWand-Q16-2-debuginfo-1.3.29-lp151.4.3.1
perl-GraphicsMagick-1.3.29-lp151.4.3.1
perl-GraphicsMagick-debuginfo-1.3.29-lp151.4.3.1

- openSUSE Leap 15.0 (x86_64):

GraphicsMagick-1.3.29-lp150.3.31.1
GraphicsMagick-debuginfo-1.3.29-lp150.3.31.1
GraphicsMagick-debugsource-1.3.29-lp150.3.31.1
GraphicsMagick-devel-1.3.29-lp150.3.31.1
libGraphicsMagick++-Q16-12-1.3.29-lp150.3.31.1
libGraphicsMagick++-Q16-12-debuginfo-1.3.29-lp150.3.31.1
libGraphicsMagick++-devel-1.3.29-lp150.3.31.1
libGraphicsMagick-Q16-3-1.3.29-lp150.3.31.1
libGraphicsMagick-Q16-3-debuginfo-1.3.29-lp150.3.31.1
libGraphicsMagick3-config-1.3.29-lp150.3.31.1
libGraphicsMagickWand-Q16-2-1.3.29-lp150.3.31.1
libGraphicsMagickWand-Q16-2-debuginfo-1.3.29-lp150.3.31.1
perl-GraphicsMagick-1.3.29-lp150.3.31.1
perl-GraphicsMagick-debuginfo-1.3.29-lp150.3.31.1


References:

https://bugzilla.suse.com/1136183

--
To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@opensuse.org
For additional commands, e-mail: opensuse-security-announce+help@opensuse.org
Pro-Linux
Unterstützer werden
Neue Nachrichten
Werbung