Login
Newsletter
Werbung

Sicherheit: Mehrere Probleme in java-1_7_0-openjdk
Aktuelle Meldungen Distributionen
Name: Mehrere Probleme in java-1_7_0-openjdk
ID: openSUSE-SU-2019:1500-1
Distribution: SUSE
Plattformen: SUSE openSUSE Leap 42.3
Datum: Mo, 3. Juni 2019, 22:33
Referenzen: https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-2426
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-2698
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-11212
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-2422
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-2684
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-2602
Applikationen: OpenJDK

Originalnachricht

   openSUSE Security Update: Security update for java-1_7_0-openjdk
______________________________________________________________________________

Announcement ID: openSUSE-SU-2019:1500-1
Rating: moderate
References: #1122293 #1122299 #1132728 #1132729 #1132732
#1134297
Cross-References: CVE-2018-11212 CVE-2019-2422 CVE-2019-2426
CVE-2019-2602 CVE-2019-2684 CVE-2019-2698

Affected Products:
openSUSE Leap 42.3
______________________________________________________________________________

An update that fixes 6 vulnerabilities is now available.

Description:

This update for java-1_7_0-openjdk fixes the following issues:

Update to 2.6.18 - OpenJDK 7u221 (April 2019 CPU)

Security issues fixed:

- CVE-2019-2602: Fixed flaw inside BigDecimal implementation (Component:
Libraries) (bsc#1132728).
- CVE-2019-2684: Fixed flaw inside the RMI registry implementation
(bsc#1132732).
- CVE-2019-2698: Fixed out of bounds access flaw in the 2D component
(bsc#1132729).
- CVE-2019-2422: Fixed memory disclosure in FileChannelImpl (bsc#1122293).
- CVE-2018-11212: Fixed a Divide By Zero in alloc_sarray function in
jmemmgr.c (bsc#1122299).
- CVE-2019-2426: Improve web server connections (bsc#1134297).

Bug fixes:

- Please check the package Changelog for detailed information.

This update was imported from the SUSE:SLE-12:Update update project.


Patch Instructions:

To install this openSUSE Security Update use the SUSE recommended
installation methods
like YaST online_update or "zypper patch".

Alternatively you can run the command listed for your product:

- openSUSE Leap 42.3:

zypper in -t patch openSUSE-2019-1500=1



Package List:

- openSUSE Leap 42.3 (i586 x86_64):

java-1_7_0-openjdk-1.7.0.221-57.1
java-1_7_0-openjdk-accessibility-1.7.0.221-57.1
java-1_7_0-openjdk-bootstrap-1.7.0.221-57.1
java-1_7_0-openjdk-bootstrap-debuginfo-1.7.0.221-57.1
java-1_7_0-openjdk-bootstrap-debugsource-1.7.0.221-57.1
java-1_7_0-openjdk-bootstrap-devel-1.7.0.221-57.1
java-1_7_0-openjdk-bootstrap-devel-debuginfo-1.7.0.221-57.1
java-1_7_0-openjdk-bootstrap-headless-1.7.0.221-57.1
java-1_7_0-openjdk-bootstrap-headless-debuginfo-1.7.0.221-57.1
java-1_7_0-openjdk-debuginfo-1.7.0.221-57.1
java-1_7_0-openjdk-debugsource-1.7.0.221-57.1
java-1_7_0-openjdk-demo-1.7.0.221-57.1
java-1_7_0-openjdk-demo-debuginfo-1.7.0.221-57.1
java-1_7_0-openjdk-devel-1.7.0.221-57.1
java-1_7_0-openjdk-devel-debuginfo-1.7.0.221-57.1
java-1_7_0-openjdk-headless-1.7.0.221-57.1
java-1_7_0-openjdk-headless-debuginfo-1.7.0.221-57.1
java-1_7_0-openjdk-src-1.7.0.221-57.1

- openSUSE Leap 42.3 (noarch):

java-1_7_0-openjdk-javadoc-1.7.0.221-57.1


References:

https://www.suse.com/security/cve/CVE-2018-11212.html
https://www.suse.com/security/cve/CVE-2019-2422.html
https://www.suse.com/security/cve/CVE-2019-2426.html
https://www.suse.com/security/cve/CVE-2019-2602.html
https://www.suse.com/security/cve/CVE-2019-2684.html
https://www.suse.com/security/cve/CVE-2019-2698.html
https://bugzilla.suse.com/1122293
https://bugzilla.suse.com/1122299
https://bugzilla.suse.com/1132728
https://bugzilla.suse.com/1132729
https://bugzilla.suse.com/1132732
https://bugzilla.suse.com/1134297

--
To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@opensuse.org
For additional commands, e-mail: opensuse-security-announce+help@opensuse.org
Pro-Linux
Traut euch!
Neue Nachrichten
Werbung