Login
Newsletter
Werbung

Sicherheit: Zwei Probleme in Linux
Aktuelle Meldungen Distributionen
Name: Zwei Probleme in Linux
ID: USN-4005-1
Distribution: Ubuntu
Plattformen: Ubuntu 19.04
Datum: Mi, 5. Juni 2019, 07:34
Referenzen: https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-11810
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-11815
Applikationen: Linux

Originalnachricht


--===============3848040864841590926==
Content-Type: multipart/signed; micalg=pgp-sha512;
protocol="application/pgp-signature";
boundary="nqkreNcslJAfgyzk"
Content-Disposition: inline


--nqkreNcslJAfgyzk
Content-Type: text/plain; charset=us-ascii
Content-Disposition: inline

==========================================================================
Ubuntu Security Notice USN-4005-1
June 04, 2019

linux, linux-aws, linux-gcp, linux-kvm, linux-raspi2, linux-snapdragon
vulnerabilities
==========================================================================

A security issue affects these releases of Ubuntu and its derivatives:

- Ubuntu 19.04

Summary:

Several security issues were fixed in the Linux kernel.

Software Description:
- linux: Linux kernel
- linux-aws: Linux kernel for Amazon Web Services (AWS) systems
- linux-gcp: Linux kernel for Google Cloud Platform (GCP) systems
- linux-kvm: Linux kernel for cloud environments
- linux-raspi2: Linux kernel for Raspberry Pi 2
- linux-snapdragon: Linux kernel for Snapdragon processors

Details:

It was discovered that a null pointer dereference vulnerability existed in
the LSI Logic MegaRAID driver in the Linux kernel. A local attacker could
use this to cause a denial of service (system crash). (CVE-2019-11810)

It was discovered that a race condition leading to a use-after-free existed
in the Reliable Datagram Sockets (RDS) protocol implementation in the Linux
kernel. The RDS protocol is blacklisted by default in Ubuntu. If enabled, a
local attacker could use this to cause a denial of service (system crash)
or possibly execute arbitrary code. (CVE-2019-11815)

Update instructions:

The problem can be corrected by updating your system to the following
package versions:

Ubuntu 19.04:
linux-image-5.0.0-1007-aws 5.0.0-1007.7
linux-image-5.0.0-1007-gcp 5.0.0-1007.7
linux-image-5.0.0-1007-kvm 5.0.0-1007.7
linux-image-5.0.0-1009-raspi2 5.0.0-1009.9
linux-image-5.0.0-1013-snapdragon 5.0.0-1013.13
linux-image-5.0.0-16-generic 5.0.0-16.17
linux-image-5.0.0-16-generic-lpae 5.0.0-16.17
linux-image-5.0.0-16-lowlatency 5.0.0-16.17
linux-image-aws 5.0.0.1007.7
linux-image-gcp 5.0.0.1007.7
linux-image-generic 5.0.0.16.17
linux-image-generic-lpae 5.0.0.16.17
linux-image-gke 5.0.0.1007.7
linux-image-kvm 5.0.0.1007.7
linux-image-lowlatency 5.0.0.16.17
linux-image-raspi2 5.0.0.1009.6
linux-image-snapdragon 5.0.0.1013.6

After a standard system update you need to reboot your computer to make
all the necessary changes.

ATTENTION: Due to an unavoidable ABI change the kernel updates have
been given a new version number, which requires you to recompile and
reinstall all third party kernel modules you might have installed.
Unless you manually uninstalled the standard kernel metapackages
(e.g. linux-generic, linux-generic-lts-RELEASE, linux-virtual,
linux-powerpc), a standard system upgrade will automatically perform
this as well.

References:
https://usn.ubuntu.com/4005-1
CVE-2019-11810, CVE-2019-11815

Package Information:
https://launchpad.net/ubuntu/+source/linux/5.0.0-16.17
https://launchpad.net/ubuntu/+source/linux-aws/5.0.0-1007.7
https://launchpad.net/ubuntu/+source/linux-gcp/5.0.0-1007.7
https://launchpad.net/ubuntu/+source/linux-kvm/5.0.0-1007.7
https://launchpad.net/ubuntu/+source/linux-raspi2/5.0.0-1009.9
https://launchpad.net/ubuntu/+source/linux-snapdragon/5.0.0-1013.13


--nqkreNcslJAfgyzk
Content-Type: application/pgp-signature; name="signature.asc"

-----BEGIN PGP SIGNATURE-----

iQIzBAABCgAdFiEEpgY7tWAjCaQ8jrvULwmejQBegfQFAlz299gACgkQLwmejQBe
gfR4KA//ZyPCP2gy/mtIgHPKFhfkDP+LOcfCXF/v2fnmG9EnnRNTSMLc8EQwpf98
GpSTM9GqnyEo9eEUbbT/k9TpS/AuE7LQjCQJL9n/qeALThbV5dRckuPh3PMFkYOD
EgrWgnPtnMNBw43sHQXcNuS2/U+tMNUzvzHRemuL6b0HZgNej4vYgUvEoMu9XvGf
I3RddIEIf8W9xAgB/SUqA9AlPuMf0B/fvLW9M2U/9QpnK2wm2mgTeh7u2CHewldj
2njrc3iwKh7Uf9DvkvAUzF++1GxJy6ZAA183yBctQxLZDhqYLcXnqfSoh2FH9zxG
cbgQ2GHrQKeXQxU6CGRqH8/PtFogThnmhFXrvmwmL2KyLQma7X9owbZAaGGc7Cbw
VBp5A4JzRrrmv+UMAbpYkSqC4E4wVsMKGTkhl5nyt4rl1ATr1/PO0m23MyL49oka
Vvh7cT1X+dlpWmCgLrafO3u9FDY4tJaQOcmOVnKRssTSWbiO9OhbJOPXj4KVxHye
S0Ncy7vypC16DQT23P9CEOkD5A5pAtba9RlrRhzCkRQIfzvfucd4CMDhlxRdeRxE
eZXiatDiq+pnS8Ly5PAWdWT8sMtgFruDxWrFcU+6s3Hn/0RsaHoNm2yhfqVoPRpO
QmxqdedTnYMyCs7UiQxPU4unBXbP9CjrMW6aabmuom+FW/Bdrr0=
=RNfQ
-----END PGP SIGNATURE-----

--nqkreNcslJAfgyzk--


--===============3848040864841590926==
Content-Type: text/plain; charset="utf-8"
MIME-Version: 1.0
Content-Transfer-Encoding: base64
Content-Disposition: inline

--
ubuntu-security-announce mailing list
ubuntu-security-announce@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-security-announce
Pro-Linux
Traut euch!
Neue Nachrichten
Werbung