Login
Newsletter
Werbung

Sicherheit: Zwei Probleme in libpng16
Aktuelle Meldungen Distributionen
Name: Zwei Probleme in libpng16
ID: openSUSE-SU-2019:1530-1
Distribution: SUSE
Plattformen: SUSE openSUSE Leap 15.0, SUSE openSUSE Leap 15.1
Datum: Fr, 7. Juni 2019, 23:30
Referenzen: https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-7317
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-13785
Applikationen: libpng

Originalnachricht

   openSUSE Security Update: Security update for libpng16
______________________________________________________________________________

Announcement ID: openSUSE-SU-2019:1530-1
Rating: low
References: #1100687 #1121624 #1124211
Cross-References: CVE-2018-13785 CVE-2019-7317
Affected Products:
openSUSE Leap 15.1
openSUSE Leap 15.0
______________________________________________________________________________

An update that solves two vulnerabilities and has one
errata is now available.

Description:

This update for libpng16 fixes the following issues:

Security issues fixed:

- CVE-2019-7317: Fixed a use-after-free vulnerability, triggered when
png_image_free() was called under png_safe_execute (bsc#1124211).
- CVE-2018-13785: Fixed a wrong calculation of row_factor in the
png_check_chunk_length function in pngrutil.c, which could haved
triggered and integer overflow and result in an divide-by-zero while
processing a crafted PNG file, leading to a denial of service
(bsc#1100687)

This update was imported from the SUSE:SLE-15:Update update project.


Patch Instructions:

To install this openSUSE Security Update use the SUSE recommended
installation methods
like YaST online_update or "zypper patch".

Alternatively you can run the command listed for your product:

- openSUSE Leap 15.1:

zypper in -t patch openSUSE-2019-1530=1

- openSUSE Leap 15.0:

zypper in -t patch openSUSE-2019-1530=1



Package List:

- openSUSE Leap 15.1 (i586 x86_64):

libpng16-16-1.6.34-lp151.3.3.1
libpng16-16-debuginfo-1.6.34-lp151.3.3.1
libpng16-compat-devel-1.6.34-lp151.3.3.1
libpng16-debugsource-1.6.34-lp151.3.3.1
libpng16-devel-1.6.34-lp151.3.3.1
libpng16-tools-1.6.34-lp151.3.3.1
libpng16-tools-debuginfo-1.6.34-lp151.3.3.1

- openSUSE Leap 15.1 (x86_64):

libpng16-16-32bit-1.6.34-lp151.3.3.1
libpng16-16-32bit-debuginfo-1.6.34-lp151.3.3.1
libpng16-compat-devel-32bit-1.6.34-lp151.3.3.1
libpng16-devel-32bit-1.6.34-lp151.3.3.1

- openSUSE Leap 15.0 (i586 x86_64):

libpng16-16-1.6.34-lp150.2.3.1
libpng16-16-debuginfo-1.6.34-lp150.2.3.1
libpng16-compat-devel-1.6.34-lp150.2.3.1
libpng16-debugsource-1.6.34-lp150.2.3.1
libpng16-devel-1.6.34-lp150.2.3.1
libpng16-tools-1.6.34-lp150.2.3.1
libpng16-tools-debuginfo-1.6.34-lp150.2.3.1

- openSUSE Leap 15.0 (x86_64):

libpng16-16-32bit-1.6.34-lp150.2.3.1
libpng16-16-32bit-debuginfo-1.6.34-lp150.2.3.1
libpng16-compat-devel-32bit-1.6.34-lp150.2.3.1
libpng16-devel-32bit-1.6.34-lp150.2.3.1


References:

https://www.suse.com/security/cve/CVE-2018-13785.html
https://www.suse.com/security/cve/CVE-2019-7317.html
https://bugzilla.suse.com/1100687
https://bugzilla.suse.com/1121624
https://bugzilla.suse.com/1124211

--
To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@opensuse.org
For additional commands, e-mail: opensuse-security-announce+help@opensuse.org
Pro-Linux
Traut euch!
Neue Nachrichten
Werbung