Login
Newsletter
Werbung

Sicherheit: Ausführen beliebiger Kommandos in Neovim (Aktualisierung)
Aktuelle Meldungen Distributionen
Name: Ausführen beliebiger Kommandos in Neovim (Aktualisierung)
ID: USN-4016-2
Distribution: Ubuntu
Plattformen: Ubuntu 18.10, Ubuntu 19.04
Datum: Di, 11. Juni 2019, 22:18
Referenzen: https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-12735
Applikationen: neovim
Update von: Zwei Probleme in Vim

Originalnachricht

This is an OpenPGP/MIME signed message (RFC 4880 and 3156)
--===============4931789517659277986==
Content-Type: multipart/signed; micalg=pgp-sha512;
protocol="application/pgp-signature";
boundary="AL05tjfUBvN1Y9trMH70MB2OGndMfkEzD"

This is an OpenPGP/MIME signed message (RFC 4880 and 3156)
--AL05tjfUBvN1Y9trMH70MB2OGndMfkEzD
Content-Type: multipart/mixed;
boundary="eoA1Y0BCd0eVBUDFiUNMVejb0XAnurTC3";
protected-headers="v1"
From: Mike Salvatore <mike.salvatore@canonical.com>
To: ubuntu-security-announce@lists.ubuntu.com
Cc: security <security@ubuntu.com>
Message-ID: <cf1d5172-92a8-2931-1326-87e2f5b095c0@canonical.com>
Subject: [USN-4016-2] Neovim vulnerability
References: <20190611182749.5C22326C2652@lillypilly.canonical.com>
In-Reply-To: <20190611182749.5C22326C2652@lillypilly.canonical.com>

--eoA1Y0BCd0eVBUDFiUNMVejb0XAnurTC3
Content-Type: text/plain; charset=utf-8
Content-Language: en-U
Content-Transfer-Encoding: quoted-printable

==========================================================================
Ubuntu Security Notice USN-4016-2
June 11, 2019

Neovim vulnerability
==========================================================================

A security issue affects these releases of Ubuntu and its derivatives:

- Ubuntu 19.04
- Ubuntu 18.10

Summary:

Neovim could be made to run programs as your login if it
opened a specially crafted file.

Software Description:
- neovim: heavily refactored vim fork

Details:

It was discovered that Neovim incorrectly handled certain files. An attacker
could possibly use this issue to execute arbitrary code. (CVE-2019-12735)

Update instructions:

The problem can be corrected by updating your system to the following
package versions:

Ubuntu 19.04:
neovim 0.3.4-1ubuntu0.19.04.1
neovim-runtime 0.3.4-1ubuntu0.19.04.1

Ubuntu 18.10:
neovim 0.3.1-1ubuntu0.1
neovim-runtime 0.3.1-1ubuntu0.1

In general, a standard system update will make all the necessary changes.

References:
https://usn.ubuntu.com/4016-2
https://usn.ubuntu.com/4016-1
CVE-2019-12735

Package Information:
https://launchpad.net/ubuntu/+source/neovim/0.3.4-1ubuntu0.19.04.1
https://launchpad.net/ubuntu/+source/neovim/0.3.1-1ubuntu0.1


--eoA1Y0BCd0eVBUDFiUNMVejb0XAnurTC3--

--AL05tjfUBvN1Y9trMH70MB2OGndMfkEzD
Content-Type: application/pgp-signature; name="signature.asc"
Content-Description: OpenPGP digital signature
Content-Disposition: attachment; filename="signature.asc"

-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEwZbe96kJeWh2OITRdyg1Qz0oXX0FAlz/9uIACgkQdyg1Qz0o
XX3X8hAAsQrj3DKT6yGLqKR/cDlqxDXvaWMVXqzTgPVGMWl+Fpq7+xRa6Lydx3Ye
oMxT34l1dXuBRiHCqeLfhPVXHzgr/zRp5Lhhrk+HQDYum4bqtjw0veoJW8TELUxR
vsRHdHLhAfHk/Rf9EQuofjlMf1tzY9jiAy04xo1evIm4HgbrgXo083l5g1gxZzKW
+kBUzahAPaIY9/ylGQCWEEdxkZ2te+VGuRNK0XiklVX057rmZDLoEgLFJIMUdg6h
UWXoyybsSHChphASgDyoxDS5vkbUe29aVc6ucx0+T2270AOFW7wg8+gazwt9CyuL
qyPkbheZrwg0FGUGVhGIEQOBKxqq6uF3m+47X7++7PV3oRwyH9fWussJylddaiJl
JKFaZCUZcW38zgTihJ4A6QM/oJZSYX0Uyqd1VPP1sq2hvTH58PlebdbNJE7OFeAW
V8AtAhct1fsZqjNNbERfCm3TljXm4YesjxvhnkjyxUyzJ1v4OR+zhY6EXFx3S5sZ
KCVpp8YMZTsW0FldT/ke3VOIuNooriBb+2DtZtU2WlPvjrb0OQCxQz/lDw4C2xYk
0OZN2+712dEGNBeAQO3ZwLylAAFKzDKs2BylPUFfziHxfvBrWN607pxYTVv7qPWm
zb8qyTPqdLz0K6W/YwT5d7A+cFojj07w+3yiNDPS5TUK271NuKw=
=QVFa
-----END PGP SIGNATURE-----

--AL05tjfUBvN1Y9trMH70MB2OGndMfkEzD--


--===============4931789517659277986==
Content-Type: text/plain; charset="utf-8"
MIME-Version: 1.0
Content-Transfer-Encoding: base64
Content-Disposition: inline

LS0gCnVidW50dS1zZWN1cml0eS1hbm5vdW5jZSBtYWlsaW5nIGxpc3QKdWJ1bnR1LXNlY3VyaXR5
LWFubm91bmNlQGxpc3RzLnVidW50dS5jb20KTW9kaWZ5IHNldHRpbmdzIG9yIHVuc3Vic2NyaWJl
IGF0OiBodHRwczovL2xpc3RzLnVidW50dS5jb20vbWFpbG1hbi9saXN0aW5mby91YnVudHUtc2Vj
dXJpdHktYW5ub3VuY2UK

--===============4931789517659277986==--
Pro-Linux
Traut euch!
Neue Nachrichten
Werbung