Login
Newsletter
Werbung

Sicherheit: Mehrere Probleme in libvirt
Aktuelle Meldungen Distributionen
Name: Mehrere Probleme in libvirt
ID: SUSE-SU-2019:1637-1
Distribution: SUSE
Plattformen: SUSE Linux Enterprise Module for Basesystem 15, SUSE Linux Enterprise Module for Server Applications 15, SUSE Linux Enterprise Module for Open Buildservice Development Tools 15
Datum: Fr, 21. Juni 2019, 20:49
Referenzen: https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-10167
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-10166
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-10161
Applikationen: libvirt

Originalnachricht


SUSE Security Update: Security update for libvirt
______________________________________________________________________________

Announcement ID: SUSE-SU-2019:1637-1
Rating: important
References: #1136109 #1138301 #1138302 #1138303
Cross-References: CVE-2019-10161 CVE-2019-10166 CVE-2019-10167

Affected Products:
SUSE Linux Enterprise Module for Server Applications 15
SUSE Linux Enterprise Module for Open Buildservice
Development Tools 15
SUSE Linux Enterprise Module for Basesystem 15
______________________________________________________________________________

An update that solves three vulnerabilities and has one
errata is now available.

Description:

This update for libvirt fixes the following issues:

Security issues fixed:

- CVE-2019-10161: Fixed virDomainSaveImageGetXMLDesc API which could
accept a path parameter pointing anywhere on the system and potentially
leading to execution
of a malicious file with root privileges by libvirtd (bsc#1138301).
- CVE-2019-10166: Fixed an issue with virDomainManagedSaveDefineXML which
could have been used to alter the domain's config used for managedsave
or execute arbitrary emulator binaries (bsc#1138302).
- CVE-2019-10167: Fixed an issue with virConnectGetDomainCapabilities API
which could have been used to execute arbitrary emulators (bsc#1138303).

Other issue addressed:

- spec: add systemd-container dependency to qemu and lxc drivers
(bsc#1136109).


Patch Instructions:

To install this SUSE Security Update use the SUSE recommended installation
methods
like YaST online_update or "zypper patch".

Alternatively you can run the command listed for your product:

- SUSE Linux Enterprise Module for Server Applications 15:

zypper in -t patch SUSE-SLE-Module-Server-Applications-15-2019-1637=1

- SUSE Linux Enterprise Module for Open Buildservice Development Tools 15:

zypper in -t patch SUSE-SLE-Module-Development-Tools-OBS-15-2019-1637=1

- SUSE Linux Enterprise Module for Basesystem 15:

zypper in -t patch SUSE-SLE-Module-Basesystem-15-2019-1637=1



Package List:

- SUSE Linux Enterprise Module for Server Applications 15 (aarch64 ppc64le
s390x x86_64):

libvirt-4.0.0-9.27.1
libvirt-admin-4.0.0-9.27.1
libvirt-admin-debuginfo-4.0.0-9.27.1
libvirt-client-4.0.0-9.27.1
libvirt-client-debuginfo-4.0.0-9.27.1
libvirt-daemon-4.0.0-9.27.1
libvirt-daemon-config-network-4.0.0-9.27.1
libvirt-daemon-config-nwfilter-4.0.0-9.27.1
libvirt-daemon-debuginfo-4.0.0-9.27.1
libvirt-daemon-driver-interface-4.0.0-9.27.1
libvirt-daemon-driver-interface-debuginfo-4.0.0-9.27.1
libvirt-daemon-driver-lxc-4.0.0-9.27.1
libvirt-daemon-driver-lxc-debuginfo-4.0.0-9.27.1
libvirt-daemon-driver-network-4.0.0-9.27.1
libvirt-daemon-driver-network-debuginfo-4.0.0-9.27.1
libvirt-daemon-driver-nodedev-4.0.0-9.27.1
libvirt-daemon-driver-nodedev-debuginfo-4.0.0-9.27.1
libvirt-daemon-driver-nwfilter-4.0.0-9.27.1
libvirt-daemon-driver-nwfilter-debuginfo-4.0.0-9.27.1
libvirt-daemon-driver-qemu-4.0.0-9.27.1
libvirt-daemon-driver-qemu-debuginfo-4.0.0-9.27.1
libvirt-daemon-driver-secret-4.0.0-9.27.1
libvirt-daemon-driver-secret-debuginfo-4.0.0-9.27.1
libvirt-daemon-driver-storage-4.0.0-9.27.1
libvirt-daemon-driver-storage-core-4.0.0-9.27.1
libvirt-daemon-driver-storage-core-debuginfo-4.0.0-9.27.1
libvirt-daemon-driver-storage-disk-4.0.0-9.27.1
libvirt-daemon-driver-storage-disk-debuginfo-4.0.0-9.27.1
libvirt-daemon-driver-storage-iscsi-4.0.0-9.27.1
libvirt-daemon-driver-storage-iscsi-debuginfo-4.0.0-9.27.1
libvirt-daemon-driver-storage-logical-4.0.0-9.27.1
libvirt-daemon-driver-storage-logical-debuginfo-4.0.0-9.27.1
libvirt-daemon-driver-storage-mpath-4.0.0-9.27.1
libvirt-daemon-driver-storage-mpath-debuginfo-4.0.0-9.27.1
libvirt-daemon-driver-storage-scsi-4.0.0-9.27.1
libvirt-daemon-driver-storage-scsi-debuginfo-4.0.0-9.27.1
libvirt-daemon-hooks-4.0.0-9.27.1
libvirt-daemon-lxc-4.0.0-9.27.1
libvirt-daemon-qemu-4.0.0-9.27.1
libvirt-debugsource-4.0.0-9.27.1
libvirt-devel-4.0.0-9.27.1
libvirt-doc-4.0.0-9.27.1
libvirt-lock-sanlock-4.0.0-9.27.1
libvirt-lock-sanlock-debuginfo-4.0.0-9.27.1
libvirt-nss-4.0.0-9.27.1
libvirt-nss-debuginfo-4.0.0-9.27.1

- SUSE Linux Enterprise Module for Server Applications 15 (aarch64 x86_64):

libvirt-daemon-driver-storage-rbd-4.0.0-9.27.1
libvirt-daemon-driver-storage-rbd-debuginfo-4.0.0-9.27.1

- SUSE Linux Enterprise Module for Server Applications 15 (x86_64):

libvirt-daemon-driver-libxl-4.0.0-9.27.1
libvirt-daemon-driver-libxl-debuginfo-4.0.0-9.27.1
libvirt-daemon-xen-4.0.0-9.27.1

- SUSE Linux Enterprise Module for Open Buildservice Development Tools 15
(aarch64 ppc64le s390x x86_64):

libvirt-debugsource-4.0.0-9.27.1
wireshark-plugin-libvirt-4.0.0-9.27.1
wireshark-plugin-libvirt-debuginfo-4.0.0-9.27.1

- SUSE Linux Enterprise Module for Basesystem 15 (aarch64 ppc64le s390x
x86_64):

libvirt-debugsource-4.0.0-9.27.1
libvirt-libs-4.0.0-9.27.1
libvirt-libs-debuginfo-4.0.0-9.27.1


References:

https://www.suse.com/security/cve/CVE-2019-10161.html
https://www.suse.com/security/cve/CVE-2019-10166.html
https://www.suse.com/security/cve/CVE-2019-10167.html
https://bugzilla.suse.com/1136109
https://bugzilla.suse.com/1138301
https://bugzilla.suse.com/1138302
https://bugzilla.suse.com/1138303

_______________________________________________
sle-security-updates mailing list
sle-security-updates@lists.suse.com
http://lists.suse.com/mailman/listinfo/sle-security-updates
Pro-Linux
Traut euch!
Neue Nachrichten
Werbung