Login
Newsletter
Werbung

Sicherheit: Zwei Probleme in netpbm
Aktuelle Meldungen Distributionen
Name: Zwei Probleme in netpbm
ID: openSUSE-SU-2019:1605-1
Distribution: SUSE
Plattformen: SUSE openSUSE Leap 15.0, SUSE openSUSE Leap 15.1
Datum: Mo, 24. Juni 2019, 15:40
Referenzen: https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-2579
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-2580
Applikationen: netpbm

Originalnachricht

   openSUSE Security Update: Security update for netpbm
______________________________________________________________________________

Announcement ID: openSUSE-SU-2019:1605-1
Rating: moderate
References: #1024288 #1024291 #1136936
Cross-References: CVE-2017-2579 CVE-2017-2580
Affected Products:
openSUSE Leap 15.1
openSUSE Leap 15.0
______________________________________________________________________________

An update that solves two vulnerabilities and has one
errata is now available.

Description:

This update for netpbm fixes the following issues:

Security issues fixed:

- CVE-2017-2579: Fixed out-of-bounds read in expandCodeOntoStack()
(bsc#1024288).
- CVE-2017-2580: Fixed out-of-bounds write of heap data in
addPixelToRaster() function (bsc#1024291).
- create netpbm-vulnerable subpackage and move pstopnm there, as
ghostscript is used to convert (bsc#1136936)


This update was imported from the SUSE:SLE-15:Update update project.


Patch Instructions:

To install this openSUSE Security Update use the SUSE recommended
installation methods
like YaST online_update or "zypper patch".

Alternatively you can run the command listed for your product:

- openSUSE Leap 15.1:

zypper in -t patch openSUSE-2019-1605=1

- openSUSE Leap 15.0:

zypper in -t patch openSUSE-2019-1605=1



Package List:

- openSUSE Leap 15.1 (i586 x86_64):

libnetpbm-devel-10.80.1-lp151.4.3.1
libnetpbm11-10.80.1-lp151.4.3.1
libnetpbm11-debuginfo-10.80.1-lp151.4.3.1
netpbm-10.80.1-lp151.4.3.1
netpbm-debuginfo-10.80.1-lp151.4.3.1
netpbm-debugsource-10.80.1-lp151.4.3.1
netpbm-vulnerable-10.80.1-lp151.4.3.1
netpbm-vulnerable-debuginfo-10.80.1-lp151.4.3.1

- openSUSE Leap 15.1 (x86_64):

libnetpbm11-32bit-10.80.1-lp151.4.3.1
libnetpbm11-32bit-debuginfo-10.80.1-lp151.4.3.1

- openSUSE Leap 15.0 (i586 x86_64):

libnetpbm-devel-10.80.1-lp150.2.6.1
libnetpbm11-10.80.1-lp150.2.6.1
libnetpbm11-debuginfo-10.80.1-lp150.2.6.1
netpbm-10.80.1-lp150.2.6.1
netpbm-debuginfo-10.80.1-lp150.2.6.1
netpbm-debugsource-10.80.1-lp150.2.6.1
netpbm-vulnerable-10.80.1-lp150.2.6.1
netpbm-vulnerable-debuginfo-10.80.1-lp150.2.6.1

- openSUSE Leap 15.0 (x86_64):

libnetpbm11-32bit-10.80.1-lp150.2.6.1
libnetpbm11-32bit-debuginfo-10.80.1-lp150.2.6.1


References:

https://www.suse.com/security/cve/CVE-2017-2579.html
https://www.suse.com/security/cve/CVE-2017-2580.html
https://bugzilla.suse.com/1024288
https://bugzilla.suse.com/1024291
https://bugzilla.suse.com/1136936

--
To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@opensuse.org
For additional commands, e-mail: opensuse-security-announce+help@opensuse.org
Pro-Linux
Traut euch!
Neue Nachrichten
Werbung