Login
Newsletter
Werbung

Sicherheit: Zwei Probleme in bzip2
Aktuelle Meldungen Distributionen
Name: Zwei Probleme in bzip2
ID: USN-4038-1
Distribution: Ubuntu
Plattformen: Ubuntu 16.04 LTS, Ubuntu 18.04 LTS, Ubuntu 18.10, Ubuntu 19.04
Datum: Mi, 26. Juni 2019, 15:51
Referenzen: https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-12900
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2016-3189
Applikationen: bzip2

Originalnachricht


--===============3919441592689332429==
Content-Type: multipart/signed; micalg=pgp-sha1;
protocol="application/pgp-signature";
boundary="RnlQjJ0d97Da+TV1"
Content-Disposition: inline


--RnlQjJ0d97Da+TV1
Content-Type: text/plain; charset=us-ascii
Content-Disposition: inline

==========================================================================
Ubuntu Security Notice USN-4038-1
June 26, 2019

bzip2 vulnerabilities
==========================================================================

A security issue affects these releases of Ubuntu and its derivatives:

- Ubuntu 19.04
- Ubuntu 18.10
- Ubuntu 18.04 LTS
- Ubuntu 16.04 LTS

Summary:

Several security issues were fixed in bzip2.

Software Description:
- bzip2: high-quality block-sorting file compressor - utilities

Details:

Aladdin Mubaied discovered that bzip2 incorrectly handled certain files.
An attacker could possibly use this issue to cause a denial of service.
This issue only affected Ubuntu 16.04 LTS. (CVE-2016-3189)

It was discovered that bzip2 incorrectly handled certain files.
An attacker could possibly use this issue to execute arbitrary code.
(CVE-2019-12900)

Update instructions:

The problem can be corrected by updating your system to the following
package versions:

Ubuntu 19.04:
bzip2 1.0.6-9ubuntu0.19.04
libbz2-1.0 1.0.6-9ubuntu0.19.04

Ubuntu 18.10:
bzip2 1.0.6-9ubuntu0.18.10
libbz2-1.0 1.0.6-9ubuntu0.18.10

Ubuntu 18.04 LTS:
bzip2 1.0.6-8.1ubuntu0.1
libbz2-1.0 1.0.6-8.1ubuntu0.1

Ubuntu 16.04 LTS:
bzip2 1.0.6-8ubuntu0.1
libbz2-1.0 1.0.6-8ubuntu0.1

In general, a standard system update will make all the necessary changes.

References:
https://usn.ubuntu.com/4038-1
CVE-2016-3189, CVE-2019-12900

Package Information:
https://launchpad.net/ubuntu/+source/bzip2/1.0.6-9ubuntu0.19.04
https://launchpad.net/ubuntu/+source/bzip2/1.0.6-9ubuntu0.18.10
https://launchpad.net/ubuntu/+source/bzip2/1.0.6-8.1ubuntu0.1
https://launchpad.net/ubuntu/+source/bzip2/1.0.6-8ubuntu0.1

--RnlQjJ0d97Da+TV1
Content-Type: application/pgp-signature; name="signature.asc"

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1

iQIcBAEBAgAGBQJdE3bgAAoJEEW851uECx9p6tEP/2S8GdoInyINBqxSXmv8p2om
zkNiS7mKd0ahMe4021lsdoqC9wiM7NRLDwGTGwLyqTrJmjYx+H4yyGX18j5dHiQ4
Nflxu7S1PfJtbmO6TD2SeeIiZUE6To9SRDApf213gMPJVAexenLx1IQ6B58K/K9J
hh0mwf8IvcQ6fNpzueo0vKlf1veGnDIkhu2djR+TUNeiRUQ+6BSR552gV6SSvYnC
FN0HkNRyLSwRSFugggFOzJD1XSvscANRNd6FBnz2aY0vsDBirhntQdt+JoJWkph8
PoeYaDX49pZttB7wSEeyn5bkIn2SwbdyymROstBR3O80EM042waSVFKIq8MImyAN
XzzVLk4p4At8UAL0E4ruLV7WrgPL6zwmJYi9+5ABNQtjafV/V709qcgBVEHTtPBo
0kdYmj9nLjCKN9O2+O/qr8X9FOiF5AoWXV8jddb2oAH5iIwwuk7HTQsnhnyc3dKb
MdpDw/bG7PuTTZYc2x94Qc0jYrFssfbKSUhc+KtXY0WbrcsOoy0ObD5XSC9/1I1P
EcuErxnBf6cdMehlFl/j02U6782HafPMWO/7ogzGXprsoMmv9p2FUrhAMVfotEBH
jeBWB+kvw1Ny3IQie9AymCYSd1JTSBBBlVFfJMmiHLe52hLvgzTGHCqm9s7ZxZNi
AxwnYJDKOxWke42flbN/
=6JOR
-----END PGP SIGNATURE-----

--RnlQjJ0d97Da+TV1--


--===============3919441592689332429==
Content-Type: text/plain; charset="utf-8"
MIME-Version: 1.0
Content-Transfer-Encoding: base64
Content-Disposition: inline

--
ubuntu-security-announce mailing list
ubuntu-security-announce@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-security-announce
Pro-Linux
Pro-Linux @Twitter
Neue Nachrichten
Werbung