Login
Newsletter
Werbung

Sicherheit: Mehrere Probleme in php5
Aktuelle Meldungen Distributionen
Name: Mehrere Probleme in php5
ID: SUSE-SU-2019:1746-1
Distribution: SUSE
Plattformen: SUSE Linux Enterprise Module for Web Scripting 12, SUSE Linux Enterprise Software Development Kit 12-SP3, SUSE Linux Enterprise Software Development Kit 12-SP4
Datum: Do, 4. Juli 2019, 15:37
Referenzen: https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-11039
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-11040
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2015-1351
Applikationen: PHP

Originalnachricht


SUSE Security Update: Security update for php5
______________________________________________________________________________

Announcement ID: SUSE-SU-2019:1746-1
Rating: moderate
References: #1137633 #1138172 #1138173
Cross-References: CVE-2015-1351 CVE-2019-11039 CVE-2019-11040

Affected Products:
SUSE Linux Enterprise Software Development Kit 12-SP4
SUSE Linux Enterprise Software Development Kit 12-SP3
SUSE Linux Enterprise Module for Web Scripting 12
______________________________________________________________________________

An update that fixes three vulnerabilities is now available.

Description:

This update for php5 fixes the following issues:

Security issues fixed:

- CVE-2019-11039: Fixed a heap-buffer-overflow on php_jpg_get16
(bsc#1138173).
- CVE-2019-11040: Fixed an out-of-bounds read due to an integer overflow
in iconv.c:_php_iconv_mime_decode() (bsc#1138172).
- CVE-2015-1351: Fixed a use after free in opcache extension (bsc#1137633).


Patch Instructions:

To install this SUSE Security Update use the SUSE recommended installation
methods
like YaST online_update or "zypper patch".

Alternatively you can run the command listed for your product:

- SUSE Linux Enterprise Software Development Kit 12-SP4:

zypper in -t patch SUSE-SLE-SDK-12-SP4-2019-1746=1

- SUSE Linux Enterprise Software Development Kit 12-SP3:

zypper in -t patch SUSE-SLE-SDK-12-SP3-2019-1746=1

- SUSE Linux Enterprise Module for Web Scripting 12:

zypper in -t patch SUSE-SLE-Module-Web-Scripting-12-2019-1746=1



Package List:

- SUSE Linux Enterprise Software Development Kit 12-SP4 (aarch64 ppc64le
s390x x86_64):

php5-debuginfo-5.5.14-109.63.2
php5-debugsource-5.5.14-109.63.2
php5-devel-5.5.14-109.63.2

- SUSE Linux Enterprise Software Development Kit 12-SP3 (aarch64 ppc64le
s390x x86_64):

php5-debuginfo-5.5.14-109.63.2
php5-debugsource-5.5.14-109.63.2
php5-devel-5.5.14-109.63.2

- SUSE Linux Enterprise Module for Web Scripting 12 (aarch64 ppc64le s390x
x86_64):

apache2-mod_php5-5.5.14-109.63.2
apache2-mod_php5-debuginfo-5.5.14-109.63.2
php5-5.5.14-109.63.2
php5-bcmath-5.5.14-109.63.2
php5-bcmath-debuginfo-5.5.14-109.63.2
php5-bz2-5.5.14-109.63.2
php5-bz2-debuginfo-5.5.14-109.63.2
php5-calendar-5.5.14-109.63.2
php5-calendar-debuginfo-5.5.14-109.63.2
php5-ctype-5.5.14-109.63.2
php5-ctype-debuginfo-5.5.14-109.63.2
php5-curl-5.5.14-109.63.2
php5-curl-debuginfo-5.5.14-109.63.2
php5-dba-5.5.14-109.63.2
php5-dba-debuginfo-5.5.14-109.63.2
php5-debuginfo-5.5.14-109.63.2
php5-debugsource-5.5.14-109.63.2
php5-dom-5.5.14-109.63.2
php5-dom-debuginfo-5.5.14-109.63.2
php5-enchant-5.5.14-109.63.2
php5-enchant-debuginfo-5.5.14-109.63.2
php5-exif-5.5.14-109.63.2
php5-exif-debuginfo-5.5.14-109.63.2
php5-fastcgi-5.5.14-109.63.2
php5-fastcgi-debuginfo-5.5.14-109.63.2
php5-fileinfo-5.5.14-109.63.2
php5-fileinfo-debuginfo-5.5.14-109.63.2
php5-fpm-5.5.14-109.63.2
php5-fpm-debuginfo-5.5.14-109.63.2
php5-ftp-5.5.14-109.63.2
php5-ftp-debuginfo-5.5.14-109.63.2
php5-gd-5.5.14-109.63.2
php5-gd-debuginfo-5.5.14-109.63.2
php5-gettext-5.5.14-109.63.2
php5-gettext-debuginfo-5.5.14-109.63.2
php5-gmp-5.5.14-109.63.2
php5-gmp-debuginfo-5.5.14-109.63.2
php5-iconv-5.5.14-109.63.2
php5-iconv-debuginfo-5.5.14-109.63.2
php5-imap-5.5.14-109.63.2
php5-imap-debuginfo-5.5.14-109.63.2
php5-intl-5.5.14-109.63.2
php5-intl-debuginfo-5.5.14-109.63.2
php5-json-5.5.14-109.63.2
php5-json-debuginfo-5.5.14-109.63.2
php5-ldap-5.5.14-109.63.2
php5-ldap-debuginfo-5.5.14-109.63.2
php5-mbstring-5.5.14-109.63.2
php5-mbstring-debuginfo-5.5.14-109.63.2
php5-mcrypt-5.5.14-109.63.2
php5-mcrypt-debuginfo-5.5.14-109.63.2
php5-mysql-5.5.14-109.63.2
php5-mysql-debuginfo-5.5.14-109.63.2
php5-odbc-5.5.14-109.63.2
php5-odbc-debuginfo-5.5.14-109.63.2
php5-opcache-5.5.14-109.63.2
php5-opcache-debuginfo-5.5.14-109.63.2
php5-openssl-5.5.14-109.63.2
php5-openssl-debuginfo-5.5.14-109.63.2
php5-pcntl-5.5.14-109.63.2
php5-pcntl-debuginfo-5.5.14-109.63.2
php5-pdo-5.5.14-109.63.2
php5-pdo-debuginfo-5.5.14-109.63.2
php5-pgsql-5.5.14-109.63.2
php5-pgsql-debuginfo-5.5.14-109.63.2
php5-phar-5.5.14-109.63.2
php5-phar-debuginfo-5.5.14-109.63.2
php5-posix-5.5.14-109.63.2
php5-posix-debuginfo-5.5.14-109.63.2
php5-pspell-5.5.14-109.63.2
php5-pspell-debuginfo-5.5.14-109.63.2
php5-shmop-5.5.14-109.63.2
php5-shmop-debuginfo-5.5.14-109.63.2
php5-snmp-5.5.14-109.63.2
php5-snmp-debuginfo-5.5.14-109.63.2
php5-soap-5.5.14-109.63.2
php5-soap-debuginfo-5.5.14-109.63.2
php5-sockets-5.5.14-109.63.2
php5-sockets-debuginfo-5.5.14-109.63.2
php5-sqlite-5.5.14-109.63.2
php5-sqlite-debuginfo-5.5.14-109.63.2
php5-suhosin-5.5.14-109.63.2
php5-suhosin-debuginfo-5.5.14-109.63.2
php5-sysvmsg-5.5.14-109.63.2
php5-sysvmsg-debuginfo-5.5.14-109.63.2
php5-sysvsem-5.5.14-109.63.2
php5-sysvsem-debuginfo-5.5.14-109.63.2
php5-sysvshm-5.5.14-109.63.2
php5-sysvshm-debuginfo-5.5.14-109.63.2
php5-tokenizer-5.5.14-109.63.2
php5-tokenizer-debuginfo-5.5.14-109.63.2
php5-wddx-5.5.14-109.63.2
php5-wddx-debuginfo-5.5.14-109.63.2
php5-xmlreader-5.5.14-109.63.2
php5-xmlreader-debuginfo-5.5.14-109.63.2
php5-xmlrpc-5.5.14-109.63.2
php5-xmlrpc-debuginfo-5.5.14-109.63.2
php5-xmlwriter-5.5.14-109.63.2
php5-xmlwriter-debuginfo-5.5.14-109.63.2
php5-xsl-5.5.14-109.63.2
php5-xsl-debuginfo-5.5.14-109.63.2
php5-zip-5.5.14-109.63.2
php5-zip-debuginfo-5.5.14-109.63.2
php5-zlib-5.5.14-109.63.2
php5-zlib-debuginfo-5.5.14-109.63.2

- SUSE Linux Enterprise Module for Web Scripting 12 (noarch):

php5-pear-5.5.14-109.63.2


References:

https://www.suse.com/security/cve/CVE-2015-1351.html
https://www.suse.com/security/cve/CVE-2019-11039.html
https://www.suse.com/security/cve/CVE-2019-11040.html
https://bugzilla.suse.com/1137633
https://bugzilla.suse.com/1138172
https://bugzilla.suse.com/1138173

_______________________________________________
sle-security-updates mailing list
sle-security-updates@lists.suse.com
http://lists.suse.com/mailman/listinfo/sle-security-updates
Pro-Linux
Traut euch!
Neue Nachrichten
Werbung