Login
Newsletter
Werbung

Sicherheit: Unsichere Verwendung temporärer Dateien in libdlm
Aktuelle Meldungen Distributionen
Name: Unsichere Verwendung temporärer Dateien in libdlm
ID: SUSE-SU-2019:1806-1
Distribution: SUSE
Plattformen: SUSE Linux Enterprise High Availability 12-SP3, SUSE Linux Enterprise Software Development Kit 12-SP4, SUSE Linux Enterprise High Availability 12-SP4
Datum: Mi, 10. Juli 2019, 16:43
Referenzen: https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-12779
Applikationen: libdlm

Originalnachricht


SUSE Security Update: Security update for libdlm, libqb
______________________________________________________________________________

Announcement ID: SUSE-SU-2019:1806-1
Rating: important
References: #1069468 #1074327 #1098449 #1137835
Cross-References: CVE-2019-12779
Affected Products:
SUSE Linux Enterprise Software Development Kit 12-SP4
SUSE Linux Enterprise High Availability 12-SP4
SUSE Linux Enterprise High Availability 12-SP3
______________________________________________________________________________

An update that solves one vulnerability and has three fixes
is now available.

Description:

This update for libdlm, libqb fixes the following issues:

libqb to version 1.0.3:

- CVE-2019-12779: Fixed an insecure treatment of IPC temporary files which
could have allowed a local attacker to overwrite privileged system files
(bsc#1137835).
- Enabled use of filesystem sockets for linux (fate#323415).
- Fixed logging with newer binutils version (bsc#1074327).

libdlm:

- Explicitly used and linked libstonithd from libpacemaker3 (bsc#1098449).


Patch Instructions:

To install this SUSE Security Update use the SUSE recommended installation
methods
like YaST online_update or "zypper patch".

Alternatively you can run the command listed for your product:

- SUSE Linux Enterprise Software Development Kit 12-SP4:

zypper in -t patch SUSE-SLE-SDK-12-SP4-2019-1806=1

- SUSE Linux Enterprise High Availability 12-SP4:

zypper in -t patch SUSE-SLE-HA-12-SP4-2019-1806=1

- SUSE Linux Enterprise High Availability 12-SP3:

zypper in -t patch SUSE-SLE-HA-12-SP3-2019-1806=1



Package List:

- SUSE Linux Enterprise Software Development Kit 12-SP4 (aarch64 ppc64le
s390x x86_64):

libdlm-debuginfo-4.0.7-3.3.2
libdlm-debugsource-4.0.7-3.3.2
libdlm-devel-4.0.7-3.3.2
libqb-debugsource-1.0.3+20171226.6d62b64-4.3.1
libqb-devel-1.0.3+20171226.6d62b64-4.3.1

- SUSE Linux Enterprise High Availability 12-SP4 (ppc64le s390x x86_64):

libdlm-4.0.7-3.3.2
libdlm-debuginfo-4.0.7-3.3.2
libdlm-debugsource-4.0.7-3.3.2
libdlm3-4.0.7-3.3.2
libdlm3-debuginfo-4.0.7-3.3.2
libqb-debugsource-1.0.3+20171226.6d62b64-4.3.1
libqb0-1.0.3+20171226.6d62b64-4.3.1
libqb0-debuginfo-1.0.3+20171226.6d62b64-4.3.1

- SUSE Linux Enterprise High Availability 12-SP3 (ppc64le s390x x86_64):

libdlm-4.0.7-3.3.2
libdlm-debuginfo-4.0.7-3.3.2
libdlm-debugsource-4.0.7-3.3.2
libdlm3-4.0.7-3.3.2
libdlm3-debuginfo-4.0.7-3.3.2
libqb-debugsource-1.0.3+20171226.6d62b64-4.3.1
libqb0-1.0.3+20171226.6d62b64-4.3.1
libqb0-debuginfo-1.0.3+20171226.6d62b64-4.3.1


References:

https://www.suse.com/security/cve/CVE-2019-12779.html
https://bugzilla.suse.com/1069468
https://bugzilla.suse.com/1074327
https://bugzilla.suse.com/1098449
https://bugzilla.suse.com/1137835

_______________________________________________
sle-security-updates mailing list
sle-security-updates@lists.suse.com
http://lists.suse.com/mailman/listinfo/sle-security-updates
Pro-Linux
Traut euch!
Neue Nachrichten
Werbung