Login
Newsletter
Werbung

Sicherheit: Ausführen beliebiger Kommandos in python3
Aktuelle Meldungen Distributionen
Name: Ausführen beliebiger Kommandos in python3
ID: SUSE-SU-2019:1352-2
Distribution: SUSE
Plattformen: SUSE Linux Enterprise Module for Open Buildservice Development Tools 15-SP1, SUSE Linux Enterprise Module for Basesystem 15-SP1, SUSE Linux Enterprise Module for Development Tools 15-SP1
Datum: Fr, 12. Juli 2019, 20:44
Referenzen: https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-9947
Applikationen: Python

Originalnachricht


SUSE Security Update: Security update for python3
______________________________________________________________________________

Announcement ID: SUSE-SU-2019:1352-2
Rating: moderate
References: #1130840 #1133452
Cross-References: CVE-2019-9947
Affected Products:
SUSE Linux Enterprise Module for Open Buildservice
Development Tools 15-SP1
SUSE Linux Enterprise Module for Development Tools 15-SP1
SUSE Linux Enterprise Module for Basesystem 15-SP1
______________________________________________________________________________

An update that solves one vulnerability and has one errata
is now available.

Description:

This update for python3 to version 3.6.8 fixes the following issues:

Security issue fixed:

- CVE-2019-9947: Fixed an issue in urllib2 which allowed CRLF injection if
the attacker controls a url parameter (bsc#1130840).

Non-security issue fixed:

- Fixed broken debuginfo packages by switching off LTO and PGO
optimization (bsc#1133452).


Patch Instructions:

To install this SUSE Security Update use the SUSE recommended installation
methods
like YaST online_update or "zypper patch".

Alternatively you can run the command listed for your product:

- SUSE Linux Enterprise Module for Open Buildservice Development Tools
15-SP1:

zypper in -t patch
SUSE-SLE-Module-Development-Tools-OBS-15-SP1-2019-1352=1

- SUSE Linux Enterprise Module for Development Tools 15-SP1:

zypper in -t patch SUSE-SLE-Module-Development-Tools-15-SP1-2019-1352=1

- SUSE Linux Enterprise Module for Basesystem 15-SP1:

zypper in -t patch SUSE-SLE-Module-Basesystem-15-SP1-2019-1352=1



Package List:

- SUSE Linux Enterprise Module for Open Buildservice Development Tools
15-SP1 (aarch64 ppc64le s390x x86_64):

python3-base-debuginfo-3.6.8-3.16.2
python3-base-debugsource-3.6.8-3.16.2
python3-testsuite-3.6.8-3.16.2
python3-testsuite-debuginfo-3.6.8-3.16.2

- SUSE Linux Enterprise Module for Open Buildservice Development Tools
15-SP1 (noarch):

python3-doc-3.6.8-3.16.2

- SUSE Linux Enterprise Module for Open Buildservice Development Tools
15-SP1 (x86_64):

libpython3_6m1_0-32bit-3.6.8-3.16.2
libpython3_6m1_0-32bit-debuginfo-3.6.8-3.16.2
python3-32bit-3.6.8-3.16.2
python3-32bit-debuginfo-3.6.8-3.16.2
python3-base-32bit-3.6.8-3.16.2
python3-base-32bit-debuginfo-3.6.8-3.16.2
python3-debugsource-3.6.8-3.16.2

- SUSE Linux Enterprise Module for Development Tools 15-SP1 (aarch64 ppc64le
s390x x86_64):

python3-base-debuginfo-3.6.8-3.16.2
python3-base-debugsource-3.6.8-3.16.2
python3-tools-3.6.8-3.16.2

- SUSE Linux Enterprise Module for Basesystem 15-SP1 (aarch64 ppc64le s390x
x86_64):

libpython3_6m1_0-3.6.8-3.16.2
libpython3_6m1_0-debuginfo-3.6.8-3.16.2
python3-3.6.8-3.16.2
python3-base-3.6.8-3.16.2
python3-base-debuginfo-3.6.8-3.16.2
python3-base-debugsource-3.6.8-3.16.2
python3-curses-3.6.8-3.16.2
python3-curses-debuginfo-3.6.8-3.16.2
python3-dbm-3.6.8-3.16.2
python3-dbm-debuginfo-3.6.8-3.16.2
python3-debuginfo-3.6.8-3.16.2
python3-debugsource-3.6.8-3.16.2
python3-devel-3.6.8-3.16.2
python3-devel-debuginfo-3.6.8-3.16.2
python3-idle-3.6.8-3.16.2
python3-tk-3.6.8-3.16.2
python3-tk-debuginfo-3.6.8-3.16.2


References:

https://www.suse.com/security/cve/CVE-2019-9947.html
https://bugzilla.suse.com/1130840
https://bugzilla.suse.com/1133452

_______________________________________________
sle-security-updates mailing list
sle-security-updates@lists.suse.com
http://lists.suse.com/mailman/listinfo/sle-security-updates
Pro-Linux
Traut euch!
Neue Nachrichten
Werbung