Login
Newsletter
Werbung

Sicherheit: Fehlerhafte Zugriffsrechte in glib2
Aktuelle Meldungen Distributionen
Name: Fehlerhafte Zugriffsrechte in glib2
ID: openSUSE-SU-2019:1749-1
Distribution: SUSE
Plattformen: SUSE openSUSE Leap 15.0
Datum: Sa, 20. Juli 2019, 12:30
Referenzen: https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-13012
Applikationen: GLib

Originalnachricht

   openSUSE Security Update: Security update for glib2
______________________________________________________________________________

Announcement ID: openSUSE-SU-2019:1749-1
Rating: moderate
References: #1139959
Cross-References: CVE-2019-13012
Affected Products:
openSUSE Leap 15.0
______________________________________________________________________________

An update that fixes one vulnerability is now available.

Description:

This update for glib2 fixes the following issues:

Security issue fixed:

- CVE-2019-13012: Fixed improper restriction of file permissions when
creating directories (bsc#1139959).

This update was imported from the SUSE:SLE-15:Update update project.


Patch Instructions:

To install this openSUSE Security Update use the SUSE recommended
installation methods
like YaST online_update or "zypper patch".

Alternatively you can run the command listed for your product:

- openSUSE Leap 15.0:

zypper in -t patch openSUSE-2019-1749=1



Package List:

- openSUSE Leap 15.0 (i586 x86_64):

glib2-debugsource-2.54.3-lp150.3.13.1
glib2-devel-2.54.3-lp150.3.13.1
glib2-devel-debuginfo-2.54.3-lp150.3.13.1
glib2-devel-static-2.54.3-lp150.3.13.1
glib2-tools-2.54.3-lp150.3.13.1
glib2-tools-debuginfo-2.54.3-lp150.3.13.1
libgio-2_0-0-2.54.3-lp150.3.13.1
libgio-2_0-0-debuginfo-2.54.3-lp150.3.13.1
libgio-fam-2.54.3-lp150.3.13.1
libgio-fam-debuginfo-2.54.3-lp150.3.13.1
libglib-2_0-0-2.54.3-lp150.3.13.1
libglib-2_0-0-debuginfo-2.54.3-lp150.3.13.1
libgmodule-2_0-0-2.54.3-lp150.3.13.1
libgmodule-2_0-0-debuginfo-2.54.3-lp150.3.13.1
libgobject-2_0-0-2.54.3-lp150.3.13.1
libgobject-2_0-0-debuginfo-2.54.3-lp150.3.13.1
libgthread-2_0-0-2.54.3-lp150.3.13.1
libgthread-2_0-0-debuginfo-2.54.3-lp150.3.13.1

- openSUSE Leap 15.0 (noarch):

gio-branding-upstream-2.54.3-lp150.3.13.1
glib2-lang-2.54.3-lp150.3.13.1

- openSUSE Leap 15.0 (x86_64):

glib2-devel-32bit-2.54.3-lp150.3.13.1
glib2-devel-32bit-debuginfo-2.54.3-lp150.3.13.1
glib2-tools-32bit-2.54.3-lp150.3.13.1
glib2-tools-32bit-debuginfo-2.54.3-lp150.3.13.1
libgio-2_0-0-32bit-2.54.3-lp150.3.13.1
libgio-2_0-0-32bit-debuginfo-2.54.3-lp150.3.13.1
libgio-fam-32bit-2.54.3-lp150.3.13.1
libgio-fam-32bit-debuginfo-2.54.3-lp150.3.13.1
libglib-2_0-0-32bit-2.54.3-lp150.3.13.1
libglib-2_0-0-32bit-debuginfo-2.54.3-lp150.3.13.1
libgmodule-2_0-0-32bit-2.54.3-lp150.3.13.1
libgmodule-2_0-0-32bit-debuginfo-2.54.3-lp150.3.13.1
libgobject-2_0-0-32bit-2.54.3-lp150.3.13.1
libgobject-2_0-0-32bit-debuginfo-2.54.3-lp150.3.13.1
libgthread-2_0-0-32bit-2.54.3-lp150.3.13.1
libgthread-2_0-0-32bit-debuginfo-2.54.3-lp150.3.13.1


References:

https://www.suse.com/security/cve/CVE-2019-13012.html
https://bugzilla.suse.com/1139959

--
To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@opensuse.org
For additional commands, e-mail: opensuse-security-announce+help@opensuse.org
Pro-Linux
Pro-Linux @Facebook
Neue Nachrichten
Werbung