Login
Newsletter
Werbung

Sicherheit: Mehrere Probleme in webkit2gtk3
Aktuelle Meldungen Distributionen
Name: Mehrere Probleme in webkit2gtk3
ID: openSUSE-SU-2019:1766-1
Distribution: SUSE
Plattformen: SUSE openSUSE Leap 15.0, SUSE openSUSE Leap 15.1
Datum: So, 21. Juli 2019, 16:15
Referenzen: https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-8608
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-8611
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-8596
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-8571
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-8609
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-8607
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-8594
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-8583
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-8587
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-8615
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-8610
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-8595
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-8584
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-6237
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-8601
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-8597
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-8623
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-8586
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-8622
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-8619
Applikationen: webkit2gtk3

Originalnachricht

   openSUSE Security Update: Security update for webkit2gtk3
______________________________________________________________________________

Announcement ID: openSUSE-SU-2019:1766-1
Rating: important
References: #1133291 #1135715
Cross-References: CVE-2019-6237 CVE-2019-8571 CVE-2019-8583
CVE-2019-8584 CVE-2019-8586 CVE-2019-8587
CVE-2019-8594 CVE-2019-8595 CVE-2019-8596
CVE-2019-8597 CVE-2019-8601 CVE-2019-8607
CVE-2019-8608 CVE-2019-8609 CVE-2019-8610
CVE-2019-8611 CVE-2019-8615 CVE-2019-8619
CVE-2019-8622 CVE-2019-8623
Affected Products:
openSUSE Leap 15.1
openSUSE Leap 15.0
______________________________________________________________________________

An update that fixes 20 vulnerabilities is now available.

Description:

This update for webkit2gtk3 to version 2.24.2 fixes the following issues:

Security issues fixed:

- CVE-2019-6237, CVE-2019-8571, CVE-2019-8583, CVE-2019-8584,
CVE-2019-8586, CVE-2019-8587, CVE-2019-8594, CVE-2019-8595,
CVE-2019-8596, CVE-2019-8597, CVE-2019-8601, CVE-2019-8607,
CVE-2019-8608, CVE-2019-8609, CVE-2019-8610, CVE-2019-8615,
CVE-2019-8611, CVE-2019-8619, CVE-2019-8622, CVE-2019-8623 (bsc#1135715).

This update was imported from the SUSE:SLE-15:Update update project.


Patch Instructions:

To install this openSUSE Security Update use the SUSE recommended
installation methods
like YaST online_update or "zypper patch".

Alternatively you can run the command listed for your product:

- openSUSE Leap 15.1:

zypper in -t patch openSUSE-2019-1766=1

- openSUSE Leap 15.0:

zypper in -t patch openSUSE-2019-1766=1



Package List:

- openSUSE Leap 15.1 (i586 x86_64):

libjavascriptcoregtk-4_0-18-2.24.2-lp151.2.3.1
libjavascriptcoregtk-4_0-18-debuginfo-2.24.2-lp151.2.3.1
libwebkit2gtk-4_0-37-2.24.2-lp151.2.3.1
libwebkit2gtk-4_0-37-debuginfo-2.24.2-lp151.2.3.1
typelib-1_0-JavaScriptCore-4_0-2.24.2-lp151.2.3.1
typelib-1_0-WebKit2-4_0-2.24.2-lp151.2.3.1
typelib-1_0-WebKit2WebExtension-4_0-2.24.2-lp151.2.3.1
webkit-jsc-4-2.24.2-lp151.2.3.1
webkit-jsc-4-debuginfo-2.24.2-lp151.2.3.1
webkit2gtk-4_0-injected-bundles-2.24.2-lp151.2.3.1
webkit2gtk-4_0-injected-bundles-debuginfo-2.24.2-lp151.2.3.1
webkit2gtk3-debugsource-2.24.2-lp151.2.3.1
webkit2gtk3-devel-2.24.2-lp151.2.3.1
webkit2gtk3-minibrowser-2.24.2-lp151.2.3.1
webkit2gtk3-minibrowser-debuginfo-2.24.2-lp151.2.3.1
webkit2gtk3-plugin-process-gtk2-2.24.2-lp151.2.3.1
webkit2gtk3-plugin-process-gtk2-debuginfo-2.24.2-lp151.2.3.1

- openSUSE Leap 15.1 (noarch):

libwebkit2gtk3-lang-2.24.2-lp151.2.3.1

- openSUSE Leap 15.1 (x86_64):

libjavascriptcoregtk-4_0-18-32bit-2.24.2-lp151.2.3.1
libjavascriptcoregtk-4_0-18-32bit-debuginfo-2.24.2-lp151.2.3.1
libwebkit2gtk-4_0-37-32bit-2.24.2-lp151.2.3.1
libwebkit2gtk-4_0-37-32bit-debuginfo-2.24.2-lp151.2.3.1

- openSUSE Leap 15.0 (i586 x86_64):

libjavascriptcoregtk-4_0-18-2.24.2-lp150.2.22.1
libjavascriptcoregtk-4_0-18-debuginfo-2.24.2-lp150.2.22.1
libwebkit2gtk-4_0-37-2.24.2-lp150.2.22.1
libwebkit2gtk-4_0-37-debuginfo-2.24.2-lp150.2.22.1
typelib-1_0-JavaScriptCore-4_0-2.24.2-lp150.2.22.1
typelib-1_0-WebKit2-4_0-2.24.2-lp150.2.22.1
typelib-1_0-WebKit2WebExtension-4_0-2.24.2-lp150.2.22.1
webkit-jsc-4-2.24.2-lp150.2.22.1
webkit-jsc-4-debuginfo-2.24.2-lp150.2.22.1
webkit2gtk-4_0-injected-bundles-2.24.2-lp150.2.22.1
webkit2gtk-4_0-injected-bundles-debuginfo-2.24.2-lp150.2.22.1
webkit2gtk3-debugsource-2.24.2-lp150.2.22.1
webkit2gtk3-devel-2.24.2-lp150.2.22.1
webkit2gtk3-minibrowser-2.24.2-lp150.2.22.1
webkit2gtk3-minibrowser-debuginfo-2.24.2-lp150.2.22.1
webkit2gtk3-plugin-process-gtk2-2.24.2-lp150.2.22.1
webkit2gtk3-plugin-process-gtk2-debuginfo-2.24.2-lp150.2.22.1

- openSUSE Leap 15.0 (noarch):

libwebkit2gtk3-lang-2.24.2-lp150.2.22.1

- openSUSE Leap 15.0 (x86_64):

libjavascriptcoregtk-4_0-18-32bit-2.24.2-lp150.2.22.1
libjavascriptcoregtk-4_0-18-32bit-debuginfo-2.24.2-lp150.2.22.1
libwebkit2gtk-4_0-37-32bit-2.24.2-lp150.2.22.1
libwebkit2gtk-4_0-37-32bit-debuginfo-2.24.2-lp150.2.22.1


References:

https://www.suse.com/security/cve/CVE-2019-6237.html
https://www.suse.com/security/cve/CVE-2019-8571.html
https://www.suse.com/security/cve/CVE-2019-8583.html
https://www.suse.com/security/cve/CVE-2019-8584.html
https://www.suse.com/security/cve/CVE-2019-8586.html
https://www.suse.com/security/cve/CVE-2019-8587.html
https://www.suse.com/security/cve/CVE-2019-8594.html
https://www.suse.com/security/cve/CVE-2019-8595.html
https://www.suse.com/security/cve/CVE-2019-8596.html
https://www.suse.com/security/cve/CVE-2019-8597.html
https://www.suse.com/security/cve/CVE-2019-8601.html
https://www.suse.com/security/cve/CVE-2019-8607.html
https://www.suse.com/security/cve/CVE-2019-8608.html
https://www.suse.com/security/cve/CVE-2019-8609.html
https://www.suse.com/security/cve/CVE-2019-8610.html
https://www.suse.com/security/cve/CVE-2019-8611.html
https://www.suse.com/security/cve/CVE-2019-8615.html
https://www.suse.com/security/cve/CVE-2019-8619.html
https://www.suse.com/security/cve/CVE-2019-8622.html
https://www.suse.com/security/cve/CVE-2019-8623.html
https://bugzilla.suse.com/1133291
https://bugzilla.suse.com/1135715

--
To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@opensuse.org
For additional commands, e-mail: opensuse-security-announce+help@opensuse.org
Pro-Linux
Traut euch!
Neue Nachrichten
Werbung