Login
Newsletter
Werbung

Sicherheit: Zwei Probleme in znc
Aktuelle Meldungen Distributionen
Name: Zwei Probleme in znc
ID: openSUSE-SU-2019:1775-1
Distribution: SUSE
Plattformen: SUSE openSUSE Leap 15.0, SUSE openSUSE Backports SLE-15, SUSE openSUSE Leap 15.1
Datum: So, 21. Juli 2019, 16:18
Referenzen: https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-9917
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-12816
Applikationen: znc

Originalnachricht

   openSUSE Security Update: Security update for znc
______________________________________________________________________________

Announcement ID: openSUSE-SU-2019:1775-1
Rating: important
References: #1130360 #1138572
Cross-References: CVE-2019-12816 CVE-2019-9917
Affected Products:
openSUSE Leap 15.1
openSUSE Leap 15.0
openSUSE Backports SLE-15
______________________________________________________________________________

An update that fixes two vulnerabilities is now available.

Description:

This update for znc to version 1.7.4 fixes the following issues:

Security issues fixed:

- CVE-2019-12816: Fixed a remote code execution in Modules.cpp
(boo#1138572).
- CVE-2019-9917: Fixed a denial of service on invalid encoding
(boo#1130360).


Patch Instructions:

To install this openSUSE Security Update use the SUSE recommended
installation methods
like YaST online_update or "zypper patch".

Alternatively you can run the command listed for your product:

- openSUSE Leap 15.1:

zypper in -t patch openSUSE-2019-1775=1

- openSUSE Leap 15.0:

zypper in -t patch openSUSE-2019-1775=1

- openSUSE Backports SLE-15:

zypper in -t patch openSUSE-2019-1775=1



Package List:

- openSUSE Leap 15.1 (x86_64):

znc-1.7.4-lp151.2.3.1
znc-debuginfo-1.7.4-lp151.2.3.1
znc-debugsource-1.7.4-lp151.2.3.1
znc-devel-1.7.4-lp151.2.3.1
znc-perl-1.7.4-lp151.2.3.1
znc-perl-debuginfo-1.7.4-lp151.2.3.1
znc-python3-1.7.4-lp151.2.3.1
znc-python3-debuginfo-1.7.4-lp151.2.3.1
znc-tcl-1.7.4-lp151.2.3.1
znc-tcl-debuginfo-1.7.4-lp151.2.3.1

- openSUSE Leap 15.1 (noarch):

znc-lang-1.7.4-lp151.2.3.1

- openSUSE Leap 15.0 (noarch):

znc-lang-1.7.4-lp150.28.1

- openSUSE Leap 15.0 (x86_64):

znc-1.7.4-lp150.28.1
znc-debuginfo-1.7.4-lp150.28.1
znc-debugsource-1.7.4-lp150.28.1
znc-devel-1.7.4-lp150.28.1
znc-perl-1.7.4-lp150.28.1
znc-perl-debuginfo-1.7.4-lp150.28.1
znc-python3-1.7.4-lp150.28.1
znc-python3-debuginfo-1.7.4-lp150.28.1
znc-tcl-1.7.4-lp150.28.1
znc-tcl-debuginfo-1.7.4-lp150.28.1

- openSUSE Backports SLE-15 (aarch64 ppc64le s390x x86_64):

znc-1.7.4-bp150.2.6.1
znc-devel-1.7.4-bp150.2.6.1
znc-perl-1.7.4-bp150.2.6.1
znc-python3-1.7.4-bp150.2.6.1
znc-tcl-1.7.4-bp150.2.6.1

- openSUSE Backports SLE-15 (noarch):

znc-lang-1.7.4-bp150.2.6.1


References:

https://www.suse.com/security/cve/CVE-2019-12816.html
https://www.suse.com/security/cve/CVE-2019-9917.html
https://bugzilla.suse.com/1130360
https://bugzilla.suse.com/1138572

--
To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@opensuse.org
For additional commands, e-mail: opensuse-security-announce+help@opensuse.org
Pro-Linux
Pro-Linux @Facebook
Neue Nachrichten
Werbung