Login
Newsletter
Werbung

Sicherheit: Preisgabe von Informationen in libgcrypt
Aktuelle Meldungen Distributionen
Name: Preisgabe von Informationen in libgcrypt
ID: openSUSE-SU-2019:1792-1
Distribution: SUSE
Plattformen: SUSE openSUSE Leap 15.0
Datum: Di, 23. Juli 2019, 19:34
Referenzen: https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-12904
Applikationen: libgcrypt

Originalnachricht

   openSUSE Security Update: Security update for libgcrypt
______________________________________________________________________________

Announcement ID: openSUSE-SU-2019:1792-1
Rating: moderate
References: #1097073 #1125740 #1138939
Cross-References: CVE-2019-12904
Affected Products:
openSUSE Leap 15.0
______________________________________________________________________________

An update that solves one vulnerability and has two fixes
is now available.

Description:

This update for libgcrypt fixes the following issues:

Security issues fixed:

- CVE-2019-12904: The C implementation of AES is vulnerable to a
flush-and-reload side-channel attack because physical addresses are
available to other processes. (The C implementation is used on platforms
where an assembly-language implementation is unavailable.) (bsc#1138939)

Other bugfixes:

- Don't run full FIPS self-tests from constructor (bsc#1097073)
- Skip all the self-tests except for binary integrity when called from the
constructor (bsc#1097073)
- Enforce the minimal RSA keygen size in fips mode (bsc#1125740)
- avoid executing some tests twice.
- Fixed a race condition in initialization.
- Fixed env-script-interpreter in cavs_driver.pl
- Fixed redundant fips tests in some situations causing failure to boot in
fips mode. (bsc#1097073)

This helps during booting of the system in FIPS mode with insufficient
entropy.

This update was imported from the SUSE:SLE-15:Update update project.


Patch Instructions:

To install this openSUSE Security Update use the SUSE recommended
installation methods
like YaST online_update or "zypper patch".

Alternatively you can run the command listed for your product:

- openSUSE Leap 15.0:

zypper in -t patch openSUSE-2019-1792=1



Package List:

- openSUSE Leap 15.0 (i586 x86_64):

libgcrypt-cavs-1.8.2-lp150.5.10.1
libgcrypt-cavs-debuginfo-1.8.2-lp150.5.10.1
libgcrypt-debugsource-1.8.2-lp150.5.10.1
libgcrypt-devel-1.8.2-lp150.5.10.1
libgcrypt-devel-debuginfo-1.8.2-lp150.5.10.1
libgcrypt20-1.8.2-lp150.5.10.1
libgcrypt20-debuginfo-1.8.2-lp150.5.10.1
libgcrypt20-hmac-1.8.2-lp150.5.10.1

- openSUSE Leap 15.0 (x86_64):

libgcrypt-devel-32bit-1.8.2-lp150.5.10.1
libgcrypt-devel-32bit-debuginfo-1.8.2-lp150.5.10.1
libgcrypt20-32bit-1.8.2-lp150.5.10.1
libgcrypt20-32bit-debuginfo-1.8.2-lp150.5.10.1
libgcrypt20-hmac-32bit-1.8.2-lp150.5.10.1


References:

https://www.suse.com/security/cve/CVE-2019-12904.html
https://bugzilla.suse.com/1097073
https://bugzilla.suse.com/1125740
https://bugzilla.suse.com/1138939

--
To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@opensuse.org
For additional commands, e-mail: opensuse-security-announce+help@opensuse.org
Pro-Linux
Pro-Linux @Facebook
Neue Nachrichten
Werbung