Login
Newsletter
Werbung

Sicherheit: Zwei Probleme in Patch
Aktuelle Meldungen Distributionen
Name: Zwei Probleme in Patch
ID: USN-4071-1
Distribution: Ubuntu
Plattformen: Ubuntu 16.04 LTS, Ubuntu 18.04 LTS, Ubuntu 19.04
Datum: Mi, 24. Juli 2019, 18:53
Referenzen: https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-13638
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-13636
Applikationen: patch

Originalnachricht


--===============4539636137958930817==
Content-Type: multipart/signed; micalg=pgp-sha1;
protocol="application/pgp-signature";
boundary="NzB8fVQJ5HfG6fxh"
Content-Disposition: inline


--NzB8fVQJ5HfG6fxh
Content-Type: text/plain; charset=us-ascii
Content-Disposition: inline

==========================================================================
Ubuntu Security Notice USN-4071-1
July 24, 2019

patch vulnerabilities
==========================================================================

A security issue affects these releases of Ubuntu and its derivatives:

- Ubuntu 19.04
- Ubuntu 18.04 LTS
- Ubuntu 16.04 LTS

Summary:

Several security issues were fixed in Patch.

Software Description:
- patch: Apply a diff file to an original

Details:

It was discovered that Patch incorrectly handled certain files.
An attacker could possibly use this issue to access sensitive information.
(CVE-2019-13636)

It was discovered that Patch incorrectly handled certain files.
An attacker could possibly use this issue to execute arbitrary code.
(CVE-2019-13638)

Update instructions:

The problem can be corrected by updating your system to the following
package versions:

Ubuntu 19.04:
patch 2.7.6-3ubuntu0.1

Ubuntu 18.04 LTS:
patch 2.7.6-2ubuntu1.1

Ubuntu 16.04 LTS:
patch 2.7.5-1ubuntu0.16.04.2

In general, a standard system update will make all the necessary changes.

References:
https://usn.ubuntu.com/4071-1
CVE-2019-13636, CVE-2019-13638

Package Information:
https://launchpad.net/ubuntu/+source/patch/2.7.6-3ubuntu0.1
https://launchpad.net/ubuntu/+source/patch/2.7.6-2ubuntu1.1
https://launchpad.net/ubuntu/+source/patch/2.7.5-1ubuntu0.16.04.2

--NzB8fVQJ5HfG6fxh
Content-Type: application/pgp-signature; name="signature.asc"

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1

iQIcBAEBAgAGBQJdOHFXAAoJEEW851uECx9p61kQAJMQOGlFpu30AxaD4toxUnXV
oVo7QrBKKrUVj9kl0vAJfegPAQN1AzhV3/Li56BkM4OpRzfsZ/0Y3Gnbf/CHT+Au
RoId/UCBelWJCQY8Peh6KpXD2HqLAlfFWRRMF3dC790B13QkxiQ9T1TXkff/1Wvu
evqcO8D4Jlx0w2ogHyqm5m41ERUhJ1Zu9lQ3HHe96yt0Lr0Y+7rYC+4Sf9OuSzlb
TirwsLB6HBOAL04MSXK48+GCdD7BmKmyuW2FQ/LlP/tgHeTx4AopyuMGtpafBaPP
cps3DEFnuzeCDUpMN3S6ARIywiSLiflYNhOYkyeBiFNAnThERj79MitFsdwyaTo4
27p79UhS8T9GRg0WUzRDJcHOslw2wEol/qCstkmgXIEnHveN4auVqV5pgmBJtCTQ
Ba0UNUATjM07JmSeXGAe7DIPUZNVNhW+T5Oq7gGxOaLwRFFQFrzlHfGFKUR3V4UC
6GY8H76UKjkPODRwTp8jxoDuqz47+3dCd6pDgd7Dpq0AjPx2DIVF8JIkdUnZMZaF
TaRHqvJEXH9vorooiKvx0HGLIImyvqfRgm7iUC6AZcCSFKiWNjdUU/ypgMFfhwnl
hhQq/e+ikNNYXe4ToYWtWVgb+HT/ID6kl835AnARn33LdIoCJSEeJeF6zCaPlWLq
rk6AZykxut/lU9UWO1Yn
=QTe+
-----END PGP SIGNATURE-----

--NzB8fVQJ5HfG6fxh--


--===============4539636137958930817==
Content-Type: text/plain; charset="utf-8"
MIME-Version: 1.0
Content-Transfer-Encoding: base64
Content-Disposition: inline

--
ubuntu-security-announce mailing list
ubuntu-security-announce@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-security-announce
Pro-Linux
Pro-Linux @Facebook
Neue Nachrichten
Werbung