Login
Newsletter
Werbung

Sicherheit: Pufferüberlauf in qemu-kvm-ma
Aktuelle Meldungen Distributionen
Name: Pufferüberlauf in qemu-kvm-ma
ID: RHSA-2019:1881-01
Distribution: Red Hat
Plattformen: Red Hat Enterprise Linux
Datum: Mo, 29. Juli 2019, 17:41
Referenzen: https://access.redhat.com/security/cve/CVE-2018-20815
Applikationen: QEMU

Originalnachricht

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA256

=====================================================================
Red Hat Security Advisory

Synopsis: Important: qemu-kvm-ma security and bug fix update
Advisory ID: RHSA-2019:1881-01
Product: Red Hat Enterprise Linux
Advisory URL: https://access.redhat.com/errata/RHSA-2019:1881
Issue date: 2019-07-29
CVE Names: CVE-2018-20815
=====================================================================

1. Summary:

An update for qemu-kvm-ma is now available for Red Hat Enterprise Linux 7.

Red Hat Product Security has rated this update as having a security impact
of Important. A Common Vulnerability Scoring System (CVSS) base score,
which gives a detailed severity rating, is available for each vulnerability
from the CVE link(s) in the References section.

2. Relevant releases/architectures:

Red Hat Enterprise Linux Server (v. 7) - ppc64, ppc64le, s390x
Red Hat Enterprise Linux Server Optional (v. 7) - ppc64
Red Hat Enterprise Linux for ARM and IBM Power LE (POWER9) Server (v. 7) -
ppc64le, s390x
Red Hat Enterprise Linux for ARM and IBM Power LE (POWER9) Server Optional (v.
7) - aarch64

3. Description:

Kernel-based Virtual Machine (KVM) is a full virtualization solution for
Linux on a variety of architectures. The qemu-kvm-ma packages provide the
user-space component for running virtual machines that use KVM on the IBM z
Systems, IBM Power, and 64-bit ARM architectures.

Security Fix(es):

* QEMU: device_tree: heap buffer overflow while loading device tree blob
(CVE-2018-20815)

For more details about the security issue(s), including the impact, a CVSS
score, acknowledgments, and other related information, refer to the CVE
page(s) listed in the References section.

Bug Fix(es):

* As newer machine remove csske feature, detection of the processor fail
and machine used old version as fallback. This update make feature
conditional so detection of newer cpu works properly. (BZ#1720262)

4. Solution:

For details on how to apply this update, which includes the changes
described in this advisory, refer to:

https://access.redhat.com/articles/11258

After installing this update, shut down all running virtual machines. Once
all virtual machines have shut down, start them again for this update to
take effect.

5. Bugs fixed (https://bugzilla.redhat.com/):

1693101 - CVE-2018-20815 QEMU: device_tree: heap buffer overflow while loading
device tree blob

6. Package List:

Red Hat Enterprise Linux Server (v. 7):

Source:
qemu-kvm-ma-2.12.0-18.el7_6.4.src.rpm

ppc64:
qemu-img-ma-2.12.0-18.el7_6.4.ppc64.rpm
qemu-kvm-ma-debuginfo-2.12.0-18.el7_6.4.ppc64.rpm

ppc64le:
qemu-img-ma-2.12.0-18.el7_6.4.ppc64le.rpm
qemu-kvm-common-ma-2.12.0-18.el7_6.4.ppc64le.rpm
qemu-kvm-ma-2.12.0-18.el7_6.4.ppc64le.rpm
qemu-kvm-ma-debuginfo-2.12.0-18.el7_6.4.ppc64le.rpm
qemu-kvm-tools-ma-2.12.0-18.el7_6.4.ppc64le.rpm

s390x:
qemu-img-ma-2.12.0-18.el7_6.4.s390x.rpm
qemu-kvm-common-ma-2.12.0-18.el7_6.4.s390x.rpm
qemu-kvm-ma-2.12.0-18.el7_6.4.s390x.rpm
qemu-kvm-ma-debuginfo-2.12.0-18.el7_6.4.s390x.rpm
qemu-kvm-tools-ma-2.12.0-18.el7_6.4.s390x.rpm

Red Hat Enterprise Linux for ARM and IBM Power LE (POWER9) Server (v. 7):

Source:
qemu-kvm-ma-2.12.0-18.el7_6.4.src.rpm

ppc64le:
qemu-img-ma-2.12.0-18.el7_6.4.ppc64le.rpm
qemu-kvm-common-ma-2.12.0-18.el7_6.4.ppc64le.rpm
qemu-kvm-ma-2.12.0-18.el7_6.4.ppc64le.rpm
qemu-kvm-ma-debuginfo-2.12.0-18.el7_6.4.ppc64le.rpm
qemu-kvm-tools-ma-2.12.0-18.el7_6.4.ppc64le.rpm

s390x:
qemu-img-ma-2.12.0-18.el7_6.4.s390x.rpm
qemu-kvm-common-ma-2.12.0-18.el7_6.4.s390x.rpm
qemu-kvm-ma-2.12.0-18.el7_6.4.s390x.rpm
qemu-kvm-ma-debuginfo-2.12.0-18.el7_6.4.s390x.rpm
qemu-kvm-tools-ma-2.12.0-18.el7_6.4.s390x.rpm

Red Hat Enterprise Linux Server Optional (v. 7):

ppc64:
qemu-kvm-common-ma-2.12.0-18.el7_6.4.ppc64.rpm
qemu-kvm-ma-2.12.0-18.el7_6.4.ppc64.rpm
qemu-kvm-ma-debuginfo-2.12.0-18.el7_6.4.ppc64.rpm
qemu-kvm-tools-ma-2.12.0-18.el7_6.4.ppc64.rpm

Red Hat Enterprise Linux for ARM and IBM Power LE (POWER9) Server Optional (v.
7):

Source:
qemu-kvm-ma-2.12.0-18.el7_6.4.src.rpm

aarch64:
qemu-img-ma-2.12.0-18.el7_6.4.aarch64.rpm
qemu-kvm-common-ma-2.12.0-18.el7_6.4.aarch64.rpm
qemu-kvm-ma-2.12.0-18.el7_6.4.aarch64.rpm
qemu-kvm-ma-debuginfo-2.12.0-18.el7_6.4.aarch64.rpm
qemu-kvm-tools-ma-2.12.0-18.el7_6.4.aarch64.rpm

These packages are GPG signed by Red Hat for security. Our key and
details on how to verify the signature are available from
https://access.redhat.com/security/team/key/

7. References:

https://access.redhat.com/security/cve/CVE-2018-20815
https://access.redhat.com/security/updates/classification/#important

8. Contact:

The Red Hat security contact is <secalert@redhat.com>. More contact
details at https://access.redhat.com/security/team/contact/

Copyright 2019 Red Hat, Inc.
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1

iQIVAwUBXT8OKNzjgjWX9erEAQgzYw//SLY7/gIByzXIsNutj4f8SjHJ5m2gYQjD
niqBb7oBklXSF40dqfCeS6nGlsQFyZvqMwxv3hZY0uVxeIBRq7YD5WcB+hTctj09
pnj/btwjI82/5tW0AROJRL689Yi8n+yEA8OHtuySpSDr6iX0c6bPvEDwjwezrnMR
k8M7EzWfQFQe1Z+9qrwb3HE1QKtsLocXhiHqxhVrODQrYChLcJ4HZlJDURE49dA3
URGBszxdSxrBd6shm8mseWRLXa3oUV0CUqvsBDKl3ocYhqqn5AS+z39oeZ+DMtDf
rnujGMhDDGk8xjRqvGjmjyZnH2kl/NCLdUMaUZJlLglvpJgWRNWjVbWgQiz5DVja
J1wbYWaK4Fwv9ux3eZ9GjxS3AAix00wxppKkXdjKaeIe7GFCbtNZVuO+uo4WqxZJ
6GJDmIGyEVLJBd8Nf/+IByhvg2+28XKlqz+nJTZfq6I6gsLdRydtY0togHMkcZxY
7P5UOvkzaP6SaP+0T39SdrFzvMaggvHEjsxeeLHV5H09yQ+j+B/9bUZFSBHD+jxY
4ezFolXllNkMUiG5DCwaYUPekLvSGL57m+1XAMhyO3werT14oNMG4SIwaN9Lblny
jOo3CW6moSBbx2qZ/Le5+cThXQnrv5KgNt/kpf/nmc27WWFd0zRmy3kzO/JF/KTN
zlADpzi+dIs=
=X7LW
-----END PGP SIGNATURE-----

--
RHSA-announce mailing list
RHSA-announce@redhat.com
https://www.redhat.com/mailman/listinfo/rhsa-announce
Pro-Linux
Pro-Linux @Facebook
Neue Nachrichten
Werbung