Login
Newsletter
Werbung

Sicherheit: Ausführen beliebiger Kommandos in zstd
Aktuelle Meldungen Distributionen
Name: Ausführen beliebiger Kommandos in zstd
ID: openSUSE-SU-2019:1845-1
Distribution: SUSE
Plattformen: SUSE openSUSE Leap 15.1
Datum: Mo, 12. August 2019, 23:03
Referenzen: https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-11922
Applikationen: zstd

Originalnachricht

   openSUSE Security Update: Security update for zstd
______________________________________________________________________________

Announcement ID: openSUSE-SU-2019:1845-1
Rating: moderate
References: #1082318 #1133297 #1142941
Cross-References: CVE-2019-11922
Affected Products:
openSUSE Leap 15.1
______________________________________________________________________________

An update that solves one vulnerability and has two fixes
is now available.

Description:

This update for zstd to version 1.4.2 fixes the following issues:

Security issues fixed:

- CVE-2019-11922: Fixed race condition in one-pass compression functions
that could allow out of bounds write (boo#1142941).

Non-security issues fixed:

- Added --[no-]compress-literals CLI flag to enable or disable literal
compression.
- Added new --rsyncable mode.
- Added handling of -f flag to zstdgrep.
- Added CPU load indicator for each file on -vv mode.
- Changed --no-progress flag to preserve the final summary.
- Added new command --adapt for compressed network piping of data adjusted
to the perceived network conditions.


Patch Instructions:

To install this openSUSE Security Update use the SUSE recommended
installation methods
like YaST online_update or "zypper patch".

Alternatively you can run the command listed for your product:

- openSUSE Leap 15.1:

zypper in -t patch openSUSE-2019-1845=1



Package List:

- openSUSE Leap 15.1 (i586 x86_64):

libzstd-devel-1.4.2-lp151.3.3.1
libzstd-devel-static-1.4.2-lp151.3.3.1
libzstd1-1.4.2-lp151.3.3.1
libzstd1-debuginfo-1.4.2-lp151.3.3.1
zstd-1.4.2-lp151.3.3.1
zstd-debuginfo-1.4.2-lp151.3.3.1
zstd-debugsource-1.4.2-lp151.3.3.1

- openSUSE Leap 15.1 (x86_64):

libzstd1-32bit-1.4.2-lp151.3.3.1
libzstd1-32bit-debuginfo-1.4.2-lp151.3.3.1


References:

https://www.suse.com/security/cve/CVE-2019-11922.html
https://bugzilla.suse.com/1082318
https://bugzilla.suse.com/1133297
https://bugzilla.suse.com/1142941

--
To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@opensuse.org
For additional commands, e-mail: opensuse-security-announce+help@opensuse.org
Pro-Linux
Traut euch!
Neue Nachrichten
Werbung