Login
Newsletter
Werbung

Sicherheit: Mangelnde Prüfung von Zertifikaten in jss
Aktuelle Meldungen Distributionen
Name: Mangelnde Prüfung von Zertifikaten in jss
ID: RHSA-2019:3067-01
Distribution: Red Hat
Plattformen: Red Hat Enterprise Linux
Datum: Di, 15. Oktober 2019, 23:14
Referenzen: https://access.redhat.com/security/cve/CVE-2019-14823
Applikationen: JSS

Originalnachricht

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA256

=====================================================================
Red Hat Security Advisory

Synopsis: Important: jss security update
Advisory ID: RHSA-2019:3067-01
Product: Red Hat Enterprise Linux
Advisory URL: https://access.redhat.com/errata/RHSA-2019:3067
Issue date: 2019-10-15
CVE Names: CVE-2019-14823
=====================================================================

1. Summary:

An update for jss is now available for Red Hat Enterprise Linux 7.

Red Hat Product Security has rated this update as having a security impact
of Important. A Common Vulnerability Scoring System (CVSS) base score,
which gives a detailed severity rating, is available for each vulnerability
from the CVE link(s) in the References section.

2. Relevant releases/architectures:

Red Hat Enterprise Linux Client (v. 7) - x86_64
Red Hat Enterprise Linux Client Optional (v. 7) - x86_64
Red Hat Enterprise Linux ComputeNode (v. 7) - x86_64
Red Hat Enterprise Linux ComputeNode Optional (v. 7) - x86_64
Red Hat Enterprise Linux Server (v. 7) - ppc64, ppc64le, s390x, x86_64
Red Hat Enterprise Linux Server Optional (v. 7) - ppc64, ppc64le, s390x, x86_64
Red Hat Enterprise Linux Workstation (v. 7) - x86_64
Red Hat Enterprise Linux Workstation Optional (v. 7) - x86_64

3. Description:

Java Security Services (JSS) provides an interface between Java Virtual
Machine and Network Security Services (NSS). It supports most of the
security standards and encryption technologies supported by NSS including
communication through SSL/TLS network protocols. JSS is primarily utilized
by the Certificate Server as a part of the Identity Management System.

Security Fix(es):

* JSS: OCSP policy "Leaf and Chain" implicitly trusts the root
certificate
(CVE-2019-14823)

For more details about the security issue(s), including the impact, a CVSS
score, acknowledgments, and other related information, refer to the CVE
page(s) listed in the References section.

4. Solution:

For details on how to apply this update, which includes the changes
described in this advisory, refer to:

https://access.redhat.com/articles/11258

5. Bugs fixed (https://bugzilla.redhat.com/):

1747435 - CVE-2019-14823 JSS: OCSP policy "Leaf and Chain" implicitly
trusts the root certificate

6. Package List:

Red Hat Enterprise Linux Client (v. 7):

Source:
jss-4.4.6-3.el7_7.src.rpm

x86_64:
jss-4.4.6-3.el7_7.x86_64.rpm
jss-debuginfo-4.4.6-3.el7_7.x86_64.rpm

Red Hat Enterprise Linux Client Optional (v. 7):

x86_64:
jss-debuginfo-4.4.6-3.el7_7.x86_64.rpm
jss-javadoc-4.4.6-3.el7_7.x86_64.rpm

Red Hat Enterprise Linux ComputeNode (v. 7):

Source:
jss-4.4.6-3.el7_7.src.rpm

x86_64:
jss-4.4.6-3.el7_7.x86_64.rpm
jss-debuginfo-4.4.6-3.el7_7.x86_64.rpm

Red Hat Enterprise Linux ComputeNode Optional (v. 7):

x86_64:
jss-debuginfo-4.4.6-3.el7_7.x86_64.rpm
jss-javadoc-4.4.6-3.el7_7.x86_64.rpm

Red Hat Enterprise Linux Server (v. 7):

Source:
jss-4.4.6-3.el7_7.src.rpm

ppc64:
jss-4.4.6-3.el7_7.ppc64.rpm
jss-debuginfo-4.4.6-3.el7_7.ppc64.rpm

ppc64le:
jss-4.4.6-3.el7_7.ppc64le.rpm
jss-debuginfo-4.4.6-3.el7_7.ppc64le.rpm

s390x:
jss-4.4.6-3.el7_7.s390x.rpm
jss-debuginfo-4.4.6-3.el7_7.s390x.rpm

x86_64:
jss-4.4.6-3.el7_7.x86_64.rpm
jss-debuginfo-4.4.6-3.el7_7.x86_64.rpm

Red Hat Enterprise Linux Server Optional (v. 7):

ppc64:
jss-debuginfo-4.4.6-3.el7_7.ppc64.rpm
jss-javadoc-4.4.6-3.el7_7.ppc64.rpm

ppc64le:
jss-debuginfo-4.4.6-3.el7_7.ppc64le.rpm
jss-javadoc-4.4.6-3.el7_7.ppc64le.rpm

s390x:
jss-debuginfo-4.4.6-3.el7_7.s390x.rpm
jss-javadoc-4.4.6-3.el7_7.s390x.rpm

x86_64:
jss-debuginfo-4.4.6-3.el7_7.x86_64.rpm
jss-javadoc-4.4.6-3.el7_7.x86_64.rpm

Red Hat Enterprise Linux Workstation (v. 7):

Source:
jss-4.4.6-3.el7_7.src.rpm

x86_64:
jss-4.4.6-3.el7_7.x86_64.rpm
jss-debuginfo-4.4.6-3.el7_7.x86_64.rpm

Red Hat Enterprise Linux Workstation Optional (v. 7):

x86_64:
jss-debuginfo-4.4.6-3.el7_7.x86_64.rpm
jss-javadoc-4.4.6-3.el7_7.x86_64.rpm

These packages are GPG signed by Red Hat for security. Our key and
details on how to verify the signature are available from
https://access.redhat.com/security/team/key/

7. References:

https://access.redhat.com/security/cve/CVE-2019-14823
https://access.redhat.com/security/updates/classification/#important

8. Contact:

The Red Hat security contact is <secalert@redhat.com>. More contact
details at https://access.redhat.com/security/team/contact/

Copyright 2019 Red Hat, Inc.
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1

iQIVAwUBXaYG2dzjgjWX9erEAQgl4g//ewrQoDnHj/0NSspcLsuSGJXO8QdmejJz
StEKgBRw7oEKYKY3nVabUv0VKewaNtiaL8ZyxzQAq7Kp1+CnG2dA3mp08qA8Qua3
3KvjKN7d+/Y1BqfzIhom3uPqDWxTigkePbx9Ln2WnT+Yhv04zqbxsT9Dcuv6YbET
AxxHQvwiSDDiCiHNAQi0DAXncBWfW1hjWIGAIofYuI5HHzlOo6BOyWkMNtnLFgcZ
ljSHMcvLVbgFbSjpSIM2wM/bSUZXJhxxiCdA3T8Shi8EL04UB7uEsCpCEUKJ9wed
1kLWvhKG1hLnaAl9L0taKUlMStMWVmzIgBr2vsoDpdJOpaQn3In8VmTBnQIQj/A+
CgAp7NzZg+pRbKtGaQg0fTTktXTef2NlahSye41v1GVaxgJeyeGcxlVzVPFibBQt
T3OFe0hXKMjPmO99Rz+cr/cDJpD2m1uXrOnAGfkTAewXVyBNPOrpG50hodMda7gP
q2mtO5FCmExX7dQm1LyxitKNKg6dJbXwCi+QYTcqyPT1mY3pf7cXfrFVZ8ZXO+xY
7PPB3+L/09vBt1vSvSfndzBXx+aMt3zQq1D+l4Y3MfXXkm0nTTUj3ZKKymyNS1ey
AFeBpxt181bvq42pH1xqNTQXH8EZZmNTIeaXe9sK7N7/4HYZ/MVSf2DcZ1JopFP+
ypW9kz0D1CM=
=AWDo
-----END PGP SIGNATURE-----

--
RHSA-announce mailing list
RHSA-announce@redhat.com
https://www.redhat.com/mailman/listinfo/rhsa-announce
Pro-Linux
Pro-Linux @Twitter
Neue Nachrichten
Werbung