Login
Newsletter
Werbung

Sicherheit: Preisgabe von Informationen in cpio
Aktuelle Meldungen Distributionen
Name: Preisgabe von Informationen in cpio
ID: openSUSE-SU-2019:2593-1
Distribution: SUSE
Plattformen: SUSE openSUSE Leap 15.0
Datum: So, 1. Dezember 2019, 00:24
Referenzen: https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-14866
Applikationen: GNU cpio

Originalnachricht

   openSUSE Security Update: Security update for cpio
______________________________________________________________________________

Announcement ID: openSUSE-SU-2019:2593-1
Rating: moderate
References: #1155199
Cross-References: CVE-2019-14866
Affected Products:
openSUSE Leap 15.0
______________________________________________________________________________

An update that fixes one vulnerability is now available.

Description:

This update for cpio fixes the following issues:

- CVE-2019-14866: Fixed an improper validation of the values written in
the header of a TAR file through the to_oct() function which could have
led to unexpected TAR generation (bsc#1155199).

This update was imported from the SUSE:SLE-15:Update update project.


Patch Instructions:

To install this openSUSE Security Update use the SUSE recommended
installation methods
like YaST online_update or "zypper patch".

Alternatively you can run the command listed for your product:

- openSUSE Leap 15.0:

zypper in -t patch openSUSE-2019-2593=1



Package List:

- openSUSE Leap 15.0 (i586 x86_64):

cpio-2.12-lp150.2.3.1
cpio-debuginfo-2.12-lp150.2.3.1
cpio-debugsource-2.12-lp150.2.3.1
cpio-mt-2.12-lp150.2.3.1
cpio-mt-debuginfo-2.12-lp150.2.3.1

- openSUSE Leap 15.0 (noarch):

cpio-lang-2.12-lp150.2.3.1


References:

https://www.suse.com/security/cve/CVE-2019-14866.html
https://bugzilla.suse.com/1155199

--
To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@opensuse.org
For additional commands, e-mail: opensuse-security-announce+help@opensuse.org
Pro-Linux
Unterstützer werden
Neue Nachrichten
Werbung