Login
Newsletter
Werbung

Sicherheit: Zwei Probleme in freerdp
Aktuelle Meldungen Distributionen
Name: Zwei Probleme in freerdp
ID: openSUSE-SU-2019:2604-1
Distribution: SUSE
Plattformen: SUSE openSUSE Leap 15.0
Datum: Mo, 2. Dezember 2019, 06:53
Referenzen: https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-17177
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-17178
Applikationen: FreeRDP

Originalnachricht

   openSUSE Security Update: Security update for freerdp
______________________________________________________________________________

Announcement ID: openSUSE-SU-2019:2604-1
Rating: moderate
References: #1153163 #1153164
Cross-References: CVE-2019-17177 CVE-2019-17178
Affected Products:
openSUSE Leap 15.0
______________________________________________________________________________

An update that fixes two vulnerabilities is now available.

Description:

This update for freerdp fixes the following issues:

- CVE-2019-17177: Fixed multiple memory leaks in libfreerdp/codec/region.c
(bsc#1153163).
- CVE-2019-17178: Fixed a memory leak in HuffmanTree_makeFromFrequencies
(bsc#1153164).

This update was imported from the SUSE:SLE-15:Update update project.


Patch Instructions:

To install this openSUSE Security Update use the SUSE recommended
installation methods
like YaST online_update or "zypper patch".

Alternatively you can run the command listed for your product:

- openSUSE Leap 15.0:

zypper in -t patch openSUSE-2019-2604=1



Package List:

- openSUSE Leap 15.0 (x86_64):

freerdp-2.0.0~rc4-lp150.10.1
freerdp-debuginfo-2.0.0~rc4-lp150.10.1
freerdp-debugsource-2.0.0~rc4-lp150.10.1
freerdp-devel-2.0.0~rc4-lp150.10.1
freerdp-server-2.0.0~rc4-lp150.10.1
freerdp-server-debuginfo-2.0.0~rc4-lp150.10.1
freerdp-wayland-2.0.0~rc4-lp150.10.1
freerdp-wayland-debuginfo-2.0.0~rc4-lp150.10.1
libfreerdp2-2.0.0~rc4-lp150.10.1
libfreerdp2-debuginfo-2.0.0~rc4-lp150.10.1
libuwac0-0-2.0.0~rc4-lp150.10.1
libuwac0-0-debuginfo-2.0.0~rc4-lp150.10.1
libwinpr2-2.0.0~rc4-lp150.10.1
libwinpr2-debuginfo-2.0.0~rc4-lp150.10.1
uwac0-0-devel-2.0.0~rc4-lp150.10.1
winpr2-devel-2.0.0~rc4-lp150.10.1


References:

https://www.suse.com/security/cve/CVE-2019-17177.html
https://www.suse.com/security/cve/CVE-2019-17178.html
https://bugzilla.suse.com/1153163
https://bugzilla.suse.com/1153164

--
To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@opensuse.org
For additional commands, e-mail: opensuse-security-announce+help@opensuse.org
Pro-Linux
Unterstützer werden
Neue Nachrichten
Werbung