Login
Newsletter
Werbung

Sicherheit: Mangelnde Rechteprüfung in netty
Aktuelle Meldungen Distributionen
Name: Mangelnde Rechteprüfung in netty
ID: DSA-4597-1
Distribution: Debian
Plattformen: Debian stretch, Debian buster
Datum: Fr, 3. Januar 2020, 17:41
Referenzen: https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-16869
Applikationen: Netty

Originalnachricht

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA512

- -------------------------------------------------------------------------
Debian Security Advisory DSA-4597-1 security@debian.org
https://www.debian.org/security/ Salvatore Bonaccorso
January 03, 2020 https://www.debian.org/security/faq
- -------------------------------------------------------------------------

Package : netty
CVE ID : CVE-2019-16869
Debian Bug : 941266

It was reported that Netty, a Java NIO client/server framework, is prone
to a HTTP request smuggling vulnerability due to mishandling whitespace
before the colon in HTTP headers.

For the oldstable distribution (stretch), this problem has been fixed
in version 1:4.1.7-2+deb9u1.

For the stable distribution (buster), this problem has been fixed in
version 1:4.1.33-1+deb10u1.

We recommend that you upgrade your netty packages.

For the detailed security status of netty please refer to its security
tracker page at:
https://security-tracker.debian.org/tracker/netty

Further information about Debian Security Advisories, how to apply
these updates to your system and frequently asked questions can be
found at: https://www.debian.org/security/

Mailing list: debian-security-announce@lists.debian.org
-----BEGIN PGP SIGNATURE-----

iQKTBAEBCgB9FiEERkRAmAjBceBVMd3uBUy48xNDz0QFAl4PVeFfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDQ2
NDQ0MDk4MDhDMTcxRTA1NTMxRERFRTA1NENCOEYzMTM0M0NGNDQACgkQBUy48xND
z0Rvvg/5AcQaA29qcRnnjCiATy7h7EenrJ1/K7KQ897hOa954t/meMp+QfeoEQnm
N8iGlCZYZEnkiZNGODcr7H9G9yzHK9IginFT3IXBQtRgOl7+Xbh1FqVDdTDvS+KE
+Ybl8uwJXK7gTAdz8GULE7e4AT4XXZRwMlGzlnQJwz4MugqPx63VAAL0esKlEChn
QnoFoyN2NtgXBAatNhyTCPOOCd3e3Z2xLcdEGvPFwJ6cPocCR1yny+apR/KYyrE1
HbWrYTE0zbDth07byyQreRcs+2WAwH5xpKlTtoJb0SpAv2YtOfFe4hSrTkWkQRzB
kkcEwJSKv27ouFUE8W9IipLjDG+BEnm+GMPxSl70Cc4Qk8L5qFbyzAFYy86RXi+x
oCE1jTFYrLidwoAuHre0z3d6ftRQNNuPuCWM5UImf0oK8NnZDm5eSIkRudC5lVru
0VUyK4SPyFEgsUVCg9y1uh4gmKRkCzAa6HQsQaE1/sKcR+XuZysd6XY+egvbUVnP
Ux+akAbkHvDf2972ukN/M737j1YpH5eYBemBPZico5haYibTC2/GMXGXhfoNubRG
/RKN6jlyUOCToB3C8R2C+dhCb3j3+tDOlMVFL4SjslUg3C2ZW/u8ng3Rl679Lm5N
oD95oVpvnn2rrQxelCgzM/tS799yKQ7/gFdQJnHKEUx+8T9n/EU=
=reXs
-----END PGP SIGNATURE-----
Pro-Linux
Unterstützer werden
Neue Nachrichten
Werbung