Login
Newsletter
Werbung

Sicherheit: Mehrere Probleme in tomcat
Aktuelle Meldungen Distributionen
Name: Mehrere Probleme in tomcat
ID: openSUSE-SU-2020:0038-1
Distribution: SUSE
Plattformen: SUSE openSUSE Leap 15.1
Datum: Di, 14. Januar 2020, 07:05
Referenzen: https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-12418
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-17563
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-10072
Applikationen: Apache Tomcat

Originalnachricht

   openSUSE Security Update: Security update for tomcat
______________________________________________________________________________

Announcement ID: openSUSE-SU-2020:0038-1
Rating: important
References: #1139924 #1159723 #1159729
Cross-References: CVE-2019-10072 CVE-2019-12418 CVE-2019-17563

Affected Products:
openSUSE Leap 15.1
______________________________________________________________________________

An update that fixes three vulnerabilities is now available.

Description:

This update for tomcat to version 9.0.30 fixes the following issues:

Security issue fixed:

- CVE-2019-12418: Fixed a local privilege escalation through by
manipulating the RMI registry and performing a man-in-the-middle attack
(bsc#1159723).
- CVE-2019-17563: Fixed a session fixation attack when using FORM
authentication (bsc#1159729).

This update was imported from the SUSE:SLE-15-SP1:Update update project.


Patch Instructions:

To install this openSUSE Security Update use the SUSE recommended
installation methods
like YaST online_update or "zypper patch".

Alternatively you can run the command listed for your product:

- openSUSE Leap 15.1:

zypper in -t patch openSUSE-2020-38=1



Package List:

- openSUSE Leap 15.1 (noarch):

tomcat-9.0.30-lp151.3.6.1
tomcat-admin-webapps-9.0.30-lp151.3.6.1
tomcat-docs-webapp-9.0.30-lp151.3.6.1
tomcat-el-3_0-api-9.0.30-lp151.3.6.1
tomcat-embed-9.0.30-lp151.3.6.1
tomcat-javadoc-9.0.30-lp151.3.6.1
tomcat-jsp-2_3-api-9.0.30-lp151.3.6.1
tomcat-jsvc-9.0.30-lp151.3.6.1
tomcat-lib-9.0.30-lp151.3.6.1
tomcat-servlet-4_0-api-9.0.30-lp151.3.6.1
tomcat-webapps-9.0.30-lp151.3.6.1


References:

https://www.suse.com/security/cve/CVE-2019-10072.html
https://www.suse.com/security/cve/CVE-2019-12418.html
https://www.suse.com/security/cve/CVE-2019-17563.html
https://bugzilla.suse.com/1139924
https://bugzilla.suse.com/1159723
https://bugzilla.suse.com/1159729

--
To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@opensuse.org
For additional commands, e-mail: opensuse-security-announce+help@opensuse.org
Pro-Linux
Traut euch!
Neue Nachrichten
Werbung