Login
Newsletter
Werbung

Sicherheit: Mehrere Probleme in libvpx
Aktuelle Meldungen Distributionen
Name: Mehrere Probleme in libvpx
ID: SUSE-SU-2020:0143-1
Distribution: SUSE
Plattformen: SUSE Linux Enterprise Module for Basesystem 15, SUSE Linux Enterprise Module for Desktop Applications 15, SUSE Linux Enterprise Module for Open Buildservice Development Tools 15, SUSE Linux Enterprise Module for Packagehub Subpackages 15, SUSE Linux Enterprise Module for Open Buildservice Development Tools 15-SP1, SUSE Linux Enterprise Module for Desktop Applications 15-SP1, SUSE Linux Enterprise Module for Basesystem 15-SP1, SUSE Linux Enterprise Server 15-LTSS, SUSE Linux Enterprise High Performance Computing 15-ESPOS, SUSE Linux Enterprise Server for SAP 15, SUSE Linux Enterprise High Performance Computing 15-LTSS
Datum: Mo, 20. Januar 2020, 22:59
Referenzen: https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-9232
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-9371
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-2126
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-9325
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-9433
Applikationen: libvpx

Originalnachricht


SUSE Security Update: Security update for libvpx
______________________________________________________________________________

Announcement ID: SUSE-SU-2020:0143-1
Rating: important
References: #1160611 #1160612 #1160613 #1160614 #1160615

Cross-References: CVE-2019-2126 CVE-2019-9232 CVE-2019-9325
CVE-2019-9371 CVE-2019-9433
Affected Products:
SUSE Linux Enterprise Server for SAP 15
SUSE Linux Enterprise Server 15-LTSS
SUSE Linux Enterprise Module for Packagehub Subpackages 15
SUSE Linux Enterprise Module for Open Buildservice
Development Tools 15-SP1
SUSE Linux Enterprise Module for Open Buildservice
Development Tools 15
SUSE Linux Enterprise Module for Desktop Applications
15-SP1
SUSE Linux Enterprise Module for Desktop Applications 15
SUSE Linux Enterprise Module for Basesystem 15-SP1
SUSE Linux Enterprise Module for Basesystem 15
SUSE Linux Enterprise High Performance Computing 15-LTSS
SUSE Linux Enterprise High Performance Computing 15-ESPOS
______________________________________________________________________________

An update that fixes 5 vulnerabilities is now available.

Description:

This update for libvpx fixes the following issues:

- CVE-2019-2126: Fixed a double free in ParseContentEncodingEntry()
(bsc#1160611).
- CVE-2019-9325: Fixed an out-of-bounds read (bsc#1160612).
- CVE-2019-9232: Fixed an out-of-bounds memory access on fuzzed data
(bsc#1160613).
- CVE-2019-9433: Fixed a use-after-free in vp8_deblock() (bsc#1160614).
- CVE-2019-9371: Fixed a resource exhaustion after memory leak
(bsc#1160615).


Patch Instructions:

To install this SUSE Security Update use the SUSE recommended installation
methods
like YaST online_update or "zypper patch".

Alternatively you can run the command listed for your product:

- SUSE Linux Enterprise Server for SAP 15:

zypper in -t patch SUSE-SLE-Product-SLES_SAP-15-2020-143=1

- SUSE Linux Enterprise Server 15-LTSS:

zypper in -t patch SUSE-SLE-Product-SLES-15-2020-143=1

- SUSE Linux Enterprise Module for Packagehub Subpackages 15:

zypper in -t patch SUSE-SLE-Module-Packagehub-Subpackages-15-2020-143=1

- SUSE Linux Enterprise Module for Open Buildservice Development Tools
15-SP1:

zypper in -t patch
SUSE-SLE-Module-Development-Tools-OBS-15-SP1-2020-143=1

- SUSE Linux Enterprise Module for Open Buildservice Development Tools 15:

zypper in -t patch SUSE-SLE-Module-Development-Tools-OBS-15-2020-143=1

- SUSE Linux Enterprise Module for Desktop Applications 15-SP1:

zypper in -t patch SUSE-SLE-Module-Desktop-Applications-15-SP1-2020-143=1

- SUSE Linux Enterprise Module for Desktop Applications 15:

zypper in -t patch SUSE-SLE-Module-Desktop-Applications-15-2020-143=1

- SUSE Linux Enterprise Module for Basesystem 15-SP1:

zypper in -t patch SUSE-SLE-Module-Basesystem-15-SP1-2020-143=1

- SUSE Linux Enterprise Module for Basesystem 15:

zypper in -t patch SUSE-SLE-Module-Basesystem-15-2020-143=1

- SUSE Linux Enterprise High Performance Computing 15-LTSS:

zypper in -t patch SUSE-SLE-Product-HPC-15-2020-143=1

- SUSE Linux Enterprise High Performance Computing 15-ESPOS:

zypper in -t patch SUSE-SLE-Product-HPC-15-2020-143=1



Package List:

- SUSE Linux Enterprise Server for SAP 15 (ppc64le x86_64):

libvpx-debugsource-1.6.1-6.3.1
libvpx4-1.6.1-6.3.1
libvpx4-debuginfo-1.6.1-6.3.1

- SUSE Linux Enterprise Server 15-LTSS (aarch64 s390x):

libvpx-debugsource-1.6.1-6.3.1
libvpx4-1.6.1-6.3.1
libvpx4-debuginfo-1.6.1-6.3.1

- SUSE Linux Enterprise Module for Packagehub Subpackages 15 (aarch64
ppc64le s390x x86_64):

libvpx-debugsource-1.6.1-6.3.1
vpx-tools-1.6.1-6.3.1
vpx-tools-debuginfo-1.6.1-6.3.1

- SUSE Linux Enterprise Module for Open Buildservice Development Tools
15-SP1 (aarch64 ppc64le s390x x86_64):

libvpx-debugsource-1.6.1-6.3.1
vpx-tools-1.6.1-6.3.1
vpx-tools-debuginfo-1.6.1-6.3.1

- SUSE Linux Enterprise Module for Open Buildservice Development Tools
15-SP1 (x86_64):

libvpx4-32bit-1.6.1-6.3.1
libvpx4-32bit-debuginfo-1.6.1-6.3.1

- SUSE Linux Enterprise Module for Open Buildservice Development Tools 15
(aarch64 ppc64le s390x x86_64):

libvpx-debugsource-1.6.1-6.3.1
vpx-tools-1.6.1-6.3.1
vpx-tools-debuginfo-1.6.1-6.3.1

- SUSE Linux Enterprise Module for Desktop Applications 15-SP1 (aarch64
ppc64le s390x x86_64):

libvpx-debugsource-1.6.1-6.3.1
libvpx-devel-1.6.1-6.3.1

- SUSE Linux Enterprise Module for Desktop Applications 15 (aarch64 ppc64le
s390x x86_64):

libvpx-debugsource-1.6.1-6.3.1
libvpx-devel-1.6.1-6.3.1

- SUSE Linux Enterprise Module for Basesystem 15-SP1 (aarch64 ppc64le s390x
x86_64):

libvpx-debugsource-1.6.1-6.3.1
libvpx4-1.6.1-6.3.1
libvpx4-debuginfo-1.6.1-6.3.1

- SUSE Linux Enterprise Module for Basesystem 15 (aarch64 ppc64le s390x
x86_64):

libvpx-debugsource-1.6.1-6.3.1
libvpx4-1.6.1-6.3.1
libvpx4-debuginfo-1.6.1-6.3.1

- SUSE Linux Enterprise High Performance Computing 15-LTSS (aarch64 x86_64):

libvpx-debugsource-1.6.1-6.3.1
libvpx4-1.6.1-6.3.1
libvpx4-debuginfo-1.6.1-6.3.1

- SUSE Linux Enterprise High Performance Computing 15-ESPOS (aarch64
x86_64):

libvpx-debugsource-1.6.1-6.3.1
libvpx4-1.6.1-6.3.1
libvpx4-debuginfo-1.6.1-6.3.1


References:

https://www.suse.com/security/cve/CVE-2019-2126.html
https://www.suse.com/security/cve/CVE-2019-9232.html
https://www.suse.com/security/cve/CVE-2019-9325.html
https://www.suse.com/security/cve/CVE-2019-9371.html
https://www.suse.com/security/cve/CVE-2019-9433.html
https://bugzilla.suse.com/1160611
https://bugzilla.suse.com/1160612
https://bugzilla.suse.com/1160613
https://bugzilla.suse.com/1160614
https://bugzilla.suse.com/1160615

_______________________________________________
sle-security-updates mailing list
sle-security-updates@lists.suse.com
http://lists.suse.com/mailman/listinfo/sle-security-updates
Pro-Linux
Unterstützer werden
Neue Nachrichten
Werbung