Login
Newsletter
Werbung

Sicherheit: Zwei Probleme in ImageMagick
Aktuelle Meldungen Distributionen
Name: Zwei Probleme in ImageMagick
ID: SUSE-SU-2020:0275-1
Distribution: SUSE
Plattformen: SUSE Linux Enterprise Module for Development Tools 15, SUSE Linux Enterprise Module for Desktop Applications 15, SUSE Linux Enterprise Module for Open Buildservice Development Tools 15, SUSE Linux Enterprise Module for Open Buildservice Development Tools 15-SP1, SUSE Linux Enterprise Module for Desktop Applications 15-SP1, SUSE Linux Enterprise Module for Development Tools 15-SP1
Datum: Do, 30. Januar 2020, 21:40
Referenzen: https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-19948
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-19949
Applikationen: ImageMagick

Originalnachricht


SUSE Security Update: Security update for ImageMagick
______________________________________________________________________________

Announcement ID: SUSE-SU-2020:0275-1
Rating: moderate
References: #1159861 #1160369 #1161194
Cross-References: CVE-2019-19948 CVE-2019-19949
Affected Products:
SUSE Linux Enterprise Module for Open Buildservice
Development Tools 15-SP1
SUSE Linux Enterprise Module for Open Buildservice
Development Tools 15
SUSE Linux Enterprise Module for Development Tools 15-SP1
SUSE Linux Enterprise Module for Development Tools 15
SUSE Linux Enterprise Module for Desktop Applications
15-SP1
SUSE Linux Enterprise Module for Desktop Applications 15
______________________________________________________________________________

An update that solves two vulnerabilities and has one
errata is now available.

Description:

This update for ImageMagick fixes the following issues:

Security issue fixed:

- CVE-2019-19948: Fixed a heap-based buffer overflow in WriteSGIImage()
(bsc#1159861).
- CVE-2019-19949: Fixed a heap-based buffer over-read in WritePNGImage()
(bsc#1160369).

Non-security issue fixed:

- Fixed an issue where converting tiff to png would lead to unviewable
files (bsc#1161194).


Patch Instructions:

To install this SUSE Security Update use the SUSE recommended installation
methods
like YaST online_update or "zypper patch".

Alternatively you can run the command listed for your product:

- SUSE Linux Enterprise Module for Open Buildservice Development Tools
15-SP1:

zypper in -t patch
SUSE-SLE-Module-Development-Tools-OBS-15-SP1-2020-275=1

- SUSE Linux Enterprise Module for Open Buildservice Development Tools 15:

zypper in -t patch SUSE-SLE-Module-Development-Tools-OBS-15-2020-275=1

- SUSE Linux Enterprise Module for Development Tools 15-SP1:

zypper in -t patch SUSE-SLE-Module-Development-Tools-15-SP1-2020-275=1

- SUSE Linux Enterprise Module for Development Tools 15:

zypper in -t patch SUSE-SLE-Module-Development-Tools-15-2020-275=1

- SUSE Linux Enterprise Module for Desktop Applications 15-SP1:

zypper in -t patch SUSE-SLE-Module-Desktop-Applications-15-SP1-2020-275=1

- SUSE Linux Enterprise Module for Desktop Applications 15:

zypper in -t patch SUSE-SLE-Module-Desktop-Applications-15-2020-275=1



Package List:

- SUSE Linux Enterprise Module for Open Buildservice Development Tools
15-SP1 (aarch64 ppc64le s390x x86_64):

ImageMagick-config-7-upstream-7.0.7.34-3.79.1
ImageMagick-debuginfo-7.0.7.34-3.79.1
ImageMagick-debugsource-7.0.7.34-3.79.1
ImageMagick-extra-7.0.7.34-3.79.1
ImageMagick-extra-debuginfo-7.0.7.34-3.79.1

- SUSE Linux Enterprise Module for Open Buildservice Development Tools
15-SP1 (x86_64):

ImageMagick-devel-32bit-7.0.7.34-3.79.1
libMagick++-7_Q16HDRI4-32bit-7.0.7.34-3.79.1
libMagick++-7_Q16HDRI4-32bit-debuginfo-7.0.7.34-3.79.1
libMagick++-devel-32bit-7.0.7.34-3.79.1
libMagickCore-7_Q16HDRI6-32bit-7.0.7.34-3.79.1
libMagickCore-7_Q16HDRI6-32bit-debuginfo-7.0.7.34-3.79.1
libMagickWand-7_Q16HDRI6-32bit-7.0.7.34-3.79.1
libMagickWand-7_Q16HDRI6-32bit-debuginfo-7.0.7.34-3.79.1

- SUSE Linux Enterprise Module for Open Buildservice Development Tools
15-SP1 (noarch):

ImageMagick-doc-7.0.7.34-3.79.1

- SUSE Linux Enterprise Module for Open Buildservice Development Tools 15
(aarch64 ppc64le s390x x86_64):

ImageMagick-debuginfo-7.0.7.34-3.79.1
ImageMagick-debugsource-7.0.7.34-3.79.1
ImageMagick-extra-7.0.7.34-3.79.1
ImageMagick-extra-debuginfo-7.0.7.34-3.79.1

- SUSE Linux Enterprise Module for Open Buildservice Development Tools 15
(noarch):

ImageMagick-doc-7.0.7.34-3.79.1

- SUSE Linux Enterprise Module for Development Tools 15-SP1 (aarch64 ppc64le
s390x x86_64):

ImageMagick-debuginfo-7.0.7.34-3.79.1
ImageMagick-debugsource-7.0.7.34-3.79.1
perl-PerlMagick-7.0.7.34-3.79.1
perl-PerlMagick-debuginfo-7.0.7.34-3.79.1

- SUSE Linux Enterprise Module for Development Tools 15 (aarch64 ppc64le
s390x x86_64):

ImageMagick-debuginfo-7.0.7.34-3.79.1
ImageMagick-debugsource-7.0.7.34-3.79.1
perl-PerlMagick-7.0.7.34-3.79.1
perl-PerlMagick-debuginfo-7.0.7.34-3.79.1

- SUSE Linux Enterprise Module for Desktop Applications 15-SP1 (aarch64
ppc64le s390x x86_64):

ImageMagick-7.0.7.34-3.79.1
ImageMagick-config-7-SUSE-7.0.7.34-3.79.1
ImageMagick-debuginfo-7.0.7.34-3.79.1
ImageMagick-debugsource-7.0.7.34-3.79.1
ImageMagick-devel-7.0.7.34-3.79.1
libMagick++-7_Q16HDRI4-7.0.7.34-3.79.1
libMagick++-7_Q16HDRI4-debuginfo-7.0.7.34-3.79.1
libMagick++-devel-7.0.7.34-3.79.1
libMagickCore-7_Q16HDRI6-7.0.7.34-3.79.1
libMagickCore-7_Q16HDRI6-debuginfo-7.0.7.34-3.79.1
libMagickWand-7_Q16HDRI6-7.0.7.34-3.79.1
libMagickWand-7_Q16HDRI6-debuginfo-7.0.7.34-3.79.1

- SUSE Linux Enterprise Module for Desktop Applications 15 (aarch64 ppc64le
s390x x86_64):

ImageMagick-7.0.7.34-3.79.1
ImageMagick-config-7-SUSE-7.0.7.34-3.79.1
ImageMagick-config-7-upstream-7.0.7.34-3.79.1
ImageMagick-debuginfo-7.0.7.34-3.79.1
ImageMagick-debugsource-7.0.7.34-3.79.1
ImageMagick-devel-7.0.7.34-3.79.1
libMagick++-7_Q16HDRI4-7.0.7.34-3.79.1
libMagick++-7_Q16HDRI4-debuginfo-7.0.7.34-3.79.1
libMagick++-devel-7.0.7.34-3.79.1
libMagickCore-7_Q16HDRI6-7.0.7.34-3.79.1
libMagickCore-7_Q16HDRI6-debuginfo-7.0.7.34-3.79.1
libMagickWand-7_Q16HDRI6-7.0.7.34-3.79.1
libMagickWand-7_Q16HDRI6-debuginfo-7.0.7.34-3.79.1


References:

https://www.suse.com/security/cve/CVE-2019-19948.html
https://www.suse.com/security/cve/CVE-2019-19949.html
https://bugzilla.suse.com/1159861
https://bugzilla.suse.com/1160369
https://bugzilla.suse.com/1161194

_______________________________________________
sle-security-updates mailing list
sle-security-updates@lists.suse.com
http://lists.suse.com/mailman/listinfo/sle-security-updates
Pro-Linux
Pro-Linux @Facebook
Neue Nachrichten
Werbung