Login
Newsletter
Werbung

Sicherheit: Ausführen beliebiger Kommandos in e2fsprogs
Aktuelle Meldungen Distributionen
Name: Ausführen beliebiger Kommandos in e2fsprogs
ID: openSUSE-SU-2020:0166-1
Distribution: SUSE
Plattformen: SUSE openSUSE Leap 15.1
Datum: Mi, 5. Februar 2020, 07:40
Referenzen: https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-5188
Applikationen: e2fsprogs

Originalnachricht

   openSUSE Security Update: Security update for e2fsprogs
______________________________________________________________________________

Announcement ID: openSUSE-SU-2020:0166-1
Rating: moderate
References: #1160571
Cross-References: CVE-2019-5188
Affected Products:
openSUSE Leap 15.1
______________________________________________________________________________

An update that fixes one vulnerability is now available.

Description:

This update for e2fsprogs fixes the following issues:

- CVE-2019-5188: Fixed a code execution vulnerability in the directory
rehashing functionality (bsc#1160571).

This update was imported from the SUSE:SLE-15:Update update project.


Patch Instructions:

To install this openSUSE Security Update use the SUSE recommended
installation methods
like YaST online_update or "zypper patch".

Alternatively you can run the command listed for your product:

- openSUSE Leap 15.1:

zypper in -t patch openSUSE-2020-166=1



Package List:

- openSUSE Leap 15.1 (i586 x86_64):

e2fsprogs-1.43.8-lp151.5.12.1
e2fsprogs-debuginfo-1.43.8-lp151.5.12.1
e2fsprogs-debugsource-1.43.8-lp151.5.12.1
e2fsprogs-devel-1.43.8-lp151.5.12.1
libcom_err-devel-1.43.8-lp151.5.12.1
libcom_err-devel-static-1.43.8-lp151.5.12.1
libcom_err2-1.43.8-lp151.5.12.1
libcom_err2-debuginfo-1.43.8-lp151.5.12.1
libext2fs-devel-1.43.8-lp151.5.12.1
libext2fs-devel-static-1.43.8-lp151.5.12.1
libext2fs2-1.43.8-lp151.5.12.1
libext2fs2-debuginfo-1.43.8-lp151.5.12.1

- openSUSE Leap 15.1 (x86_64):

e2fsprogs-32bit-debuginfo-1.43.8-lp151.5.12.1
libcom_err-devel-32bit-1.43.8-lp151.5.12.1
libcom_err2-32bit-1.43.8-lp151.5.12.1
libcom_err2-32bit-debuginfo-1.43.8-lp151.5.12.1
libext2fs-devel-32bit-1.43.8-lp151.5.12.1
libext2fs2-32bit-1.43.8-lp151.5.12.1
libext2fs2-32bit-debuginfo-1.43.8-lp151.5.12.1


References:

https://www.suse.com/security/cve/CVE-2019-5188.html
https://bugzilla.suse.com/1160571

--
To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@opensuse.org
For additional commands, e-mail: opensuse-security-announce+help@opensuse.org
Pro-Linux
Pro-Linux @Facebook
Neue Nachrichten
Werbung