Login
Newsletter
Werbung

Sicherheit: Ausführen beliebiger Kommandos in libqt5-qtbase
Aktuelle Meldungen Distributionen
Name: Ausführen beliebiger Kommandos in libqt5-qtbase
ID: openSUSE-SU-2020:0209-1
Distribution: SUSE
Plattformen: SUSE openSUSE Leap 15.1
Datum: Mi, 12. Februar 2020, 07:11
Referenzen: https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2020-0569
Applikationen: Qt

Originalnachricht

   openSUSE Security Update: Security update for libqt5-qtbase
______________________________________________________________________________

Announcement ID: openSUSE-SU-2020:0209-1
Rating: important
References: #1158667 #1161167
Cross-References: CVE-2020-0569
Affected Products:
openSUSE Leap 15.1
______________________________________________________________________________

An update that solves one vulnerability and has one errata
is now available.

Description:

This update for libqt5-qtbase fixes the following issues:

Security issue fixed:

- CVE-2020-0569: Fixed a potential local code execution by loading plugins
from CWD (bsc#1161167).

Other issue fixed:

- Fixed comboboxes not showing in correct location (bsc#1158667).

This update was imported from the SUSE:SLE-15-SP1:Update update project.


Patch Instructions:

To install this openSUSE Security Update use the SUSE recommended
installation methods
like YaST online_update or "zypper patch".

Alternatively you can run the command listed for your product:

- openSUSE Leap 15.1:

zypper in -t patch openSUSE-2020-209=1



Package List:

- openSUSE Leap 15.1 (i586 x86_64):

libQt5Bootstrap-devel-static-5.9.7-lp151.4.3.1
libQt5Concurrent-devel-5.9.7-lp151.4.3.1
libQt5Concurrent5-5.9.7-lp151.4.3.1
libQt5Concurrent5-debuginfo-5.9.7-lp151.4.3.1
libQt5Core-devel-5.9.7-lp151.4.3.1
libQt5Core5-5.9.7-lp151.4.3.1
libQt5Core5-debuginfo-5.9.7-lp151.4.3.1
libQt5DBus-devel-5.9.7-lp151.4.3.1
libQt5DBus-devel-debuginfo-5.9.7-lp151.4.3.1
libQt5DBus5-5.9.7-lp151.4.3.1
libQt5DBus5-debuginfo-5.9.7-lp151.4.3.1
libQt5Gui-devel-5.9.7-lp151.4.3.1
libQt5Gui5-5.9.7-lp151.4.3.1
libQt5Gui5-debuginfo-5.9.7-lp151.4.3.1
libQt5KmsSupport-devel-static-5.9.7-lp151.4.3.1
libQt5Network-devel-5.9.7-lp151.4.3.1
libQt5Network5-5.9.7-lp151.4.3.1
libQt5Network5-debuginfo-5.9.7-lp151.4.3.1
libQt5OpenGL-devel-5.9.7-lp151.4.3.1
libQt5OpenGL5-5.9.7-lp151.4.3.1
libQt5OpenGL5-debuginfo-5.9.7-lp151.4.3.1
libQt5OpenGLExtensions-devel-static-5.9.7-lp151.4.3.1
libQt5PlatformHeaders-devel-5.9.7-lp151.4.3.1
libQt5PlatformSupport-devel-static-5.9.7-lp151.4.3.1
libQt5PrintSupport-devel-5.9.7-lp151.4.3.1
libQt5PrintSupport5-5.9.7-lp151.4.3.1
libQt5PrintSupport5-debuginfo-5.9.7-lp151.4.3.1
libQt5Sql-devel-5.9.7-lp151.4.3.1
libQt5Sql5-5.9.7-lp151.4.3.1
libQt5Sql5-debuginfo-5.9.7-lp151.4.3.1
libQt5Sql5-mysql-5.9.7-lp151.4.3.1
libQt5Sql5-mysql-debuginfo-5.9.7-lp151.4.3.1
libQt5Sql5-postgresql-5.9.7-lp151.4.3.1
libQt5Sql5-postgresql-debuginfo-5.9.7-lp151.4.3.1
libQt5Sql5-sqlite-5.9.7-lp151.4.3.1
libQt5Sql5-sqlite-debuginfo-5.9.7-lp151.4.3.1
libQt5Sql5-unixODBC-5.9.7-lp151.4.3.1
libQt5Sql5-unixODBC-debuginfo-5.9.7-lp151.4.3.1
libQt5Test-devel-5.9.7-lp151.4.3.1
libQt5Test5-5.9.7-lp151.4.3.1
libQt5Test5-debuginfo-5.9.7-lp151.4.3.1
libQt5Widgets-devel-5.9.7-lp151.4.3.1
libQt5Widgets5-5.9.7-lp151.4.3.1
libQt5Widgets5-debuginfo-5.9.7-lp151.4.3.1
libQt5Xml-devel-5.9.7-lp151.4.3.1
libQt5Xml5-5.9.7-lp151.4.3.1
libQt5Xml5-debuginfo-5.9.7-lp151.4.3.1
libqt5-qtbase-common-devel-5.9.7-lp151.4.3.1
libqt5-qtbase-common-devel-debuginfo-5.9.7-lp151.4.3.1
libqt5-qtbase-debugsource-5.9.7-lp151.4.3.1
libqt5-qtbase-devel-5.9.7-lp151.4.3.1
libqt5-qtbase-examples-5.9.7-lp151.4.3.1
libqt5-qtbase-examples-debuginfo-5.9.7-lp151.4.3.1
libqt5-qtbase-platformtheme-gtk3-5.9.7-lp151.4.3.1
libqt5-qtbase-platformtheme-gtk3-debuginfo-5.9.7-lp151.4.3.1

- openSUSE Leap 15.1 (noarch):

libQt5Core-private-headers-devel-5.9.7-lp151.4.3.1
libQt5DBus-private-headers-devel-5.9.7-lp151.4.3.1
libQt5Gui-private-headers-devel-5.9.7-lp151.4.3.1
libQt5KmsSupport-private-headers-devel-5.9.7-lp151.4.3.1
libQt5Network-private-headers-devel-5.9.7-lp151.4.3.1
libQt5OpenGL-private-headers-devel-5.9.7-lp151.4.3.1
libQt5PlatformSupport-private-headers-devel-5.9.7-lp151.4.3.1
libQt5PrintSupport-private-headers-devel-5.9.7-lp151.4.3.1
libQt5Sql-private-headers-devel-5.9.7-lp151.4.3.1
libQt5Test-private-headers-devel-5.9.7-lp151.4.3.1
libQt5Widgets-private-headers-devel-5.9.7-lp151.4.3.1
libqt5-qtbase-private-headers-devel-5.9.7-lp151.4.3.1

- openSUSE Leap 15.1 (x86_64):

libQt5Bootstrap-devel-static-32bit-5.9.7-lp151.4.3.1
libQt5Concurrent-devel-32bit-5.9.7-lp151.4.3.1
libQt5Concurrent5-32bit-5.9.7-lp151.4.3.1
libQt5Concurrent5-32bit-debuginfo-5.9.7-lp151.4.3.1
libQt5Core-devel-32bit-5.9.7-lp151.4.3.1
libQt5Core5-32bit-5.9.7-lp151.4.3.1
libQt5Core5-32bit-debuginfo-5.9.7-lp151.4.3.1
libQt5DBus-devel-32bit-5.9.7-lp151.4.3.1
libQt5DBus-devel-32bit-debuginfo-5.9.7-lp151.4.3.1
libQt5DBus5-32bit-5.9.7-lp151.4.3.1
libQt5DBus5-32bit-debuginfo-5.9.7-lp151.4.3.1
libQt5Gui-devel-32bit-5.9.7-lp151.4.3.1
libQt5Gui5-32bit-5.9.7-lp151.4.3.1
libQt5Gui5-32bit-debuginfo-5.9.7-lp151.4.3.1
libQt5Network-devel-32bit-5.9.7-lp151.4.3.1
libQt5Network5-32bit-5.9.7-lp151.4.3.1
libQt5Network5-32bit-debuginfo-5.9.7-lp151.4.3.1
libQt5OpenGL-devel-32bit-5.9.7-lp151.4.3.1
libQt5OpenGL5-32bit-5.9.7-lp151.4.3.1
libQt5OpenGL5-32bit-debuginfo-5.9.7-lp151.4.3.1
libQt5OpenGLExtensions-devel-static-32bit-5.9.7-lp151.4.3.1
libQt5PlatformSupport-devel-static-32bit-5.9.7-lp151.4.3.1
libQt5PrintSupport-devel-32bit-5.9.7-lp151.4.3.1
libQt5PrintSupport5-32bit-5.9.7-lp151.4.3.1
libQt5PrintSupport5-32bit-debuginfo-5.9.7-lp151.4.3.1
libQt5Sql-devel-32bit-5.9.7-lp151.4.3.1
libQt5Sql5-32bit-5.9.7-lp151.4.3.1
libQt5Sql5-32bit-debuginfo-5.9.7-lp151.4.3.1
libQt5Sql5-mysql-32bit-5.9.7-lp151.4.3.1
libQt5Sql5-mysql-32bit-debuginfo-5.9.7-lp151.4.3.1
libQt5Sql5-postgresql-32bit-5.9.7-lp151.4.3.1
libQt5Sql5-postgresql-32bit-debuginfo-5.9.7-lp151.4.3.1
libQt5Sql5-sqlite-32bit-5.9.7-lp151.4.3.1
libQt5Sql5-sqlite-32bit-debuginfo-5.9.7-lp151.4.3.1
libQt5Sql5-unixODBC-32bit-5.9.7-lp151.4.3.1
libQt5Sql5-unixODBC-32bit-debuginfo-5.9.7-lp151.4.3.1
libQt5Test-devel-32bit-5.9.7-lp151.4.3.1
libQt5Test5-32bit-5.9.7-lp151.4.3.1
libQt5Test5-32bit-debuginfo-5.9.7-lp151.4.3.1
libQt5Widgets-devel-32bit-5.9.7-lp151.4.3.1
libQt5Widgets5-32bit-5.9.7-lp151.4.3.1
libQt5Widgets5-32bit-debuginfo-5.9.7-lp151.4.3.1
libQt5Xml-devel-32bit-5.9.7-lp151.4.3.1
libQt5Xml5-32bit-5.9.7-lp151.4.3.1
libQt5Xml5-32bit-debuginfo-5.9.7-lp151.4.3.1
libqt5-qtbase-examples-32bit-5.9.7-lp151.4.3.1
libqt5-qtbase-examples-32bit-debuginfo-5.9.7-lp151.4.3.1


References:

https://www.suse.com/security/cve/CVE-2020-0569.html
https://bugzilla.suse.com/1158667
https://bugzilla.suse.com/1161167

--
To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@opensuse.org
For additional commands, e-mail: opensuse-security-announce+help@opensuse.org
Pro-Linux
Pro-Linux @Facebook
Neue Nachrichten
Werbung