Login
Newsletter
Werbung

Sicherheit: Mehrere Probleme in nodejs10
Aktuelle Meldungen Distributionen
Name: Mehrere Probleme in nodejs10
ID: SUSE-SU-2020:0455-1
Distribution: SUSE
Plattformen: SUSE Linux Enterprise Module for Web Scripting 15, SUSE Linux Enterprise Module for Web Scripting 15-SP1, SUSE Linux Enterprise Server 15-LTSS, SUSE Linux Enterprise High Performance Computing 15-ESPOS, SUSE Linux Enterprise Server for SAP 15, SUSE Linux Enterprise High Performance Computing 15-LTSS
Datum: Di, 25. Februar 2020, 16:27
Referenzen: https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-15604
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-15606
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-15605
Applikationen: node.js

Originalnachricht


SUSE Security Update: Security update for nodejs10
______________________________________________________________________________

Announcement ID: SUSE-SU-2020:0455-1
Rating: important
References: #1163102 #1163103 #1163104
Cross-References: CVE-2019-15604 CVE-2019-15605 CVE-2019-15606

Affected Products:
SUSE Linux Enterprise Server for SAP 15
SUSE Linux Enterprise Server 15-LTSS
SUSE Linux Enterprise Module for Web Scripting 15-SP1
SUSE Linux Enterprise Module for Web Scripting 15
SUSE Linux Enterprise High Performance Computing 15-LTSS
SUSE Linux Enterprise High Performance Computing 15-ESPOS
______________________________________________________________________________

An update that fixes three vulnerabilities is now available.

Description:

This update for nodejs10 fixes the following issues:

nodejs10 was updated to version 10.19.0.

Security issues fixed:

- CVE-2019-15604: Fixed a remotely triggerable assertion in the TLS server
via a crafted certificate string (CVE-2019-15604, bsc#1163104).
- CVE-2019-15605: Fixed an HTTP request smuggling vulnerability via
malformed Transfer-Encoding header (CVE-2019-15605, bsc#1163102).
- CVE-2019-15606: Fixed the white space sanitation of HTTP headers
(CVE-2019-15606, bsc#1163103).


Patch Instructions:

To install this SUSE Security Update use the SUSE recommended installation
methods
like YaST online_update or "zypper patch".

Alternatively you can run the command listed for your product:

- SUSE Linux Enterprise Server for SAP 15:

zypper in -t patch SUSE-SLE-Product-SLES_SAP-15-2020-455=1

- SUSE Linux Enterprise Server 15-LTSS:

zypper in -t patch SUSE-SLE-Product-SLES-15-2020-455=1

- SUSE Linux Enterprise Module for Web Scripting 15-SP1:

zypper in -t patch SUSE-SLE-Module-Web-Scripting-15-SP1-2020-455=1

- SUSE Linux Enterprise Module for Web Scripting 15:

zypper in -t patch SUSE-SLE-Module-Web-Scripting-15-2020-455=1

- SUSE Linux Enterprise High Performance Computing 15-LTSS:

zypper in -t patch SUSE-SLE-Product-HPC-15-2020-455=1

- SUSE Linux Enterprise High Performance Computing 15-ESPOS:

zypper in -t patch SUSE-SLE-Product-HPC-15-2020-455=1



Package List:

- SUSE Linux Enterprise Server for SAP 15 (ppc64le x86_64):

nodejs10-10.19.0-1.18.1
nodejs10-debuginfo-10.19.0-1.18.1
nodejs10-debugsource-10.19.0-1.18.1
nodejs10-devel-10.19.0-1.18.1
npm10-10.19.0-1.18.1

- SUSE Linux Enterprise Server for SAP 15 (noarch):

nodejs10-docs-10.19.0-1.18.1

- SUSE Linux Enterprise Server 15-LTSS (aarch64 s390x):

nodejs10-10.19.0-1.18.1
nodejs10-debuginfo-10.19.0-1.18.1
nodejs10-debugsource-10.19.0-1.18.1
nodejs10-devel-10.19.0-1.18.1
npm10-10.19.0-1.18.1

- SUSE Linux Enterprise Server 15-LTSS (noarch):

nodejs10-docs-10.19.0-1.18.1

- SUSE Linux Enterprise Module for Web Scripting 15-SP1 (aarch64 ppc64le
s390x x86_64):

nodejs10-10.19.0-1.18.1
nodejs10-debuginfo-10.19.0-1.18.1
nodejs10-debugsource-10.19.0-1.18.1
nodejs10-devel-10.19.0-1.18.1
npm10-10.19.0-1.18.1

- SUSE Linux Enterprise Module for Web Scripting 15-SP1 (noarch):

nodejs10-docs-10.19.0-1.18.1

- SUSE Linux Enterprise Module for Web Scripting 15 (aarch64 ppc64le s390x
x86_64):

nodejs10-10.19.0-1.18.1
nodejs10-debuginfo-10.19.0-1.18.1
nodejs10-debugsource-10.19.0-1.18.1
nodejs10-devel-10.19.0-1.18.1
npm10-10.19.0-1.18.1

- SUSE Linux Enterprise Module for Web Scripting 15 (noarch):

nodejs10-docs-10.19.0-1.18.1

- SUSE Linux Enterprise High Performance Computing 15-LTSS (aarch64 x86_64):

nodejs10-10.19.0-1.18.1
nodejs10-debuginfo-10.19.0-1.18.1
nodejs10-debugsource-10.19.0-1.18.1
nodejs10-devel-10.19.0-1.18.1
npm10-10.19.0-1.18.1

- SUSE Linux Enterprise High Performance Computing 15-LTSS (noarch):

nodejs10-docs-10.19.0-1.18.1

- SUSE Linux Enterprise High Performance Computing 15-ESPOS (aarch64
x86_64):

nodejs10-10.19.0-1.18.1
nodejs10-debuginfo-10.19.0-1.18.1
nodejs10-debugsource-10.19.0-1.18.1
nodejs10-devel-10.19.0-1.18.1
npm10-10.19.0-1.18.1

- SUSE Linux Enterprise High Performance Computing 15-ESPOS (noarch):

nodejs10-docs-10.19.0-1.18.1


References:

https://www.suse.com/security/cve/CVE-2019-15604.html
https://www.suse.com/security/cve/CVE-2019-15605.html
https://www.suse.com/security/cve/CVE-2019-15606.html
https://bugzilla.suse.com/1163102
https://bugzilla.suse.com/1163103
https://bugzilla.suse.com/1163104

_______________________________________________
sle-security-updates mailing list
sle-security-updates@lists.suse.com
http://lists.suse.com/mailman/listinfo/sle-security-updates
Pro-Linux
Pro-Linux @Facebook
Neue Nachrichten
Werbung