Login
Newsletter
Werbung

Sicherheit: Mehrere Probleme in squid
Aktuelle Meldungen Distributionen
Name: Mehrere Probleme in squid
ID: SUSE-SU-2020:0493-1
Distribution: SUSE
Plattformen: SUSE Linux Enterprise Module for Server Applications 15-SP1
Datum: Mi, 26. Februar 2020, 21:23
Referenzen: https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2020-8449
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-12528
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2020-8517
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2020-8450
Applikationen: Squid

Originalnachricht


SUSE Security Update: Security update for squid
______________________________________________________________________________

Announcement ID: SUSE-SU-2020:0493-1
Rating: moderate
References: #1162687 #1162689 #1162691
Cross-References: CVE-2019-12528 CVE-2020-8449 CVE-2020-8450
CVE-2020-8517
Affected Products:
SUSE Linux Enterprise Module for Server Applications 15-SP1
______________________________________________________________________________

An update that fixes four vulnerabilities is now available.

Description:

This update for squid to version 4.10 fixes the following issues:

Security issues fixed:

- CVE-2019-12528: Fixed an information disclosure flaw in the FTP gateway
(bsc#1162689).
- CVE-2020-8449: Fixed a buffer overflow when squid is acting as
reverse-proxy (bsc#1162687).
- CVE-2020-8450: Fixed a buffer overflow when squid is acting as
reverse-proxy (bsc#1162687).
- CVE-2020-8517: Fixed a buffer overflow in ext_lm_group_acl when
processing NTLM Authentication credentials (bsc#1162691).

Non-security issue fixed:

- Improved cache handling with chunked responses.


Patch Instructions:

To install this SUSE Security Update use the SUSE recommended installation
methods
like YaST online_update or "zypper patch".

Alternatively you can run the command listed for your product:

- SUSE Linux Enterprise Module for Server Applications 15-SP1:

zypper in -t patch SUSE-SLE-Module-Server-Applications-15-SP1-2020-493=1



Package List:

- SUSE Linux Enterprise Module for Server Applications 15-SP1 (aarch64
ppc64le s390x x86_64):

squid-4.10-5.14.1
squid-debuginfo-4.10-5.14.1
squid-debugsource-4.10-5.14.1


References:

https://www.suse.com/security/cve/CVE-2019-12528.html
https://www.suse.com/security/cve/CVE-2020-8449.html
https://www.suse.com/security/cve/CVE-2020-8450.html
https://www.suse.com/security/cve/CVE-2020-8517.html
https://bugzilla.suse.com/1162687
https://bugzilla.suse.com/1162689
https://bugzilla.suse.com/1162691

_______________________________________________
sle-security-updates mailing list
sle-security-updates@lists.suse.com
http://lists.suse.com/mailman/listinfo/sle-security-updates
Pro-Linux
Pro-Linux @Facebook
Neue Nachrichten
Werbung