Login
Newsletter
Werbung

Sicherheit: Mangelnde Rechteprüfung in postgresql10
Aktuelle Meldungen Distributionen
Name: Mangelnde Rechteprüfung in postgresql10
ID: openSUSE-SU-2020:0331-1
Distribution: SUSE
Plattformen: SUSE openSUSE Leap 15.1
Datum: Mi, 11. März 2020, 07:21
Referenzen: https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2020-1720
Applikationen: PostgreSQL

Originalnachricht

   openSUSE Security Update: Security update for postgresql10
______________________________________________________________________________

Announcement ID: openSUSE-SU-2020:0331-1
Rating: low
References: #1163985
Cross-References: CVE-2020-1720
Affected Products:
openSUSE Leap 15.1
______________________________________________________________________________

An update that fixes one vulnerability is now available.

Description:

This update for postgresql10 fixes the following issues:

PostgreSQL was updated to version 10.12.

Security issue fixed:

- CVE-2020-1720: Fixed a missing authorization check in the ALTER ...
DEPENDS ON extension (bsc#1163985).

This update was imported from the SUSE:SLE-15:Update update project.


Patch Instructions:

To install this openSUSE Security Update use the SUSE recommended
installation methods
like YaST online_update or "zypper patch".

Alternatively you can run the command listed for your product:

- openSUSE Leap 15.1:

zypper in -t patch openSUSE-2020-331=1



Package List:

- openSUSE Leap 15.1 (i586 x86_64):

libecpg6-10.12-lp151.2.9.1
libecpg6-debuginfo-10.12-lp151.2.9.1
libpq5-10.12-lp151.2.9.1
libpq5-debuginfo-10.12-lp151.2.9.1
postgresql10-10.12-lp151.2.9.1
postgresql10-contrib-10.12-lp151.2.9.1
postgresql10-contrib-debuginfo-10.12-lp151.2.9.1
postgresql10-debuginfo-10.12-lp151.2.9.1
postgresql10-debugsource-10.12-lp151.2.9.1
postgresql10-devel-10.12-lp151.2.9.1
postgresql10-devel-debuginfo-10.12-lp151.2.9.1
postgresql10-plperl-10.12-lp151.2.9.1
postgresql10-plperl-debuginfo-10.12-lp151.2.9.1
postgresql10-plpython-10.12-lp151.2.9.1
postgresql10-plpython-debuginfo-10.12-lp151.2.9.1
postgresql10-pltcl-10.12-lp151.2.9.1
postgresql10-pltcl-debuginfo-10.12-lp151.2.9.1
postgresql10-server-10.12-lp151.2.9.1
postgresql10-server-debuginfo-10.12-lp151.2.9.1
postgresql10-test-10.12-lp151.2.9.1

- openSUSE Leap 15.1 (noarch):

postgresql10-docs-10.12-lp151.2.9.1

- openSUSE Leap 15.1 (x86_64):

libecpg6-32bit-10.12-lp151.2.9.1
libecpg6-32bit-debuginfo-10.12-lp151.2.9.1
libpq5-32bit-10.12-lp151.2.9.1
libpq5-32bit-debuginfo-10.12-lp151.2.9.1


References:

https://www.suse.com/security/cve/CVE-2020-1720.html
https://bugzilla.suse.com/1163985

--
To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@opensuse.org
For additional commands, e-mail: opensuse-security-announce+help@opensuse.org
Pro-Linux
Pro-Linux @Facebook
Neue Nachrichten
Werbung