Login
Newsletter
Werbung

Sicherheit: Pufferüberlauf in Nagios
Aktuelle Meldungen Distributionen
Name: Pufferüberlauf in Nagios
ID: 200605-07
Distribution: Gentoo
Plattformen: Keine Angabe
Datum: So, 7. Mai 2006, 20:35
Referenzen: http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-2162
Applikationen: Nagios

Originalnachricht

--nextPart3344695.05sqWyjtLS
Content-Type: text/plain;
charset="us-ascii"
Content-Transfer-Encoding: 7bit
Content-Disposition: inline

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory GLSA 200605-07
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Severity: High
Title: Nagios: Buffer overflow
Date: May 07, 2006
Bugs: #132159
ID: 200605-07

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

Nagios is vulnerable to a buffer overflow which may lead to remote
execution of arbitrary code.

Background
==========

Nagios is an open source host, service and network monitoring program.

Affected packages
=================

-------------------------------------------------------------------
Package / Vulnerable / Unaffected
-------------------------------------------------------------------
1 net-analyzer/nagios-core < 1.4 >= 1.4

Description
===========

Sebastian Krahmer of the SuSE security team discovered a buffer
overflow vulnerability in the handling of a negative HTTP
Content-Length header.

Impact
======

A buffer overflow in Nagios CGI scripts under certain web servers
allows remote attackers to execute arbitrary code via a negative
content length HTTP header.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All Nagios users should upgrade to the latest version:

# emerge --sync
# emerge --ask --oneshot --verbose
">=net-analyzer/nagios-core-1.4"

References
==========

[ 1 ] CVE-2006-2162
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-2162

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

http://security.gentoo.org/glsa/glsa-200605-07.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
http://bugs.gentoo.org.

License
=======

Copyright 2006 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.0

--nextPart3344695.05sqWyjtLS
Content-Type: application/pgp-signature

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.2.2 (GNU/Linux)

iD8DBQBEXju8zKC5hMHO6rkRAhjEAJ96mna8AESjmCPGiAZBx4dYocHk2gCfYZMh
kCTfrHf7EvVZALw792yS5Pk=
=xdMG
-----END PGP SIGNATURE-----

--nextPart3344695.05sqWyjtLS--
--
gentoo-announce@gentoo.org mailing list
Pro-Linux
Traut euch!
Neue Nachrichten
Werbung