Login
Newsletter
Werbung

Sicherheit: Zwei Probleme in ldns
Aktuelle Meldungen Distributionen
Name: Zwei Probleme in ldns
ID: SUSE-SU-2020:0801-1
Distribution: SUSE
Plattformen: SUSE Linux Enterprise Module for Open Buildservice Development Tools 15-SP1, SUSE Linux Enterprise Module for Basesystem 15-SP1, SUSE Linux Enterprise Module for Development Tools 15-SP1
Datum: Do, 26. März 2020, 21:53
Referenzen: https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-1000231
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-1000232
Applikationen: ldns

Originalnachricht


SUSE Security Update: Security update for ldns
______________________________________________________________________________

Announcement ID: SUSE-SU-2020:0801-1
Rating: moderate
References: #1068709 #1068711
Cross-References: CVE-2017-1000231 CVE-2017-1000232
Affected Products:
SUSE Linux Enterprise Module for Open Buildservice
Development Tools 15-SP1
SUSE Linux Enterprise Module for Development Tools 15-SP1
SUSE Linux Enterprise Module for Basesystem 15-SP1
______________________________________________________________________________

An update that fixes two vulnerabilities is now available.

Description:

This update for ldns fixes the following issues:

- CVE-2017-1000231: Fixed a buffer overflow during token parsing
(bsc#1068711).
- CVE-2017-1000232: Fixed a double-free vulnerability in str2host.c
(bsc#1068709).


Patch Instructions:

To install this SUSE Security Update use the SUSE recommended installation
methods
like YaST online_update or "zypper patch".

Alternatively you can run the command listed for your product:

- SUSE Linux Enterprise Module for Open Buildservice Development Tools
15-SP1:

zypper in -t patch
SUSE-SLE-Module-Development-Tools-OBS-15-SP1-2020-801=1

- SUSE Linux Enterprise Module for Development Tools 15-SP1:

zypper in -t patch SUSE-SLE-Module-Development-Tools-15-SP1-2020-801=1

- SUSE Linux Enterprise Module for Basesystem 15-SP1:

zypper in -t patch SUSE-SLE-Module-Basesystem-15-SP1-2020-801=1



Package List:

- SUSE Linux Enterprise Module for Open Buildservice Development Tools
15-SP1 (aarch64 ppc64le s390x x86_64):

ldns-1.7.0-4.3.1
ldns-debuginfo-1.7.0-4.3.1
ldns-debugsource-1.7.0-4.3.1
python3-ldns-1.7.0-4.3.1
python3-ldns-debuginfo-1.7.0-4.3.1

- SUSE Linux Enterprise Module for Development Tools 15-SP1 (aarch64 ppc64le
s390x x86_64):

ldns-debuginfo-1.7.0-4.3.1
ldns-debugsource-1.7.0-4.3.1
perl-DNS-LDNS-1.7.0-4.3.1
perl-DNS-LDNS-debuginfo-1.7.0-4.3.1

- SUSE Linux Enterprise Module for Basesystem 15-SP1 (aarch64 ppc64le s390x
x86_64):

ldns-debuginfo-1.7.0-4.3.1
ldns-debugsource-1.7.0-4.3.1
ldns-devel-1.7.0-4.3.1
libldns2-1.7.0-4.3.1
libldns2-debuginfo-1.7.0-4.3.1


References:

https://www.suse.com/security/cve/CVE-2017-1000231.html
https://www.suse.com/security/cve/CVE-2017-1000232.html
https://bugzilla.suse.com/1068709
https://bugzilla.suse.com/1068711

_______________________________________________
sle-security-updates mailing list
sle-security-updates@lists.suse.com
http://lists.suse.com/mailman/listinfo/sle-security-updates
Pro-Linux
Pro-Linux @Twitter
Neue Nachrichten
Werbung